zoj 3469

2024-03-24 07:38
文章标签 zoj 3469

本文主要是介绍zoj 3469,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

原题:
When we are focusing on solving problems, we usually prefer to stay in front of computers rather than go out for lunch. At this time, we may call for food delivery.

Suppose there are N people living in a straight street that is just lies on an X-coordinate axis. The ith person’s coordinate is Xi meters. And in the street there is a take-out restaurant which has coordinates X meters. One day at lunchtime, each person takes an order from the restaurant at the same time. As a worker in the restaurant, you need to start from the restaurant, send food to the N people, and then come back to the restaurant. Your speed is V-1 meters per minute.

You know that the N people have different personal characters; therefore they have different feeling on the time their food arrives. Their feelings are measured by Displeasure Index. At the beginning, the Displeasure Index for each person is 0. When waiting for the food, the ith person will gain Bi Displeasure Index per minute.

If one’s Displeasure Index goes too high, he will not buy your food any more. So you need to keep the sum of all people’s Displeasure Index as low as possible in order to maximize your income. Your task is to find the minimal sum of Displeasure Index.

Input

The input contains multiple test cases, separated with a blank line. Each case is started with three integers N ( 1 <= N <= 1000 ), V ( V > 0), X ( X >= 0 ), then N lines followed. Each line contains two integers Xi ( Xi >= 0 ), Bi ( Bi >= 0), which are described above.

You can safely assume that all numbers in the input and output will be less than 2^31 - 1.

Please process to the end-of-file.

Output

For each test case please output a single number, which is the minimal sum of Displeasure Index. One test case per line.

Sample Input

5 1 0
1 1
2 2
3 3
4 4
5 5

Sample Output

55

中文:

在一个一维数轴上,你开了一家外卖店,数轴上还有居民,你现在需要给不同位置的居民送餐,你的送餐速度是v,每户居民有两个值,分别是在数轴上的坐标xi和容忍度bi,居民的容忍度每隔一分钟上涨bi,求全部居民送餐后,总的容忍度最小。

代码:

#include<bits/stdc++.h>using namespace std;
#define INF 0x3f3f3f3f
#define mem0(x) memset(x,0,sizeof(x))
#define memI(x) memset(x,INF,sizeof(x))
const int maxn = 1002;typedef pair<int,int> pii;
pii ps[maxn];
int n,v,x;
int dp[maxn][maxn][2];
int sum[maxn];int main()
{ios::sync_with_stdio(false);while(cin>>n>>v>>x){for(int i=1;i<=n;i++)cin>>ps[i].first>>ps[i].second;ps[++n].first=x;ps[n].second=0;sort(ps+1,ps+1+n,[](const pii& p1,const pii &p2){ return p1.first<p2.first;});mem0(sum);memI(dp);int start;for(int i = 1;i<=n;++i){sum[i]=sum[i-1]+ps[i].second;if(ps[i].first==x)start=i;}dp[start][start][0]=dp[start][start][1]=0;for(int i = start;i>=1;i--){for(int j=start;j<=n;++j){if(i==j)continue;dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[n]-sum[j]+sum[i])*(ps[i+1].first-ps[i].first));dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[n]-sum[j]+sum[i])*(ps[j].first-ps[i].first));dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(sum[n]-sum[j-1]+sum[i-1])*(ps[j].first-ps[i].first));dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(sum[n]-sum[j-1]+sum[i-1])*(ps[j].first-ps[j-1].first));}}cout<<v*min(dp[1][n][0],dp[1][n][1])<<endl;}return 0;
}

思路:

太笨,自己没想出来,想出来个思路还是错的 -_-

首先没想出来为什么这题为什么可以使用区间模型去求解,要不是做的是区间dp的练习场,自己肯定不会把这个题目想到区间dp模型上去。

另外,此题的状态设置与一般的状态设置有些区别,本题目状态方程为
d p [ i ] [ j ] [ 2 ] dp[i][j][2] dp[i][j][2]表示在区间i到j这段区间送餐完成后,留在左侧或右侧的全局容忍度和最小,从状态转移方程就能看出来,与一般的dp状态转移方程表达的结果不同。

这题为什么可以用区间dp来解答?
个人理解关键在于如何描述这个送货员的状态,送货员在每次送餐后一定是停留在刚送完的餐的位置,那么有两种可能,一种是从相邻的位置坐标到最终位置;另一种是从较远的位置送来,即刚刚送完餐后折返到另一头。
所以需要使用区间dp来描述状态

那么状态转移方程可以表示如下
其中 d p [ i ] [ j ] 0 ] dp[i][j]0] dp[i][j]0]表示在区间i到j送餐完成后留在左端点i的全局最小容忍度,那么转移状态按照上面说的有两种,一种是从i+1到i 另一种是从j到i,对应的状态转移表达式如下
d p [ i ] [ j ] [ 0 ] = m i n ( d p [ i ] [ j ] [ 0 ] , d p [ i + 1 ] [ j ] [ 0 ] + ( s u m [ n ] − s u m [ j ] + s u m [ i ] ) ∗ ( p s [ i + 1 ] . f i r s t − p s [ i ] . f i r s t ) ) dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[n]-sum[j]+sum[i])*(ps[i+1].first-ps[i].first)) dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][0]+(sum[n]sum[j]+sum[i])(ps[i+1].firstps[i].first))
d p [ i ] [ j ] [ 0 ] = m i n ( d p [ i ] [ j ] [ 0 ] , d p [ i + 1 ] [ j ] [ 1 ] + ( s u m [ n ] − s u m [ j ] + s u m [ i ] ) ∗ ( p s [ j ] . f i r s t − p s [ i ] . f i r s t ) ) dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[n]-sum[j]+sum[i])*(ps[j].first-ps[i].first)) dp[i][j][0]=min(dp[i][j][0],dp[i+1][j][1]+(sum[n]sum[j]+sum[i])(ps[j].firstps[i].first))
同理留在右端点
d p [ i ] [ j ] [ 1 ] = m i n ( d p [ i ] [ j ] [ 1 ] , d p [ i ] [ j − 1 ] [ 0 ] + ( s u m [ n ] − s u m [ j − 1 ] + s u m [ i − 1 ] ) ∗ ( p s [ j ] . f i r s t − p s [ i ] . f i r s t ) ) dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][0]+(sum[n]-sum[j-1]+sum[i-1])*(ps[j].first-ps[i].first)) dp[i][j][1]=min(dp[i][j][1],dp[i][j1][0]+(sum[n]sum[j1]+sum[i1])(ps[j].firstps[i].first))
d p [ i ] [ j ] [ 1 ] = m i n ( d p [ i ] [ j ] [ 1 ] , d p [ i ] [ j − 1 ] [ 1 ] + ( s u m [ n ] − s u m [ j − 1 ] + s u m [ i − 1 ] ) ∗ ( p s [ j ] . f i r s t − p s [ j − 1 ] . f i r s t ) ) dp[i][j][1]=min(dp[i][j][1],dp[i][j-1][1]+(sum[n]-sum[j-1]+sum[i-1])*(ps[j].first-ps[j-1].first)) dp[i][j][1]=min(dp[i][j][1],dp[i][j1][1]+(sum[n]sum[j1]+sum[i1])(ps[j].firstps[j1].first))

这篇关于zoj 3469的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/840897

相关文章

数论ZOJ 2562

题意:给定一个数N,求小于等于N的所有数当中,约数最多的一个数,如果存在多个这样的数,输出其中最大的一个。 分析:反素数定义:对于任何正整数x,其约数的个数记做g(x).例如g(1)=1,g(6)=4.如果某个正整数x满足:对于任意i(0<i<x),都有g(i)<g(x),则称x为反素数。 性质一:一个反素数的质因子必然是从2开始连续的质数。 性质二:p=2^t1*3^t2*5^t3*7

zoj 1721 判断2条线段(完全)相交

给出起点,终点,与一些障碍线段。 求起点到终点的最短路。 枚举2点的距离,然后最短路。 2点可达条件:没有线段与这2点所构成的线段(完全)相交。 const double eps = 1e-8 ;double add(double x , double y){if(fabs(x+y) < eps*(fabs(x) + fabs(y))) return 0 ;return x + y ;

zoj 4624

题目分析:有两排灯,每排n个,每个灯亮的概率为p,每个灯之间互不影响,亮了的灯不再灭,问两排中,每排有大于等于m个灯亮的概率。 设dp[ i ][ j ]为第一排亮了i个灯,第二排亮了j个灯,距离目标状态的期望天数。显然 i >= m ,j >= m时 , dp[ i ][ j ] = 0 。 状态转移 : 第一排亮了a个灯,a 在[ 0 , n - i] 之间,第二排亮了b个灯 , b 在

zoj 3228 ac自动机

给出一个字符串和若干个单词,问这些单词在字符串里面出现了多少次。单词前面为0表示这个单词可重叠出现,1为不可重叠出现。 Sample Input ab 2 0 ab 1 ab abababac 2 0 aba 1 aba abcdefghijklmnopqrstuvwxyz 3 0 abc 1 def 1 jmn Sample Output Case 1 1 1 Case 2

ZOJ Monthly, August 2014小记

最近太忙太忙,只能抽时间写几道简单题。不过我倒是明白要想水平提高不看题解是最好的了。 A  我只能死找规律了,无法证明 int a[50002][2] ;vector< vector<int> > gmax , gmin ;int main(){int n , i , j , k , cmax , cmin ;while(cin>>n){/* g

ZOJ 3324 Machine(线段树区间合并)

这道题网上很多代码是错误的,由于后台数据水,他们可以AC。 比如这组数据 10 3 p 0 9 r 0 5 r 6 9 输出应该是 0 1 1 所以有的人直接记录该区间是否被覆盖过的方法是错误的 正确方法应该是记录这段区间的最小高度(就是最接近初始位置的高度),和最小高度对应的最长左区间和右区间 开一个sum记录这段区间最小高度的块数,min_v 记录该区间最小高度 cover

【ZOJ】3362 Beer Problem 最小费用流

传送门:【ZOJ】3362 Beer Problem 题目分析:这道题本来应该很快就AC的,但是!因为我以前犯的一个致命错误导致我这题一天了到现在才调出来!唉。。失策。。貌似给的模板也有这个错误。。。马上就去改。。但是这个错误竟然还能过掉那么多的题。。害我还要一题一题的改回去。。 本题就是赤裸裸的最小费用流。 新建汇点t(源点即1),将所有的n-1个城市和汇点建边,容量为无穷大,

【ZOJ】2332 Gems 最大流——判断满流

传送门:【ZOJ】2332 Gems 题目分析:首先我们设立源点s,汇点t,s向所有宝石建边,容量为题目中给出的,然后所有可行的转换,向两个宝石之间建无向边,容量为INF,接下来所有的宝石向自己相应的类型建边,容量INF,所有的宝石向自己相应的颜色建边,容量INF。最后,所有的类型以及颜色向汇点建边,容量为题目中给出的。最后跑一遍最大流,如果满流,说明所有的宝石都成功的限制条件下分给了男主

【ZOJ】2532 Internship 最小割——关键割边

传送门:【ZOJ】2532 Internship 题目分析:题目意思很明显,问你能否增加一条边的容量使得流量增加,就是让求关键割边。关键割边怎么求?首先按照题意建图跑一遍最小割。之后在残余网络上进行dfs,将从源点s出发能到的点标记为1,将从汇点t出发能到的点重标记为2。一条边为关键割边当且仅当它为正向边且弧头标记为1,弧尾标记为2。 PS:注意dfs的细节,s出发沿正向残余网络,t出发

【ZOJ】2071 Technology Trader 最大权闭合子图

传送门:【ZOJ】2071 Technology Trader 题目分析:最大权闭合子图问题。源点向订单建边,容量为利益,汇点向组件建边,容量为成本,原图所有边变成容量无穷大的边,最后跑一遍最小割,订单利益和减去最小割容量就是最大净利润。 输出方案就从源点跑一遍dfs,能从源点到达的所有点都标记上。然后看从源点出发的边的弧尾是否被标记,被标记表示被使用,然后再看从汇点出发的点,如果被标记