uva 1626

2024-03-24 07:38
文章标签 uva 1626

本文主要是介绍uva 1626,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

原题:

Let us define a regular brackets sequence in the following way:
1… Empty sequence is a regular sequence.
2 …If S is a regular sequence, then (S) and [S] are both regular sequences.
3…If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:
(), [], (()), ([]), ()[], ()[()]
And all of the following character sequences are not:
(, [, ), )(, ([)], ([]
Some sequence of characters ‘(’, ‘)’, ‘[’, and ‘]’ is given. You are to find the shortest possible
regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string
a 1 a 2 …a n is called a subsequence of the string b 1 b 2 …b m , if there exist such indices 1 ≤ i 1 < i 2 <
… < i n ≤ m, that a j = b i j for all 1 ≤ j ≤ n.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The input file contains at most 100 brackets (characters ‘(’, ‘)’, ‘[’ and ‘]’) that are situated on a
single line without any other characters among them.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases
will be separated by a blank line.
Write to the output file a single line that contains some regular brackets sequence that has the
minimal possible length and contains the given sequence as a subsequence.
Sample Input
1

([(]
Sample Output
()[()]

中文:

给你一堆()[]组成的括号序列,现在让你找出最少插入多少个括号可以将这些括号序列变为合法,并把合法序列输出。

代码:

#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<utility>
#include <iomanip>
#include<climits>
#include<string>
#include<memory>
#include<functional>
#include<stack>
#include<cstring>
using namespace std;typedef long long ll;
const int maxn = 105;
typedef pair<int, int> pii;
typedef pair<int,char> pic;char s[maxn];
int n,dp[maxn][maxn];
bool match(char a,char b)
{if(a=='('&&b==')'||a=='['&&b==']')return true;return false;
}
void print(int i,int j)
{if(i > j)return ;if(i == j){if(s[i]=='('||s[i]==')')cout<<"()";elsecout<<"[]";}int ans = dp[i][j];if(match(s[i],s[j])&&ans == dp[i+1][j-1]){cout<<s[i];print(i+1,j-1);cout<<s[j];return;}for(int k=i;k<j;k++){if(ans == dp[i][k]+dp[k+1][j]){print(i,k);print(k+1,j);return;}}
}void readline(char* S)
{fgets(S, maxn, stdin);
}int main()
{//ios::sync_with_stdio(false);int t;readline(s);sscanf(s, "%d", &t);readline(s);while(t--){readline(s);memset(dp,0,sizeof(dp));int n = strlen(s)-1;for(int i=0;i<n;i++)dp[i][i]=1;for(int i=n-2;i>=0;i--){for(int j=i+1;j<n;j++){dp[i][j]=INT_MAX;if(match(s[i],s[j]))dp[i][j]=min(dp[i][j],dp[i+1][j-1]);for(int k=i;k<j;k++)dp[i][j]=min(dp[i][k]+dp[k+1][j],dp[i][j]);}}print(0,n-1);cout<<endl;if(t)cout<<endl;readline(s);}//system("pause");return 0;
}

思路:

lrj紫书的例题
此题的数据输入和输出格式很让人头疼,格式错了只会提供wa不会出现pe
以书上代码作为参考

思路较为简单,典型的区间dp

d p [ i ] [ j ] dp[i][j] dp[i][j]表示区间最少插入多少个括号可以使得合法。

状态转移方程为
s [ i ] ! = s [ j ] s[i]!=s[j] s[i]!=s[j]
d p [ i ] [ j ] = m a x ( d p [ i ] [ k ] + d p [ k + 1 ] [ j ] , d p [ i ] [ j ] ) dp[i][j]=max(dp[i][k]+dp[k+1][j],dp[i][j]) dp[i][j]=max(dp[i][k]+dp[k+1][j],dp[i][j])

否则
d p [ i ] [ j ] = m a x ( d p [ i + 1 ] [ j − 1 ] , d p [ i ] [ j ] ) dp[i][j]=max(dp[i+1][j-1],dp[i][j]) dp[i][j]=max(dp[i+1][j1],dp[i][j])

这篇关于uva 1626的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/840890

相关文章

uva 10055 uva 10071 uva 10300(水题两三道)

情歌两三首,水题两三道。 好久没敲代码了为暑假大作战热热身。 uva 10055 Hashmat the Brave Warrior 求俩数相减。 两个debug的地方,一个是longlong,一个是输入顺序。 代码: #include<stdio.h>int main(){long long a, b;//debugwhile(scanf("%lld%lld", &

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

uva 10387 Billiard(简单几何)

题意是一个球从矩形的中点出发,告诉你小球与矩形两条边的碰撞次数与小球回到原点的时间,求小球出发时的角度和小球的速度。 简单的几何问题,小球每与竖边碰撞一次,向右扩展一个相同的矩形;每与横边碰撞一次,向上扩展一个相同的矩形。 可以发现,扩展矩形的路径和在当前矩形中的每一段路径相同,当小球回到出发点时,一条直线的路径刚好经过最后一个扩展矩形的中心点。 最后扩展的路径和横边竖边恰好组成一个直

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

uva 568 Just the Facts(n!打表递推)

题意是求n!的末尾第一个不为0的数字。 不用大数,特别的处理。 代码: #include <stdio.h>const int maxn = 10000 + 1;int f[maxn];int main(){#ifdef LOCALfreopen("in.txt", "r", stdin);#endif // LOCALf[0] = 1;for (int i = 1; i <=

uva 575 Skew Binary(位运算)

求第一个以(2^(k+1)-1)为进制的数。 数据不大,可以直接搞。 代码: #include <stdio.h>#include <string.h>const int maxn = 100 + 5;int main(){char num[maxn];while (scanf("%s", num) == 1){if (num[0] == '0')break;int len =

uva 10014 Simple calculations(数学推导)

直接按照题意来推导最后的结果就行了。 开始的时候只做到了第一个推导,第二次没有继续下去。 代码: #include<stdio.h>int main(){int T, n, i;double a, aa, sum, temp, ans;scanf("%d", &T);while(T--){scanf("%d", &n);scanf("%lf", &first);scanf

uva 10916 Factstone Benchmark(打表)

题意是求 k ! <= 2 ^ n ,的最小k。 由于n比较大,大到 2 ^ 20 次方,所以 2 ^ 2 ^ 20比较难算,所以做一些基础的数学变换。 对不等式两边同时取log2,得: log2(k ! ) <=  log2(2 ^ n)= n,即:log2(1) + log2(2) + log2 (3) + log2(4) + ... + log2(k) <= n ,其中 n 为 2 ^

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=