本文主要是介绍uva 1626,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
原题:
Let us define a regular brackets sequence in the following way:
1… Empty sequence is a regular sequence.
2 …If S is a regular sequence, then (S) and [S] are both regular sequences.
3…If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:
(), [], (()), ([]), ()[], ()[()]
And all of the following character sequences are not:
(, [, ), )(, ([)], ([]
Some sequence of characters ‘(’, ‘)’, ‘[’, and ‘]’ is given. You are to find the shortest possible
regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string
a 1 a 2 …a n is called a subsequence of the string b 1 b 2 …b m , if there exist such indices 1 ≤ i 1 < i 2 <
… < i n ≤ m, that a j = b i j for all 1 ≤ j ≤ n.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases
following, each of them as described below. This line is followed by a blank line, and there is also a
blank line between two consecutive inputs.
The input file contains at most 100 brackets (characters ‘(’, ‘)’, ‘[’ and ‘]’) that are situated on a
single line without any other characters among them.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases
will be separated by a blank line.
Write to the output file a single line that contains some regular brackets sequence that has the
minimal possible length and contains the given sequence as a subsequence.
Sample Input
1
([(]
Sample Output
()[()]
中文:
给你一堆()[]组成的括号序列,现在让你找出最少插入多少个括号可以将这些括号序列变为合法,并把合法序列输出。
代码:
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<utility>
#include <iomanip>
#include<climits>
#include<string>
#include<memory>
#include<functional>
#include<stack>
#include<cstring>
using namespace std;typedef long long ll;
const int maxn = 105;
typedef pair<int, int> pii;
typedef pair<int,char> pic;char s[maxn];
int n,dp[maxn][maxn];
bool match(char a,char b)
{if(a=='('&&b==')'||a=='['&&b==']')return true;return false;
}
void print(int i,int j)
{if(i > j)return ;if(i == j){if(s[i]=='('||s[i]==')')cout<<"()";elsecout<<"[]";}int ans = dp[i][j];if(match(s[i],s[j])&&ans == dp[i+1][j-1]){cout<<s[i];print(i+1,j-1);cout<<s[j];return;}for(int k=i;k<j;k++){if(ans == dp[i][k]+dp[k+1][j]){print(i,k);print(k+1,j);return;}}
}void readline(char* S)
{fgets(S, maxn, stdin);
}int main()
{//ios::sync_with_stdio(false);int t;readline(s);sscanf(s, "%d", &t);readline(s);while(t--){readline(s);memset(dp,0,sizeof(dp));int n = strlen(s)-1;for(int i=0;i<n;i++)dp[i][i]=1;for(int i=n-2;i>=0;i--){for(int j=i+1;j<n;j++){dp[i][j]=INT_MAX;if(match(s[i],s[j]))dp[i][j]=min(dp[i][j],dp[i+1][j-1]);for(int k=i;k<j;k++)dp[i][j]=min(dp[i][k]+dp[k+1][j],dp[i][j]);}}print(0,n-1);cout<<endl;if(t)cout<<endl;readline(s);}//system("pause");return 0;
}
思路:
lrj紫书的例题
此题的数据输入和输出格式很让人头疼,格式错了只会提供wa不会出现pe
以书上代码作为参考
思路较为简单,典型的区间dp
设 d p [ i ] [ j ] dp[i][j] dp[i][j]表示区间最少插入多少个括号可以使得合法。
状态转移方程为
当 s [ i ] ! = s [ j ] s[i]!=s[j] s[i]!=s[j]时
d p [ i ] [ j ] = m a x ( d p [ i ] [ k ] + d p [ k + 1 ] [ j ] , d p [ i ] [ j ] ) dp[i][j]=max(dp[i][k]+dp[k+1][j],dp[i][j]) dp[i][j]=max(dp[i][k]+dp[k+1][j],dp[i][j])
否则
d p [ i ] [ j ] = m a x ( d p [ i + 1 ] [ j − 1 ] , d p [ i ] [ j ] ) dp[i][j]=max(dp[i+1][j-1],dp[i][j]) dp[i][j]=max(dp[i+1][j−1],dp[i][j])
这篇关于uva 1626的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!