HDU 1598 find the most comfortable road (Kruskal + 枚举)

2024-03-20 14:38

本文主要是介绍HDU 1598 find the most comfortable road (Kruskal + 枚举),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!


find the most comfortable road

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4181    Accepted Submission(s): 1811

Problem Description
XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ),
但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。

Input
输入包括多个测试实例,每个实例包括:
第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。
接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000
然后是一个正整数Q(Q<11),表示寻路的个数。
接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。

Output
每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。

Sample Input
  
4 4 1 2 2 2 3 4 1 4 1 3 4 2 2 1 3 1 2

Sample Output
  
1 0

Author
ailyanlu

Source
HDU 2007-Spring Programming Contest - Warm Up (1)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1598

题目大意:无向图n个点,m条边,每条边有个权值,q个询问,问x到y权值差的最小值,若x y不连通输出-1

题目分析:先对权值排序,从最小权值开始枚举起点,利用Kruskal求最小生成树,一旦x y连通,则记下此时差值退出从下一起点开始继续找,每次更新差值的最小值


#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int const INF = 0xffffff;
int const MAX = 1005;
int n, m, ans;
int fa[MAX], rank[MAX];
struct Edge
{int u, v, s;
}e[MAX];bool cmp(Edge a, Edge b)
{return a.s < b.s;
}void UFset()
{for(int i = 0; i <= n; i++)fa[i] = i;memset(rank, 0, sizeof(rank));
}int Find(int x)
{return x == fa[x] ? x : fa[x] = Find(fa[x]);
}void Union(int a, int b)
{int r1 = Find(a);int r2 = Find(b);if(r1 == r2)return;if(rank[r1] > rank[r2])fa[r2] = r1;else{fa[r1] = r2;if(rank[r1] == rank[r2])rank[r1]++;}
}void Kruskal(int v0, int x, int y)
{UFset();for(int i = v0; i < m; i++){Union(e[i].u, e[i].v);if(Find(x) == Find(y)){ans = min(ans, e[i].s - e[v0].s);return;}}
}int main()
{while(scanf("%d %d", &n, &m) != EOF){for(int i = 0; i < m; i++)scanf("%d %d %d", &e[i].u, &e[i].v, &e[i].s);sort(e, e + m, cmp);int q, x, y;scanf("%d", &q);while(q--){ans = INF;scanf("%d %d", &x, &y);for(int i = 0; i < m; i++)Kruskal(i, x, y);printf("%d\n", ans == INF ? -1 : ans);}}
}





这篇关于HDU 1598 find the most comfortable road (Kruskal + 枚举)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/829790

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时