poj 1856Sea Battle(BFS ,DFS亦可)

2024-03-15 10:48
文章标签 bfs poj dfs battle 亦可 1856sea

本文主要是介绍poj 1856Sea Battle(BFS ,DFS亦可),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

                终于AC了,眼泪汪汪啊……昨天从晚上11点弄到2点,开始时TL,然后WR……今天早上再看代码,突然发现,有一个等号没写,悲催啊……

这个题的关键在于先找出‘#’围成的最大矩形,然后判断: 矩形内部是否全为‘#’; 左边界的左边,右边界的右边和下边界的下边是否全为‘.’ ;下方两个顶点的对顶点是否为‘.’;

Sea Battle
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 2429 Accepted: 832

Description

During the Summit, the armed forces will be highly active. The police will monitor Prague streets, the army will guard buildings, the Czech air space will be full of American F-16s. Moreover, the ships and battle cruisers will be sent to guard the banks of the Vltava river. Unfortunately, in the case of any incident, the Czech Admiralty have only a few captains able to control over the large sea battle. Therefore, it was decided to educate new admirals. As an excellent preparation, the game of "Sea Battle" was chosen to help with their study program. 

In this well-known game, a predefined number of ships of predefined shapes are placed on the square board in such a way that they cannot contact one another even with their corners. In this task, we will consider rectangular shaped ships only. The unknown number of rectangular ships of unknown sizes are placed on a rectangular board. All the ships are full rectangles built of hash characters. Write a program that counts the total number of ships present in the field. 

Input

The input consists of more scenarios. The description of each scenario begins with two integer numbers R and C separated with a single space, 1 <= R,C <= 1000. These numbers give the number of rows and columns in the game field. 

After these two numbers, there are R lines, each of them containing C characters. Each character is either hash ("#") or dot ("."). Hashes denote ships, dots water. 

Then, the next scenario description begins. At the end of the input, there will be a line containing two zeros instead of the field size. 

Output

Output a single line for every scenario. If the ships were placed correctly (i.e., there are only rectangles that do not touch each other even with a corner), print the sentence "There are S ships." where S is the number of ships. 

Otherwise, print the sentence "Bad placement.". 

Sample Input

6 6
.....#
##...#
##...#
..#..#
.....#
######
6 8
.....#.#
##.....#
##.....#
.......#
#......#
#..#...#
0 0

Sample Output

Bad placement.
There are 5 ships.

代码如下:

#include<stdio.h>
#include<string.h>
int r, c;
char map[1001][1001];
int visited[1001][1001]={0};int BFS(int x, int y)
{int iy=y, jx=x;//找出最大矩形(jx, iy)- (x, y)while(x+1<c && map[iy][x+1]=='#' )x++;while(y+1<r && map[y+1][jx]=='#' )y++;int i ,j;//先判断边界是否符合for(j=jx; j<=x; j++)//矩形的下方{if(y<r-1){if( map[y+1][j]=='#')return 0;}}for(i=iy; i<=y; i++){if(jx>=1)//矩形左边{if( map[i][jx-1]=='#')return 0;}if(x<c-1)//矩形右边{if( map[i][x+1]=='#')return 0;}}//判断矩形内部是否符合for(i=iy; i<=y; i++)for(j=jx; j<=x; j++){if(map[i][j]=='#')visited[i][j]=1;else return 0;}//再判断下方两个个顶点的对顶点if(y<r-1 && jx>=1)//左下角if( map[y+1][jx-1]=='#')return 0;if(y<r-1 && x<c-1)//右下角if( map[y+1][x+1]=='#')return 0;return 1;
}
int main()
{int i, j;int num;int flag;while(scanf("%d %d",&r,&c) && r){getchar();num=0;flag=0;for(i=0; i<r; i++)for(j=0; j<c; j++)visited[i][j]=0;for(i=0; i<r; i++){gets(map[i]);}for(i=0; i<r; i++){if( flag ) break;for(j=0; j<c; j++){if( map[i][j]=='#' && !visited[i][j]){if( BFS(j, i) )num++;else{flag=1;break;}}}}if( flag ) printf("Bad placement.\n");else  printf("There are %d ships.\n",num);}
}


这篇关于poj 1856Sea Battle(BFS ,DFS亦可)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/811709

相关文章

windos server2022里的DFS配置的实现

《windosserver2022里的DFS配置的实现》DFS是WindowsServer操作系统提供的一种功能,用于在多台服务器上集中管理共享文件夹和文件的分布式存储解决方案,本文就来介绍一下wi... 目录什么是DFS?优势:应用场景:DFS配置步骤什么是DFS?DFS指的是分布式文件系统(Distr

hdu1254(嵌套bfs,两次bfs)

/*第一次做这种题感觉很有压力,思路还是有点混乱,总是wa,改了好多次才ac的思路:把箱子的移动当做第一层bfs,队列节点要用到当前箱子坐标(x,y),走的次数step,当前人的weizhi(man_x,man_y),要判断人能否将箱子推到某点时要嵌套第二层bfs(人的移动);代码如下:

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问