本文主要是介绍UVa 10183 How Many Fibs? (统计斐波那契数个数高精度),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
10183 - How Many Fibs?
Time limit: 3.000 seconds
http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=115&page=show_problem&problem=1124
Recall the definition of the Fibonacci numbers:
f 1 := 1Given two numbers a and b , calculate how many Fibonacci numbers are in the range [ a , b ].
f 2 := 2
f n := f n-1 + f n-2 (n>=3)
Input Specification
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a=b=0. Otherwise, a<=b<=10100. The numbers a and b are given with no superfluous leading zeros.
Output Specification
For each test case output on a single line the number of Fibonacci numbers fi with a<=fi<=b.
Sample Input
10 100 1234567890 9876543210 0 0
Sample Output
5 4
先打表,再从头开始枚举判断即可。
完整代码:
/*0.016s*/#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 105;///注意此值的设置要留意中间结果char numstr[maxn], numstr2[maxn]; ///输入输出接口struct bign
{int len, s[maxn];bign(){memset(s, 0, sizeof(s));len = 1;}bign(int num){*this = num;}bign(const char* num){*this = num;}bign operator = (const int num){char s[maxn];sprintf(s, "%d", num);*this = s;return *this;}bign operator = (const char* num){len = strlen(num);for (int i = 0; i < len; i++) s[i] = num[len - i - 1] & 15;return *this;}///输出const char* str() const{if (len){for (int i = 0; i < len; i++)numstr[i] = '0' + s[len - i - 1];numstr[len] = '\0';}else strcpy(numstr, "0");return numstr;}///去前导零void clean(){while (len > 1 && !s[len - 1]) len--;}///加bign operator + (const bign& b) const{bign c;c.len = 0;for (int i = 0, g = 0; g || i < max(len, b.len); i++){int x = g;if (i < len) x += s[i];if (i < b.len) x += b.s[i];c.s[c.len++] = x % 10;g = x / 10;}return c;}///减bign operator - (const bign& b) const{bign c;c.len = 0;for (int i = 0, g = 0; i < len; i++){int x = s[i] - g;if (i < b.len) x -= b.s[i];if (x >= 0) g = 0;else{g = 1;x += 10;}c.s[c.len++] = x;}c.clean();return c;}///乘bign operator * (const bign& b) const{bign c;c.len = len + b.len;for (int i = 0; i < len; i++)for (int j = 0; j < b.len; j++)c.s[i + j] += s[i] * b.s[j];for (int i = 0; i < c.len - 1; i++){c.s[i + 1] += c.s[i] / 10;c.s[i] %= 10;}c.clean();return c;}///除bign operator / (const bign &b) const{bign ret, cur = 0;ret.len = len;for (int i = len - 1; i >= 0; i--){cur = cur * 10;cur.s[0] = s[i];while (cur >= b){cur -= b;ret.s[i]++;}}ret.clean();return ret;}///模、余bign operator % (const bign &b) const{bign c = *this / b;return *this - c * b;}bool operator < (const bign& b) const{if (len != b.len) return len < b.len;for (int i = len - 1; i >= 0; i--)if (s[i] != b.s[i]) return s[i] < b.s[i];return false;}bool operator > (const bign& b) const{return b < *this;}bool operator <= (const bign& b) const{return !(b < *this);}bool operator >= (const bign &b) const{return !(*this < b);}bool operator != (const bign &b) const{return b < *this || *this < b;}bool operator == (const bign& b) const{return !(b < *this) && !(*this < b);}bign operator += (const bign &a){*this = *this + a;return *this;}bign operator -= (const bign &a){*this = *this - a;return *this;}bign operator *= (const bign &a){*this = *this * a;return *this;}bign operator /= (const bign &a){*this = *this / a;return *this;}bign operator %= (const bign &a){*this = *this % a;return *this;}
};bign f[500] = {1, 1};int main()
{bign a, b;int i, j;for (i = 2; i < 500; ++i)f[i] = f[i - 1] + f[i - 2];while (scanf("%s%s", numstr, numstr2), a = numstr, b = numstr2, b != 0){i = 1;while (f[i++] < a);--i;j = i;while (f[j++] <= b);printf("%d\n", j - i - 1);}return 0;
}
/*0.372s*/import java.io.*;
import java.util.*;
import java.math.*;public class Main {static final int maxn = 500;static Scanner cin = new Scanner(new BufferedInputStream(System.in));public static void main(String[] args) {BigInteger[] f = new BigInteger[maxn];f[1] = BigInteger.ONE;f[2] = new BigInteger("2");for (int i = 3; i < maxn; ++i)f[i] = f[i - 1].add(f[i - 2]);while (true) {BigInteger a = cin.nextBigInteger(), b = cin.nextBigInteger();if (b.compareTo(BigInteger.ZERO) == 0)break;int i = 1;while (f[i++].compareTo(a) < 0);--i;int j = i;while (f[j++].compareTo(b) < 1);System.out.println(j - i - 1);}}
}
这篇关于UVa 10183 How Many Fibs? (统计斐波那契数个数高精度)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!