本文主要是介绍hdu 1258 确定比赛名次,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
Input输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
Output给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
Sample Input
4 3 1 2 2 3 4 3Sample Output
1 2 4 3链式向前星存储结构:
#include<iostream>
#include<algorithm>
#include <math.h>
#define maxn 600
#include <queue>
#include <set>
#include <cstring>
#include <cstdio>
using namespace std;
struct node
{int to,w,next;
}edge[maxn];
int first[maxn][2];
int n,m;
int index;
void add(int a,int b)
{edge[index].to=b;edge[index].next=first[a][1];first[a][1]=index++;first[b][0]++;//rudu
}
int main()
{int a,b;while(cin>>n>>m){index=1;set<int>Q;set<int>::iterator it=Q.begin();vector<int>v;memset(first,0,sizeof(first));memset(edge,0,sizeof(edge));for(int i=0;i<m;++i){scanf("%d%d",&a,&b);add(a,b);}/* for(int i=1;i<=n;++i){cout<<i<<' '<<first[i][0];for(int j=first[i][1];j!=0;j=edge[j].next)cout<<' '<<edge[j].to;cout<<endl;}*/for(int i=1;i<=n;++i){if(first[i][0]==0){Q.insert(i);//break;}}int flag=0;while(Q.size()){it=Q.begin();if(flag==0){cout<<*it;flag=1;}else{cout<<' '<<*it;}Q.erase(Q.begin());for(int i=first[*it][1];i;i=edge[i].next){first[edge[i].to][0]--;if(first[edge[i].to][0]==0){Q.insert(edge[i].to);}}}cout<<endl;}return 0;
}
这篇关于hdu 1258 确定比赛名次的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!