《算法笔记》3.4小节——入门模拟-日期处理

2024-02-28 00:38

本文主要是介绍《算法笔记》3.4小节——入门模拟-日期处理,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

《算法笔记》3.4小节——入门模拟->日期处理

问题 A: 日期差值

[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
有两个日期,求两个日期之间的天数,如果两个日期是连续的我们规定他们之间的天数为两天。

输入
有多组数据,每组数据有两行,分别表示两个日期,形式为YYYYMMDD

输出
每组数据输出一行,即日期差值

样例输入 Copy
20130101
20130105
样例输出 Copy
5

程序代码:

#include<cstdio>
int month[13][2] = {{0, 0}, {31, 31}, {28, 29}, {31, 31}, {30, 30}, {31, 31}, {30, 30},{31, 31}, {31, 31}, {30, 30}, {31, 31},{30, 30}, {31, 31}
};
int main()
{int time1,y1,m1,d1;int time2,y2,m2,d2;while(scanf("%d%d",&time1,&time2)!=EOF){if(time1>time2){int temp = time1;time1 = time2;time2 = temp;}y1 = time1 / 10000, m1 = time1 % 10000 / 100, d1 = time1 % 100;		y2 = time2 / 10000, m2 = time2 % 10000 / 100, d2 = time2 % 100;int count = 1;while(y1<y2||m1<m2||d1<d2){d1++;if(d1==month[m1][(y1%4==0&&y1%100!=0)||(y1%400==0)]+1){	m1++;d1=1;}if(m1==13){y1++;m1=1;}count++;}printf("%d\n",count);}return 0;
}	

问题 B: Day of Week

[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
We now use the Gregorian style of dating in Russia. The leap years are years with number divisible by 4 but not divisible by 100, or divisible by 400.
For example, years 2004, 2180 and 2400 are leap. Years 2004, 2181 and 2300 are not leap.
Your task is to write a program which will compute the day of week corresponding to a given date in the nearest past or in the future using today’s agreement about dating.

输入
There is one single line contains the day number d, month name M and year number y(1000≤y≤3000). The month name is the corresponding English name starting from the capital letter.

输出
Output a single line with the English name of the day of week corresponding to the date, starting from the capital letter. All other letters must be in lower case.

样例输入 Copy
21 December 2012
5 January 2013
样例输出 Copy
Friday
Saturday

程序代码:

基姆拉尔森计算公式 [1] (C++与VB.Net整数除法和取余运算符不同)
W= (d+2m+3(m+1)/5+y+y/4-y/100+y/400+1)%7 //C++计算公式
W = (D + 2 * M + 3 * (M + 1) \ 5 + Y + Y \ 4 - Y \ 100 + Y \ 400+1) Mod 7 'VB.Net计算公式
在公式中d表示日期中的日数,m表示月份数,y表示年数。
注意:在公式中有个与其他公式不同的地方:
把一月和二月看成是上一年的十三月和十四月,例:如果是2004-1-10则换算成:2003-13-10来代入公式计算。

#include <cstdio>
#include <cstring>
char month[15][20] = { {}, {"January"}, {"February"}, {"March"}, {"April"}, {"May"}, {"June"}, {"July"}, {"August"}, {"September"}, {"October"}, {"November"}, {"December"}
};
char week[15][20] = { {"Monday"}, {"Tuesday"}, {"Wednesday"}, {"Thursday"}, {"Friday"}, {"Saturday"}, {"Sunday"}
};int main()
{int d, y, k;char m[15];while(scanf("%d %s %d", &d,m,&y)!=EOF) {for(int i=0;i<13;i++) {if(strcmp(month[i],m)==0)	k = i;}	if(k==1||k==2) {					 k += 12;y--;}int j = (d + 2 * k + 3 * (k + 1) / 5 + y + y / 4 - y / 100 + y / 400) % 7;printf("%s\n",week[j]);				 }return 0;
}

问题 C: 打印日期

[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
给出年分m和一年中的第n天,算出第n天是几月几号。

输入
输入包括两个整数y(1<=y<=3000),n(1<=n<=366)。

输出
可能有多组测试数据,对于每组数据,按 yyyy-mm-dd的格式将输入中对应的日期打印出来。

样例输入 Copy
2013 60
2012 300
2011 350
2000 211
样例输出 Copy
2013-03-01
2012-10-26
2011-12-16
2000-07-29

程序代码:

#include<cstdio>
int month[13][2] = {{0, 0}, {31, 31}, {28, 29}, {31, 31}, {30, 30}, {31, 31}, {30, 30},{31, 31}, {31, 31}, {30, 30}, {31, 31},{30, 30}, {31, 31}
};
int main()
{int year,n;while(scanf("%d %d",&year,&n)!=EOF){		int count = 1;int temp = 0,m = 1,d = 1;if((year%4==0&&year%100!=0)||(year%400==0))temp = 1;while(count<n){d++;if(d==month[m][temp]+1){	m++;d=1;}count++;}printf("%04d-%02d-%02d\n",year,m,d);}return 0;
}	

问题 D: 日期类

[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
编写一个日期类,要求按xxxx-xx-xx 的格式输出日期,实现加一天的操作。

输入
输入第一行表示测试用例的个数m,接下来m行每行有3个用空格隔开的整数,分别表示年月日。测试数据不会有闰年。

输出
输出m行。按xxxx-xx-xx的格式输出,表示输入日期的后一天的日期。

样例输入 Copy
2
1999 10 20
2001 1 31
样例输出 Copy
1999-10-21
2001-02-01
提示
注意个位数日期前面要有0。

程序代码:

#include<cstdio>
int month[13] = {0, 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
int main()
{int n;scanf("%d",&n);int y,m,d;for(int i=0;i<n;i++){scanf("%d %d %d",&y,&m,&d);d++;if(d==month[m]+1){m++;d = 1;}printf("%04d-%02d-%02d\n",y,m,d);}return 0;
}

问题 E: 日期累加

[命题人 : 外部导入]
时间限制 : 1.000 sec 内存限制 : 32 MB

题目描述
设计一个程序能计算一个日期加上若干天后是什么日期。

输入
输入第一行表示样例个数m,接下来m行每行四个整数分别表示年月日和累加的天数。

输出
输出m行,每行按yyyy-mm-dd的个数输出。

样例输入 Copy
1
2008 2 3 100
样例输出 Copy
2008-05-13

程序代码:

#include<cstdio>
int month[13][2] = {{0, 0}, {31, 31}, {28, 29}, {31, 31}, {30, 30}, {31, 31}, {30, 30},{31, 31}, {31, 31}, {30, 30}, {31, 31},{30, 30}, {31, 31}
};
int main()
{int n;scanf("%d",&n);while(n--){int y,m,d,num;scanf("%d %d %d %d",&y,&m,&d,&num);int count = 0;while(count<num){d++;if(d==month[m][(y % 400 == 0) || (y % 4 == 0 && y % 100 != 0)]+1){m++;d = 1;}if(m==13){y++;m = 1;}count++;}printf("%04d-%02d-%02d\n", y, m, d);}return 0;
}	

这篇关于《算法笔记》3.4小节——入门模拟-日期处理的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/754012

相关文章

Python FastAPI+Celery+RabbitMQ实现分布式图片水印处理系统

《PythonFastAPI+Celery+RabbitMQ实现分布式图片水印处理系统》这篇文章主要为大家详细介绍了PythonFastAPI如何结合Celery以及RabbitMQ实现简单的分布式... 实现思路FastAPI 服务器Celery 任务队列RabbitMQ 作为消息代理定时任务处理完整

C#使用SQLite进行大数据量高效处理的代码示例

《C#使用SQLite进行大数据量高效处理的代码示例》在软件开发中,高效处理大数据量是一个常见且具有挑战性的任务,SQLite因其零配置、嵌入式、跨平台的特性,成为许多开发者的首选数据库,本文将深入探... 目录前言准备工作数据实体核心技术批量插入:从乌龟到猎豹的蜕变分页查询:加载百万数据异步处理:拒绝界面

Spring Boot + MyBatis Plus 高效开发实战从入门到进阶优化(推荐)

《SpringBoot+MyBatisPlus高效开发实战从入门到进阶优化(推荐)》本文将详细介绍SpringBoot+MyBatisPlus的完整开发流程,并深入剖析分页查询、批量操作、动... 目录Spring Boot + MyBATis Plus 高效开发实战:从入门到进阶优化1. MyBatis

Springboot处理跨域的实现方式(附Demo)

《Springboot处理跨域的实现方式(附Demo)》:本文主要介绍Springboot处理跨域的实现方式(附Demo),具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不... 目录Springboot处理跨域的方式1. 基本知识2. @CrossOrigin3. 全局跨域设置4.

Spring Boot 3.4.3 基于 Spring WebFlux 实现 SSE 功能(代码示例)

《SpringBoot3.4.3基于SpringWebFlux实现SSE功能(代码示例)》SpringBoot3.4.3结合SpringWebFlux实现SSE功能,为实时数据推送提供... 目录1. SSE 简介1.1 什么是 SSE?1.2 SSE 的优点1.3 适用场景2. Spring WebFlu

SpringBoot实现MD5加盐算法的示例代码

《SpringBoot实现MD5加盐算法的示例代码》加盐算法是一种用于增强密码安全性的技术,本文主要介绍了SpringBoot实现MD5加盐算法的示例代码,文中通过示例代码介绍的非常详细,对大家的学习... 目录一、什么是加盐算法二、如何实现加盐算法2.1 加盐算法代码实现2.2 注册页面中进行密码加盐2.

python+opencv处理颜色之将目标颜色转换实例代码

《python+opencv处理颜色之将目标颜色转换实例代码》OpenCV是一个的跨平台计算机视觉库,可以运行在Linux、Windows和MacOS操作系统上,:本文主要介绍python+ope... 目录下面是代码+ 效果 + 解释转HSV: 关于颜色总是要转HSV的掩膜再标注总结 目标:将红色的部分滤

Python实现自动化接收与处理手机验证码

《Python实现自动化接收与处理手机验证码》在移动互联网时代,短信验证码已成为身份验证、账号注册等环节的重要安全手段,本文将介绍如何利用Python实现验证码的自动接收,识别与转发,需要的可以参考下... 目录引言一、准备工作1.1 硬件与软件需求1.2 环境配置二、核心功能实现2.1 短信监听与获取2.

Java时间轮调度算法的代码实现

《Java时间轮调度算法的代码实现》时间轮是一种高效的定时调度算法,主要用于管理延时任务或周期性任务,它通过一个环形数组(时间轮)和指针来实现,将大量定时任务分摊到固定的时间槽中,极大地降低了时间复杂... 目录1、简述2、时间轮的原理3. 时间轮的实现步骤3.1 定义时间槽3.2 定义时间轮3.3 使用时

Python使用date模块进行日期处理的终极指南

《Python使用date模块进行日期处理的终极指南》在处理与时间相关的数据时,Python的date模块是开发者最趁手的工具之一,本文将用通俗的语言,结合真实案例,带您掌握date模块的六大核心功能... 目录引言一、date模块的核心功能1.1 日期表示1.2 日期计算1.3 日期比较二、六大常用方法详