PAT甲级 1012 The Best Rank------排序

2024-02-14 15:08

本文主要是介绍PAT甲级 1012 The Best Rank------排序,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目描述:
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:
就是一个排序的问题。

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{int id,best;        //存最高名次的下标, 像这种情况,从来都是比存值要来的更有效。int score[4],rank[4];
}stu[2001];
int flag=0;
bool cmp(node a,node b){ return a.score[flag]>b.score[flag];}
int main()
{int n,k,exist[1000000]={0},id;cin>>n>>k;for(int i=0;i<n;i++){scanf("%d %d %d %d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);     // c   m    e     astu[i].score[0]=(stu[i].score[1]+stu[i].score[2]+stu[i].score[3])/3+0.5;}for(int i=0;i<4;i++,flag++){         //flag为了控制排序的    名次排完了,并且存储好了sort(stu,stu+n,cmp);stu[0].rank[i]=1;for(int j=1;j<n;j++)              //这个地方得考虑名次相等的情况if(stu[j].score[i]==stu[j-1].score[i]) stu[j].rank[i]=stu[j-1].rank[i];else stu[j].rank[i]=j+1;}for(int i=0;i<n;i++){               //为了寻找best,找到最高名次的小标int min=n+1;exist[stu[i].id]=i+1;            //这个时候stu数组中的顺序已经确定了,只是为了以后方便定位for(int j=0;j<4;j++)if(stu[i].rank[j]<min){min=stu[i].rank[j];stu[i].best=j;}}char sub[4]={'A','C','M','E'};for(int i=0;i<k;i++){cin>>id;int t=exist[id];if(t) printf("%d %c\n",stu[t-1].rank[stu[t-1].best],sub[stu[t-1].best]);else printf("N/A\n");}/*for(int i=0;i<n;i++)printf("%d %d %d %d %d\n",stu[i].id,stu[i].score[0],stu[i].score[1],stu[i].score[2],stu[i].score[3]);for(int i=0;i<n;i++)printf("%d %d %d %d %d\n",stu[i].id,stu[i].rank[0],stu[i].rank[1],stu[i].rank[2],stu[i].rank[3]);*/return 0;
}

来总结一下:
正如图中的代码所示,代表了这道题写题的一个思路。接下来说一下思路,遇到的问题和感悟。

  • 思路就是:对每个成绩都排序,分别存储每个成绩的名词,在从所有名次中找到最高的名次,然后在输出最高名次的同时,也输出相对应的成绩。(思路很简单,关键在于如何存储,怎样定位!)

  • 首先,这个题这么多的成绩,声明好几个数组肯定是不合适的,而且还不好找,所以就需要定义一个结构体,(如果数量很少就可以使用下标的方法来存储)。既然有四个成绩,就要有四个下标,一一对应,来表示每个成绩的排名。best最有用的地方在于它找出的是最高名次的下标,这样就可以直接定位,而不用再费劲的去查找了。

  • sort函数中的自定义函数cmp中可以放置一个未知数flag,可以在循环中每次对同一类的成绩进行排序,但是flag必须为全局变量,要不然的话,会报错!
    !!! 排序的过程很关键,主要是因为排序是所有的一起换,而不是只换其中的某一项,所以可以放心大胆的换,也可以放心大胆的存储名次。

  • 最后就是exist数组设定,题目当中要求学号的长度为6位,我设置完1000000的长度之后,在我电脑上是运行不了的(估计是申请的空间太大了),所以可以在自己测试的时候,设置小一些,然后在提交的时候再改回去。这个数组的作用主要有两点:
    1)来查找这个id是否存在。
    2)也是最重要的一点,有了学生的id,因为要输出再去遍历结构体数组的话太麻烦了,这个数组就是将学生的id和这个id所在的结构体数组的下标结合在一起(方便在输出的时候直接定位)。

 exist[stu[i].id]=i+1;   

这个题难点不是在排序,而在于定位,定位的两个关键点,一个是best,一个是exist数组。

这篇关于PAT甲级 1012 The Best Rank------排序的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/708830

相关文章

【数据结构】——原来排序算法搞懂这些就行,轻松拿捏

前言:快速排序的实现最重要的是找基准值,下面让我们来了解如何实现找基准值 基准值的注释:在快排的过程中,每一次我们要取一个元素作为枢纽值,以这个数字来将序列划分为两部分。 在此我们采用三数取中法,也就是取左端、中间、右端三个数,然后进行排序,将中间数作为枢纽值。 快速排序实现主框架: //快速排序 void QuickSort(int* arr, int left, int rig

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时

《数据结构(C语言版)第二版》第八章-排序(8.3-交换排序、8.4-选择排序)

8.3 交换排序 8.3.1 冒泡排序 【算法特点】 (1) 稳定排序。 (2) 可用于链式存储结构。 (3) 移动记录次数较多,算法平均时间性能比直接插入排序差。当初始记录无序,n较大时, 此算法不宜采用。 #include <stdio.h>#include <stdlib.h>#define MAXSIZE 26typedef int KeyType;typedef char In

【软考】希尔排序算法分析

目录 1. c代码2. 运行截图3. 运行解析 1. c代码 #include <stdio.h>#include <stdlib.h> void shellSort(int data[], int n){// 划分的数组,例如8个数则为[4, 2, 1]int *delta;int k;// i控制delta的轮次int i;// 临时变量,换值int temp;in

学习记录:js算法(二十八):删除排序链表中的重复元素、删除排序链表中的重复元素II

文章目录 删除排序链表中的重复元素我的思路解法一:循环解法二:递归 网上思路 删除排序链表中的重复元素 II我的思路网上思路 总结 删除排序链表中的重复元素 给定一个已排序的链表的头 head , 删除所有重复的元素,使每个元素只出现一次 。返回 已排序的链表 。 图一 图二 示例 1:(图一)输入:head = [1,1,2]输出:[1,2]示例 2:(图

鸡尾酒排序算法

目录 引言 一、概念 二、算法思想 三、图例解释 1.采用冒泡排序:   2.采用鸡尾酒排序:  3.对比总结 四、算法实现  1.代码实现  2.运行结果 3.代码解释   五、总结 引言 鸡尾酒排序(Cocktail Sort),也被称为双向冒泡排序,是一种改进的冒泡排序算法。它在冒泡排序的基础上进行了优化,通过双向遍历来减少排序时间。今天我们将学习如何在C

快速排序(java代码实现)

简介: 1.采用“分治”的思想,对于一组数据,选择一个基准元素,这里选择中间元素mid 2.通过第一轮扫描,比mid小的元素都在mid左边,比mid大的元素都在mid右边 3.然后使用递归排序这两部分,直到序列中所有数据均有序为止。 public class csdnTest {public static void main(String[] args){int[] arr = {3,

O(n)时间内对[0..n^-1]之间的n个数排序

题目 如何在O(n)时间内,对0到n^2-1之间的n个整数进行排序 思路 把整数转换为n进制再排序,每个数有两位,每位的取值范围是[0..n-1],再进行基数排序 代码 #include <iostream>#include <cmath>using namespace std;int n, radix, length_A, digit = 2;void Print(int *A,

常用排序算法分析

1. 插入排序 1.1 性能分析 时间复杂度O(n^2), 空间复杂度O(1) 排序时间与输入有关:输入的元素个数;元素已排序的程度。 最佳情况,输入数组是已经排好序的数组,运行时间是n的线性函数; 最坏情况,输入数组是逆序,运行时间是n的二次函数。 1.2 核心代码 public void sort(){int temp;for(int i = 1; i<arraytoSort.