本文主要是介绍hdu1875-畅通工程再续(Kruskal ),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
畅通工程再续
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26109 Accepted Submission(s): 8459
Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000
Sample Output
1414.2
oh!
分析
有n个点,则有 n*(n-1) 条边,然后kruskal
#include<iostream>
#include<cstdio>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;const int maxn=110;
int fa[maxn];
void init(){for(int i=0;i<maxn;i++)fa[i]=i;
}
int Find(int x){if(fa[x] == x) return fa[x];else return fa[x]= Find(fa[x]);
}
void Union(int x,int y){int fx=Find(x),fy=Find(y);if(fx != fy)fa[fx] =fy;
}
typedef struct{int st,ed;double cost;
}Edge;
Edge edge[10005];
int cmp(Edge a,Edge b){return a.cost <b.cost;
}int X[110];
int Y[110];
int main(){int T;cin>>T;while(T--){int n;cin>>n;init();for(int i=0;i<n;i++)cin>>X[i]>>Y[i];int m=0;for(int i=0;i <n;i++)for(int j=0;j< n;j++){if( i== j) continue;edge[m].st=i;edge[m].ed=j;edge[m].cost=sqrt( pow( X[i]-X[j],2)+pow(Y[i]-Y[j],2) );// cout<<"cost="<<edge[m].cost<<endl;m++;}// cout<<"m="<<m<<endl;sort(edge,edge+m,cmp);int rst=n;double tot_cost=0;for(int i=0;i<m && rst>1;i++){if(Find(edge[i].st)!= Find(edge[i].ed) && (edge[i].cost>=10 && edge[i].cost <=1000)){Union(edge[i].st,edge[i].ed);rst--;tot_cost +=edge[i].cost;}}// cout<<"rst="<<rst<<endl;if(rst==1)printf("%.1f\n",tot_cost*100);elseprintf("oh!\n");}}
这篇关于hdu1875-畅通工程再续(Kruskal )的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!