本文主要是介绍FatMouse's Trade(猫鼠交易),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1247: FatMouse's Trade
时间限制: 1 Sec 内存限制: 32 MB
提交: 89 解决: 55
您该题的状态:已完成
[提交][状态][讨论版]
题目描述
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
输入
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
输出
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
样例输入
4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1
样例输出
2.286
2.500
#include<cstdio>
#include<algorithm>
using namespace std;
struct off
{
double a;
double b;
double c;
}team[1001];
int cmp(off x,off y)
{
return x.c>y.c;
}
int main()
{
int m,n;
while(scanf("%d %d",&m,&n))
{
if(m==-1&&n==-1)
{
break;
}
int i,j;
for(i=0;i<n;i++)
{
scanf("%lf %lf",&team[i].a,&team[i].b);
team[i].c =team[i].a /team[i].b ;
}
sort(team,team+n,cmp);
double sum=0;
for(i=0;i<n;i++)
{
if(m>team[i].b)
{
m-=team[i].b;
sum+=team[i].a;
}
else
{
sum+=m*team[i].c ;
break;
}
}
printf("%.3lf\n",sum);
}
return 0;
}
这篇关于FatMouse's Trade(猫鼠交易)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!