POJ 1679 The Unique MST(次小生成树之一)

2024-01-25 00:38
文章标签 生成 poj unique mst 1679

本文主要是介绍POJ 1679 The Unique MST(次小生成树之一),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:

  1. V’ = V.
  2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题目大意
对于一个无向图,判断其最小生成树是否唯一,若唯一,输出最小生成树,若不唯一,输出Not Unique!。
解题思路
次小生成数求解,对于无向图,求次小生成树,判断其值是否与最小生成树相等,若相等,则最小生成树不唯一;相反,则唯一。
次小生成树求解思想:
1、先求出最小生成树,在这一过程中,标记出最小生成树包含的边,并且保存在最小生成树中从节点i到节点j路径中的最大边权Max[i][j];
2、选取不在最小生成树中的一条边,添加进去,那么一定会构成一个环,然后除去这个环中边(除了刚添加的边)的最大值(即Max[i][j]),当前仍是无向图的一个生成树且该生成树有可能是次小生成树;
3、重复步骤2,依次将不在最小生成树中的边遍历完之后,得到的最小值便是次小生成树。
这里写图片描述
代码实现

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 207
#define INF 0x3f3f3f3f
int cost[maxn][maxn],used[maxn][maxn];
int pre[maxn],lowcost[maxn];
int Max[maxn][maxn];  //Max[i][j]表示在最小生成树中从i到j的路径中的最大边权
bool vis[maxn];
int n,m,ans;
int Prim()
{memset(vis,0,sizeof(vis));memset(lowcost,INF,sizeof(lowcost));memset(Max,0,sizeof(Max));memset(used,0,sizeof(used));vis[0]=1;                      //先将节点0添加到最小生成树中pre[0]=-1;int an=0;for(int i=1; i<n; i++){lowcost[i]=cost[0][i];pre[i]=0;}for(int i=1; i<n; i++){int Min=INF;int p=-1;for(int j=0; j<n; j++)         //寻找最短的边添加到最小生成树中if(!vis[j]&&Min>lowcost[j]){Min=lowcost[j];p=j;}an+=Min;             //最小生成树的值vis[p]=1;             //将节点p添加到最小生成树中used[p][pre[p]]=used[pre[p]][p]=1;         //标记最小生成树包含的边for(int j=0; j<n; j++){if(vis[j])Max[j][p]=Max[p][j]=max(Max[j][pre[p]],lowcost[p]);else{if(lowcost[j]>cost[j][p])  //更新还未添加到最小生成树中的节点与现有的最小生成树的最短距离{lowcost[j]=cost[j][p];pre[j]=p;}}}}return an;
}
int smst()
{int cnt=INF;for(int i=0; i<n; i++){for(int j=i+1; j<n; j++){if(cost[i][j]!=INF&&!used[i][j])       //添加不在最小生成树的边,减去环中的最大边权,更新次小生成树{cnt=min(cnt,ans+cost[i][j]-Max[i][j]);}}}return cnt;
}
int main()
{int T;int u,v,l;scanf("%d",&T);while(T--){scanf("%d %d",&n,&m);for(int i=0; i<n; i++)       //初始化for(int j=0; j<n; j++){if(i==j) cost[i][j]=0;else cost[i][j]=INF;}for(int i=0; i<m; i++){scanf("%d %d %d",&u,&v,&l);u--,v--;                         //节点从0开始cost[u][v]=cost[v][u]=l;}ans=Prim();           //求最小生成树if(ans==smst())       //求次小生成树进行比较printf("Not Unique!\n");elseprintf("%d\n",ans);}return 0;
}

这篇关于POJ 1679 The Unique MST(次小生成树之一)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/641566

相关文章

AI一键生成 PPT

AI一键生成 PPT 操作步骤 作为一名打工人,是不是经常需要制作各种PPT来分享我的生活和想法。但是,你们知道,有时候灵感来了,时间却不够用了!😩直到我发现了Kimi AI——一个能够自动生成PPT的神奇助手!🌟 什么是Kimi? 一款月之暗面科技有限公司开发的AI办公工具,帮助用户快速生成高质量的演示文稿。 无论你是职场人士、学生还是教师,Kimi都能够为你的办公文

pdfmake生成pdf的使用

实际项目中有时会有根据填写的表单数据或者其他格式的数据,将数据自动填充到pdf文件中根据固定模板生成pdf文件的需求 文章目录 利用pdfmake生成pdf文件1.下载安装pdfmake第三方包2.封装生成pdf文件的共用配置3.生成pdf文件的文件模板内容4.调用方法生成pdf 利用pdfmake生成pdf文件 1.下载安装pdfmake第三方包 npm i pdfma

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问