POJ2886 Who Gets the Most Candies?【线段树 点修改】

2024-01-20 14:38

本文主要是介绍POJ2886 Who Gets the Most Candies?【线段树 点修改】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Who Gets the Most Candies?

http://poj.org/problem?id=2886

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 16835 Accepted: 5298
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3

Source

POJ Monthly--2006.07.30, Sempr

题意

 n个孩子按顺时针排列,每个人手上都有一张牌,牌上有一个数字,从第k个孩子开始出队,出队的孩子卡上数字是val,则从他开始顺时针第val人是下一个出队的,负数则逆时针数那个第val个人,第P个出队的会得到的糖果数是p的因子个数,输出得到最多糖果的人和他的糖果数,如果有多个,则输出最先出队的人。

思路

先打表求出1-500000的因子个数,然后使用线段树,点修改,区间信息为这个区间还剩下多少人。

C++代码

#include<iostream>using namespace std;#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1const int N=500050;char name[N][15];
int val[N];
int f[N];//f[i]=j,表示数i有j个因子 
int sum[N<<2];//打表求f[n] 
void maketable(int n)
{for(int i=1;i<n;i++) f[i]=1;for(int i=2;i<n;i++)for(int j=i;j<n;j+=i)f[j]++;
}int getorder(int n)
{int k=1;for(int i=2;i<=n;i++)if(f[k]<f[i])k=i;return k;
}void pushup(int rt)
{sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}void build(int l,int r,int rt)
{if(l==r){sum[rt]=1;return;}int m=(l+r)>>1;build(ls);build(rs);pushup(rt);
}int update(int num,int l,int r,int rt)
{if(l==r){sum[rt]=0;return l;}int m=(l+r)>>1;int res;if(num<=sum[rt<<1])res=update(num,ls);elseres=update(num-sum[rt<<1],rs);pushup(rt);return res;
}int main()
{int n,k;maketable(N);while(~scanf("%d%d",&n,&k)){for(int i=1;i<=n;i++)scanf("%s%d",name[i],&val[i]);build(1,n,1);int order=getorder(n);//出队次序为 order 的人获得的糖果最多 int pos=0,num=k,total=n,ln=0,rn=0;for(int i=1;i<=order;i++){pos=update(num,1,n,1);total--;ln=num-1;//删除元素左边的人的数量 rn=total-num+1;//删除元素右边的人的数量if(i==order) break;//找到第order个出队的人,跳出//获取下一个出队的人是现在队列中的第num个人,即求num int v=val[pos];//v表示跳跃值 if(v>0){v%=total;if(!v) v=total;if(v<=rn)num=ln+v;elsenum=v-rn;} else{v=-v;v%=total;if(!v) v=total;if(v<=ln)num=ln-v+1;elsenum=total-v+ln+1;}}printf("%s %d\n",name[pos],f[order]); }return 0;
}

 

这篇关于POJ2886 Who Gets the Most Candies?【线段树 点修改】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/626332

相关文章

Python实现无痛修改第三方库源码的方法详解

《Python实现无痛修改第三方库源码的方法详解》很多时候,我们下载的第三方库是不会有需求不满足的情况,但也有极少的情况,第三方库没有兼顾到需求,本文将介绍几个修改源码的操作,大家可以根据需求进行选择... 目录需求不符合模拟示例 1. 修改源文件2. 继承修改3. 猴子补丁4. 追踪局部变量需求不符合很

Linux修改pip和conda缓存路径的几种方法

《Linux修改pip和conda缓存路径的几种方法》在Python生态中,pip和conda是两种常见的软件包管理工具,它们在安装、更新和卸载软件包时都会使用缓存来提高效率,适当地修改它们的缓存路径... 目录一、pip 和 conda 的缓存机制1. pip 的缓存机制默认缓存路径2. conda 的缓

Linux修改pip临时目录方法的详解

《Linux修改pip临时目录方法的详解》在Linux系统中,pip在安装Python包时会使用临时目录(TMPDIR),但默认的临时目录可能会受到存储空间不足或权限问题的影响,所以本文将详细介绍如何... 目录引言一、为什么要修改 pip 的临时目录?1. 解决存储空间不足的问题2. 解决权限问题3. 提

Linux文件名修改方法大全

《Linux文件名修改方法大全》在Linux系统中,文件名修改是一个常见且重要的操作,文件名修改可以更好地管理文件和文件夹,使其更具可读性和有序性,本文将介绍三种在Linux系统下常用的文件名修改方法... 目录一、引言二、使用mv命令修改文件名三、使用rename命令修改文件名四、mv命令和rename命

mybatis-plus 实现查询表名动态修改的示例代码

《mybatis-plus实现查询表名动态修改的示例代码》通过MyBatis-Plus实现表名的动态替换,根据配置或入参选择不同的表,本文主要介绍了mybatis-plus实现查询表名动态修改的示... 目录实现数据库初始化依赖包配置读取类设置 myBATis-plus 插件测试通过 mybatis-plu

Linux下修改hostname的三种实现方式

《Linux下修改hostname的三种实现方式》:本文主要介绍Linux下修改hostname的三种实现方式,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录linux下修改ho编程stname三种方式方法1:修改配置文件方法2:hFvEWEostnamectl命

Git如何修改已提交人的用户名和邮箱

《Git如何修改已提交人的用户名和邮箱》文章介绍了如何修改Git已提交人的用户名和邮箱,包括注意事项和具体步骤,确保操作正确无误... 目录git修改已提交人的用户名和邮箱前言第一步第二步总结git修改已提交人的用户名和邮箱前言需注意以下两点内容:需要在顶层目录下(php就是 .git 文件夹所在的目

修改若依框架Token的过期时间问题

《修改若依框架Token的过期时间问题》本文介绍了如何修改若依框架中Token的过期时间,通过修改`application.yml`文件中的配置来实现,默认单位为分钟,希望此经验对大家有所帮助,也欢迎... 目录修改若依框架Token的过期时间修改Token的过期时间关闭Token的过期时js间总结修改若依

MySQL修改密码的四种实现方式

《MySQL修改密码的四种实现方式》文章主要介绍了如何使用命令行工具修改MySQL密码,包括使用`setpassword`命令和`mysqladmin`命令,此外,还详细描述了忘记密码时的处理方法,包... 目录mysql修改密码四种方式一、set password命令二、使用mysqladmin三、修改u

使用Python在Excel中插入、修改、提取和删除超链接

《使用Python在Excel中插入、修改、提取和删除超链接》超链接是Excel中的常用功能,通过点击超链接可以快速跳转到外部网站、本地文件或工作表中的特定单元格,有效提升数据访问的效率和用户体验,这... 目录引言使用工具python在Excel中插入超链接Python修改Excel中的超链接Python