本文主要是介绍ACM DP Super Jumping! Jumping! Jumping!,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution.Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
Output For each case, print the maximum according to rules, and one line one case.
Sample Input
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0Sample Output
4 10 3
题意:
求出最大上升子序列的和
分析:
模板即可,dp【i】表示到第i个点的最大值,比较i之前的点,看是否比a[i]大,之后求出最大的dp【i】
代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1111],num[1111],n;
int main()
{ int maxx,i,j;
while(scanf("%d",&n)!=EOF)
{
if(n==0)
break;
memset(dp,0,sizeof(dp));
maxx=0;
for(i=1;i<=n;i++)
{
scanf("%d",&num[i]);
}
dp[1]=num[1];
for(i=2;i<=n;i++)
{
for(j=1;j<n;j++)
{
if(num[i]>num[j])
dp[i]=max(dp[i],dp[j]+num[i]);
}
}
for(i=1;i<=n;i++)
maxx=max(dp[i],maxx);
printf("%d\n",maxx);
}
return 0;
}
这篇关于ACM DP Super Jumping! Jumping! Jumping!的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!