本文主要是介绍POJ 1094 Sorting It All Out【拓扑排序】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.Sample Input
4 6 A<B A<C B<C C<D B<D A<B 3 2 A<B B<A 26 1 A<Z 0 0Sample Output
Sorted sequence determined after 4 relations: ABCD. Inconsistency found after 2 relations. Sorted sequence cannot be determined.
题目大意:
给定前 n 个字母,以及一些他们之间的大小关系,求这些字母满足大小关系的一个序列;
在大小关系给定的过程中,如果已经可以满足唯一有序,则可以按顺序输出序列;
如果现有关系是相互矛盾的,则输出发生矛盾的关系的序号;
如果最终关系满足有序,但不满足唯一有序,则输出 序列不能够确定。
解题思路:
一开始居然在思考 一笔画问题,后来发现,关系出现矛盾,即在拓扑排序中发现环,才立刻转上了拓扑排序的车。
这个的输入数据可以不完全采纳,感觉有点麻烦,加一个标记变量即可。
则,每一组新的关系加入,就进行一次拓扑排序:【拓扑排序:https://blog.csdn.net/sodacoco/article/details/86586881】
1》如果出现环,则可以结束,关系相互矛盾;
2》如果已经可以唯一有序,则可以结束,输出这个序列;
3》所有关系都已经输入,还未产生以上两种结果,则关系无法确定;
代码实现:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int Map[30][30],in[30],que[30];int topu(int n){int ru0,dian,flag=1;int tempIn[30],queNum=0;for(int i=1;i<=n;i++)tempIn[i]=in[i];for(int i=1;i<=n;i++){ru0=0;for(int j=1;j<=n;j++){if(tempIn[j]==0){ru0++; dian=j; //下一个入栈的点}}if(ru0==0) return 0; //对于现阶段的子图来说存在环if(ru0>1) flag=-1; //对于现阶段的子图来说,有多个入度为0的点que[++queNum]=dian; //入数组tempIn[dian]=-1;for(int j=1;j<=n;j++)if(Map[dian][j]==1)tempIn[j]--;}return flag;
}
int main(){int n,m,biao=0;char ch1,ch2;while(scanf("%d%d",&n,&m)&&(n+m)!=0){getchar();memset(Map,0,sizeof(Map));memset(in,0,sizeof(in));biao=0;for(int i=1;i<=m;i++){ch1=getchar(); getchar();ch2=getchar(); getchar();if(biao==1)continue;int x=ch1-'A'+1;int y=ch2-'A'+1;Map[x][y]=1; in[y]++;int ans=topu(n);if(ans==0){ //有环printf("Inconsistency found after %d relations.\n",i);biao=1;}if(ans==1){ //有序printf("Sorted sequence determined after %d relations: ",i);for(int j=1;j<=n;j++) printf("%c",que[j]+'A'-1);printf(".\n");biao=1;}}if(!biao) //不确定printf("Sorted sequence cannot be determined.\n");}return 0;
}
这篇关于POJ 1094 Sorting It All Out【拓扑排序】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!