POJ 1094 Sorting It All Out【拓扑排序】

2024-01-17 00:32
文章标签 排序 poj 拓扑 sorting 1094

本文主要是介绍POJ 1094 Sorting It All Out【拓扑排序】,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目:

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题目大意:

       给定前 n 个字母,以及一些他们之间的大小关系,求这些字母满足大小关系的一个序列;

       在大小关系给定的过程中,如果已经可以满足唯一有序,则可以按顺序输出序列;

       如果现有关系是相互矛盾的,则输出发生矛盾的关系的序号;

       如果最终关系满足有序,但不满足唯一有序,则输出 序列不能够确定。

解题思路:

      一开始居然在思考 一笔画问题,后来发现,关系出现矛盾,即在拓扑排序中发现环,才立刻转上了拓扑排序的车。

     这个的输入数据可以不完全采纳,感觉有点麻烦,加一个标记变量即可。

     则,每一组新的关系加入,就进行一次拓扑排序:【拓扑排序:https://blog.csdn.net/sodacoco/article/details/86586881】

            1》如果出现环,则可以结束,关系相互矛盾;

            2》如果已经可以唯一有序,则可以结束,输出这个序列;

            3》所有关系都已经输入,还未产生以上两种结果,则关系无法确定;

代码实现:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int Map[30][30],in[30],que[30];int topu(int n){int ru0,dian,flag=1;int tempIn[30],queNum=0;for(int i=1;i<=n;i++)tempIn[i]=in[i];for(int i=1;i<=n;i++){ru0=0;for(int j=1;j<=n;j++){if(tempIn[j]==0){ru0++; dian=j;  //下一个入栈的点}}if(ru0==0) return 0;    //对于现阶段的子图来说存在环if(ru0>1) flag=-1;      //对于现阶段的子图来说,有多个入度为0的点que[++queNum]=dian;     //入数组tempIn[dian]=-1;for(int j=1;j<=n;j++)if(Map[dian][j]==1)tempIn[j]--;}return flag;
}
int main(){int n,m,biao=0;char ch1,ch2;while(scanf("%d%d",&n,&m)&&(n+m)!=0){getchar();memset(Map,0,sizeof(Map));memset(in,0,sizeof(in));biao=0;for(int i=1;i<=m;i++){ch1=getchar();  getchar();ch2=getchar();  getchar();if(biao==1)continue;int x=ch1-'A'+1;int y=ch2-'A'+1;Map[x][y]=1;  in[y]++;int ans=topu(n);if(ans==0){ //有环printf("Inconsistency found after %d relations.\n",i);biao=1;}if(ans==1){ //有序printf("Sorted sequence determined after %d relations: ",i);for(int j=1;j<=n;j++)   printf("%c",que[j]+'A'-1);printf(".\n");biao=1;}}if(!biao) //不确定printf("Sorted sequence cannot be determined.\n");}return 0;
}

 

这篇关于POJ 1094 Sorting It All Out【拓扑排序】的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/614408

相关文章

【数据结构】——原来排序算法搞懂这些就行,轻松拿捏

前言:快速排序的实现最重要的是找基准值,下面让我们来了解如何实现找基准值 基准值的注释:在快排的过程中,每一次我们要取一个元素作为枢纽值,以这个数字来将序列划分为两部分。 在此我们采用三数取中法,也就是取左端、中间、右端三个数,然后进行排序,将中间数作为枢纽值。 快速排序实现主框架: //快速排序 void QuickSort(int* arr, int left, int rig

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

poj 1502 MPI Maelstrom(单源最短路dijkstra)

题目真是长得头疼,好多生词,给跪。 没啥好说的,英语大水逼。 借助字典尝试翻译了一下,水逼直译求不喷 Description: BIT他们的超级计算机最近交货了。(定语秀了一堆词汇那就省略吧再见) Valentine McKee的研究顾问Jack Swigert,要她来测试一下这个系统。 Valentine告诉Swigert:“因为阿波罗是一个分布式共享内存的机器,所以它的内存访问