本文主要是介绍杭电ACM——1098,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Ignatius's puzzle
问题: Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".
no exists that a,then print "no".
输入:The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.
输出:The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.
示例输入:
11
100
9999
示例输出:
22
no
43
问题分析:
5*x^13+13*x^5+k*a*x可以分成两部分 即 5*x^13+13*x^5 和 k*a*x;
而第一个部分我们可以发现 (5*x^13+13*x^5)% 65 结果会不断循环,循环节为65,而且为等差数列,差为18,则通过数学归纳法证明可得
只要满足(18 + k * x) % 65 == 0即可
代码如下
# include <stdio.h>
int main()
{
int k, flag, x;
while(scanf("%d", &k) != EOF)
{
flag = 0;
for(x = 1; x <= 65; x++)
{
if ((18 + k * x) % 65 == 0)
{
flag = 1;
printf("%d\n", x);
break;
}
}
if (flag == 0)
{
printf("no\n");
}
}
return 0;
}
这篇关于杭电ACM——1098的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!