树状数组Color the ball

2024-01-10 08:18
文章标签 数组 树状 color ball

本文主要是介绍树状数组Color the ball,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1003&ojid=0&cid=601&hide=0

N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
Sample Input
31 12 23 331 11 21 30
Sample Output
1 1 13 2 1

思路:这是一道插线问点的题:

树状数组无非有两种考法:

 1.修改一段区间的值,查找的是某个位上的值。要向上统计,向下修改;即插线问点。

  2.修改某个位置上的值,查找的是一段区间的和。要向上修改,向下统计;即插点问线。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100001;
int d[maxn];
int n;
int lowbit(int i)
{return i&(-i);
}
void update(int i,int x)
{while(i>0){d[i]+=x;i-=lowbit(i);}
}
int get_sum(int i)
{int ret=0;while(i<=n){ret+=d[i];i+=lowbit(i);}return ret;
}
int main()
{int a ,b;while(scanf("%d",&n),n){memset(d,0,sizeof(d));for(int i=1;i<=n;i++){scanf("%d %d",&a,&b);update(b,1);update(a-1,-1);}for(i=1;i<n;i++)printf("%d ",get_sum(i));printf("%d\n",get_sum(n));}return 0;
}

这里就说一道插点问线的题吧!

http://59.69.128.200/JudgeOnline/problem.php?pid=116

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int N;
int aa[1000010];
int lowbit(int i)
{return i&(-i);}
void g(int n,int m)
{  while(n<=N){  aa[n]+=m;n+=lowbit(n);}}
int f(int n)
{  int sum=0;while(n>0){sum+=aa[n];n-=lowbit(n);}return sum;
}
int main()
{  int k;scanf("%d%d",&N,&k);for(int i=1;i<=N;++i){  int t;scanf("%d",&t);g(i,t);}while(k--){  char a[10];scanf("%s",a);int x,y;scanf("%d%d",&x,&y);if(a[0]=='A') g(x,y);else  printf("%d\n",f(y)-f(x-1));}return 0;
}




这篇关于树状数组Color the ball的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/590148

相关文章

JAVA中整型数组、字符串数组、整型数和字符串 的创建与转换的方法

《JAVA中整型数组、字符串数组、整型数和字符串的创建与转换的方法》本文介绍了Java中字符串、字符数组和整型数组的创建方法,以及它们之间的转换方法,还详细讲解了字符串中的一些常用方法,如index... 目录一、字符串、字符数组和整型数组的创建1、字符串的创建方法1.1 通过引用字符数组来创建字符串1.2

vue如何监听对象或者数组某个属性的变化详解

《vue如何监听对象或者数组某个属性的变化详解》这篇文章主要给大家介绍了关于vue如何监听对象或者数组某个属性的变化,在Vue.js中可以通过watch监听属性变化并动态修改其他属性的值,watch通... 目录前言用watch监听深度监听使用计算属性watch和计算属性的区别在vue 3中使用watchE

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

C语言:柔性数组

数组定义 柔性数组 err int arr[0] = {0}; // ERROR 柔性数组 // 常见struct Test{int len;char arr[1024];} // 柔性数组struct Test{int len;char arr[0];}struct Test *t;t = malloc(sizeof(Test) + 11);strcpy(t->arr,

C 语言基础之数组

文章目录 什么是数组数组变量的声明多维数组 什么是数组 数组,顾名思义,就是一组数。 假如班上有 30 个同学,让你编程统计每个人的分数,求最高分、最低分、平均分等。如果不知道数组,你只能这样写代码: int ZhangSan_score = 95;int LiSi_score = 90;......int LiuDong_score = 100;int Zhou

三色标记(Tri-color marking)

维基百科部分 原文 https://en.wikipedia.org/wiki/Tracing_garbage_collection#TRI-COLOR Because of these performance problems, most modern tracing garbage collectors implement some variant of the tri-color ma

计算数组的斜率,偏移,R2

模拟Excel中的R2的计算。         public bool fnCheckRear_R2(List<double[]> lRear, int iMinRear, int iMaxRear, ref double dR2)         {             bool bResult = true;             int n = 0;             dou

C# double[] 和Matlab数组MWArray[]转换

C# double[] 转换成MWArray[], 直接赋值就行             MWNumericArray[] ma = new MWNumericArray[4];             double[] dT = new double[] { 0 };             double[] dT1 = new double[] { 0,2 };

PHP7扩展开发之数组处理

前言 这次,我们将演示如何在PHP扩展中如何对数组进行处理。要实现的PHP代码如下: <?phpfunction array_concat ($arr, $prefix) {foreach($arr as $key => $val) {if (isset($prefix[$key]) && is_string($val) && is_string($prefix[$key])) {$arr[