本文主要是介绍HDU——1028 Ignatius and the Princess III(母函数),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem Description
“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.
“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
解题思路:
近期最后一个母函数练习,这题可以算是母函数的最基础的一个练习了。
代码:
#include <stdio.h>
#include <string.h>
using namespace std;long ways[125];
long temp[125];
int main(){int n , i , j ,k;while(scanf("%d",&n) != EOF){memset(ways , 0 , sizeof(ways));memset(temp , 0 ,sizeof(temp));for(i = 0 ; i <= n ; i++) //只用数字1的情况 ,每个数字都只有一种表现方式ways[i] = 1;for(i = 2 ; i <= n ; i++){ //依次加入可以使用的数字的种类for(j = 0 ; j <= n ; j ++)for(k = 0 ; k + j <= n ; k = k + i){temp[k + j] = temp[k + j] + ways[j];}for(j = 0 ; j <= n ; j++)ways[j] = temp[j];memset(temp , 0 , sizeof(temp));}printf("%ld\n",ways[n]);}return 0;
}
这篇关于HDU——1028 Ignatius and the Princess III(母函数)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!