HDU——1084 What is your grade?(莫名的Wrong Answer)

2023-12-28 14:32
文章标签 hdu answer grade 莫名 wrong 1084

本文主要是介绍HDU——1084 What is your grade?(莫名的Wrong Answer),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Problem Description

“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!

Input

Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0

Output

Output the scores of N students in N lines for each case, and there is a blank line after each case.

Sample Input

4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1

Sample Output

100
90
90
95

100

代码(自己的Wrong Answer 代码):

#include <stdio.h>
#include <algorithm>
using namespace std;typedef struct{int num;int hour;int minute;int sec;int gra;int id;
}Record;bool method1(Record a , Record b){return (b.sec > a.sec);
}bool method2(Record a , Record b){return (b.minute > a.minute);
}bool method3(Record a , Record b){return (b.hour > a.hour);
}bool method(Record a , Record b){return (b.num < a.num);
}bool method4(Record a , Record b){return (b.id > a.id);
}int main()
{int n , i , temp ,j ,k;Record *grade;while(scanf("%d",&n) != EOF){if(n == -1)break;grade = new Record[n];for(i = 0 ; i < n ; i ++){scanf("%d %d:%d:%d",&grade[i].num , &grade[i].hour , &grade[i].minute , &grade[i].sec);grade[i].gra = 0;grade[i].id = i;}sort(grade , grade + n ,method1);sort(grade , grade + n ,method2);sort(grade , grade + n ,method3);sort(grade , grade + n , method);for(i = 0 ; i < n ; i ++){if(grade[i].num == 5)grade[i].gra = 100;elsebreak;}temp = i;for(k = 4 ; i < n  ; k --){if(k >= 1){int count = 0;for(i = temp ; i < n ; i ++){if(grade[i].num == k)count++;elsebreak;}for( j = temp ; j < temp + count/2 ; j ++)grade[j].gra = 100 - (5 - k)*10 + 5;for( j = temp + count/2  ; j < i ; j ++)grade[j].gra = 100 - (5 - k)*10;}else{for(i = temp ; i < n ; i ++){if(grade[i].num == k)grade[i].gra = 100 - (5 - k)*10;elsebreak;}}temp = i;}sort(grade ,grade + n , method4);for(i = 0 ; i < n ; i ++){printf("%d\n",grade[i].gra);}printf("\n");}return 0;
}

疑问:

这段代码一直Wrong Answer ,无奈到网上找了一段AC代码,对比做了好多例子 , 答案也都一样。自己实在找不到哪里错了 ,如果很幸运的被哪位大神看到了这段代码,希望可以告诉我错在哪儿了,那真的是太感谢了。

这篇关于HDU——1084 What is your grade?(莫名的Wrong Answer)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/546267

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时