本文主要是介绍HDU——1084 What is your grade?(莫名的Wrong Answer),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
100
90
90
95
100
代码(自己的Wrong Answer 代码):
#include <stdio.h>
#include <algorithm>
using namespace std;typedef struct{int num;int hour;int minute;int sec;int gra;int id;
}Record;bool method1(Record a , Record b){return (b.sec > a.sec);
}bool method2(Record a , Record b){return (b.minute > a.minute);
}bool method3(Record a , Record b){return (b.hour > a.hour);
}bool method(Record a , Record b){return (b.num < a.num);
}bool method4(Record a , Record b){return (b.id > a.id);
}int main()
{int n , i , temp ,j ,k;Record *grade;while(scanf("%d",&n) != EOF){if(n == -1)break;grade = new Record[n];for(i = 0 ; i < n ; i ++){scanf("%d %d:%d:%d",&grade[i].num , &grade[i].hour , &grade[i].minute , &grade[i].sec);grade[i].gra = 0;grade[i].id = i;}sort(grade , grade + n ,method1);sort(grade , grade + n ,method2);sort(grade , grade + n ,method3);sort(grade , grade + n , method);for(i = 0 ; i < n ; i ++){if(grade[i].num == 5)grade[i].gra = 100;elsebreak;}temp = i;for(k = 4 ; i < n ; k --){if(k >= 1){int count = 0;for(i = temp ; i < n ; i ++){if(grade[i].num == k)count++;elsebreak;}for( j = temp ; j < temp + count/2 ; j ++)grade[j].gra = 100 - (5 - k)*10 + 5;for( j = temp + count/2 ; j < i ; j ++)grade[j].gra = 100 - (5 - k)*10;}else{for(i = temp ; i < n ; i ++){if(grade[i].num == k)grade[i].gra = 100 - (5 - k)*10;elsebreak;}}temp = i;}sort(grade ,grade + n , method4);for(i = 0 ; i < n ; i ++){printf("%d\n",grade[i].gra);}printf("\n");}return 0;
}
疑问:
这段代码一直Wrong Answer ,无奈到网上找了一段AC代码,对比做了好多例子 , 答案也都一样。自己实在找不到哪里错了 ,如果很幸运的被哪位大神看到了这段代码,希望可以告诉我错在哪儿了,那真的是太感谢了。
这篇关于HDU——1084 What is your grade?(莫名的Wrong Answer)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!