UVa 10391 - Compound Words

2023-12-10 04:58
文章标签 words compound uva 10391

本文主要是介绍UVa 10391 - Compound Words,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目链接:

UVa: http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1332

zoj :  http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=825


类型: Hash


原题:

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn



题目大意:

题目很短很简洁,大爱~!  

给出一系列按字典序排好的单词, 把它们看成是一个字典。然后再按字典序输出里面所有的复合词,复合词就是这个单词是由字典中的另外两个单词组成的。


思路与总结:

很自然地可以想到一个思路,就是按顺序直接枚举每一个单词,然后判断这个单词是不是复合词,是的话就输出。

这题的核心就在于怎样判断一个单词是否是复合词,由复合词的定义,可以把单词拆分成两个,枚举一个单词的所有拆分方案,然后再判断是否有拆分的两个单词是否在字典中即可。

题目数据量达到120,000, 所以一定要找到一个快速的判断一个单词是否属于字典集合中的方法。

这是哈希表的超高速作用就凸显出来了。只要给每个单词建立哈希表映射关系, 然后就可以几乎可以是O(1)的时间判断一个单词是否属于字典。 



/** UVa  10391 - Compound Words* 哈希表* Time: 0.020s (UVa)* Author: D_Double*/
#include<iostream>  
#include<cstdio>  
#include<cstring>  
#define MAXN 120003
using namespace std;  
typedef char Word[30];Word word[MAXN];
const int HashSize = MAXN;
int N, head[HashSize], next[HashSize];inline void init_lookup_table(){N=1;  memset(head, 0, sizeof(head));
}inline int hash(char *str){ // 字符串哈希函数int seed = 131;int hash=0;while(*str) hash = hash * seed + (*str++);return (hash & 0x7FFFFFFF) % HashSize;
}int add_hash(int s){int h = hash(word[s]);int u = head[h];while(u) u = next[u];next[s] = head[h];head[h] = s;return 1;
}int search(char *s){int h = hash(s);int u = head[h];while(u){if(strcmp(word[u], s)==0) return u;u = next[u];}return 0;
}int main(){Word str;N = 1;init_lookup_table();while(gets(word[N])){add_hash(N);++N;}// 查询for(int i=1; i<N; ++i)if(word[i][1]){for(int j=0; j<strlen(word[i])-1; ++j){strcpy(str, word[i]);str[j+1] = '\0';if(search(str) && search(word[i]+j+1)){puts(word[i]); break;}} }return 0;
}

——  生命的意义,在于赋予它意义。

 

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)

这篇关于UVa 10391 - Compound Words的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/476072

相关文章

uva 10055 uva 10071 uva 10300(水题两三道)

情歌两三首,水题两三道。 好久没敲代码了为暑假大作战热热身。 uva 10055 Hashmat the Brave Warrior 求俩数相减。 两个debug的地方,一个是longlong,一个是输入顺序。 代码: #include<stdio.h>int main(){long long a, b;//debugwhile(scanf("%lld%lld", &

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D

uva 10387 Billiard(简单几何)

题意是一个球从矩形的中点出发,告诉你小球与矩形两条边的碰撞次数与小球回到原点的时间,求小球出发时的角度和小球的速度。 简单的几何问题,小球每与竖边碰撞一次,向右扩展一个相同的矩形;每与横边碰撞一次,向上扩展一个相同的矩形。 可以发现,扩展矩形的路径和在当前矩形中的每一段路径相同,当小球回到出发点时,一条直线的路径刚好经过最后一个扩展矩形的中心点。 最后扩展的路径和横边竖边恰好组成一个直

uva 10061 How many zero's and how many digits ?(不同进制阶乘末尾几个0)+poj 1401

题意是求在base进制下的 n!的结果有几位数,末尾有几个0。 想起刚开始的时候做的一道10进制下的n阶乘末尾有几个零,以及之前有做过的一道n阶乘的位数。 当时都是在10进制下的。 10进制下的做法是: 1. n阶位数:直接 lg(n!)就是得数的位数。 2. n阶末尾0的个数:由于2 * 5 将会在得数中以0的形式存在,所以计算2或者计算5,由于因子中出现5必然出现2,所以直接一

uva 568 Just the Facts(n!打表递推)

题意是求n!的末尾第一个不为0的数字。 不用大数,特别的处理。 代码: #include <stdio.h>const int maxn = 10000 + 1;int f[maxn];int main(){#ifdef LOCALfreopen("in.txt", "r", stdin);#endif // LOCALf[0] = 1;for (int i = 1; i <=

uva 575 Skew Binary(位运算)

求第一个以(2^(k+1)-1)为进制的数。 数据不大,可以直接搞。 代码: #include <stdio.h>#include <string.h>const int maxn = 100 + 5;int main(){char num[maxn];while (scanf("%s", num) == 1){if (num[0] == '0')break;int len =

uva 10014 Simple calculations(数学推导)

直接按照题意来推导最后的结果就行了。 开始的时候只做到了第一个推导,第二次没有继续下去。 代码: #include<stdio.h>int main(){int T, n, i;double a, aa, sum, temp, ans;scanf("%d", &T);while(T--){scanf("%d", &n);scanf("%lf", &first);scanf

uva 10916 Factstone Benchmark(打表)

题意是求 k ! <= 2 ^ n ,的最小k。 由于n比较大,大到 2 ^ 20 次方,所以 2 ^ 2 ^ 20比较难算,所以做一些基础的数学变换。 对不等式两边同时取log2,得: log2(k ! ) <=  log2(2 ^ n)= n,即:log2(1) + log2(2) + log2 (3) + log2(4) + ... + log2(k) <= n ,其中 n 为 2 ^

uva 10025 The ? 1 ? 2 ? ... ? n = k problem(数学)

题意是    ?  1  ?  2  ?  ...  ?  n = k 式子中给k,? 处可以填 + 也可以填 - ,问最小满足条件的n。 e.g k = 12  - 1 + 2 + 3 + 4 + 5 + 6 - 7 = 12 with n = 7。 先给证明,令 S(n) = 1 + 2 + 3 + 4 + 5 + .... + n 暴搜n,搜出当 S(n) >=