HDU 3926 Hand in Hand(同构图)

2023-12-10 04:48
文章标签 hdu 构图 hand 3926

本文主要是介绍HDU 3926 Hand in Hand(同构图),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

链接:

http://acm.hdu.edu.cn/showproblem.php?pid=3926


原题:

Hand in Hand

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 122768/62768 K (Java/Others)
Total Submission(s): 731    Accepted Submission(s): 294


Problem Description
In order to get rid of Conan, Kaitou KID disguises himself as a teacher in the kindergarten. He knows kids love games and works out a new game called "hand in hand". 

Initially kids run on the playground randomly. When Kid says "stop", kids catch others' hands immediately. One hand can catch any other hand randomly. It's weird to have more than two hands get together so one hand grabs at most one other hand. After kids stop moving they form a graph.

Everybody takes a look at the graph and repeat the above steps again to form another graph. Now Kid has a question for his kids: "Are the two graph isomorphism?"

Input
The first line contains a single positive integer T( T <= 100 ), indicating the number of datasets.
There are two graphs in each case, for each graph:
first line contains N( 1 <= N <= 10^4 ) and M indicating the number of kids and connections.
the next M lines each have two integers u and v indicating kid u and v are "hand in hand".
You can assume each kid only has two hands.

Output
For each test case: output the case number as shown and "YES" if the two graph are isomorphism or "NO" otherwise.

Sample Input
  
23 2 1 2 2 3 3 2 3 2 2 13 3 1 2 2 3 3 1 3 1 1 2

Sample Output
  
Case #1: YES Case #2: NO

Source
2011 Multi-University Training Contest 9 - Host by BJTU


分析与总结:

由于每个人只有两只手,每只手不能与多只手连,就是说每个节点的度数最多只能是2,最终这些学生可能会被分成多组,每组是一个环形圆圈,或者是一条链。


题目要判断两个已经连好的图是否是"同构图", 这里所谓的同构图是指两个图组成的不同的圆圈,链条,他们各个所对应的数量都是相等的。


那么我们只需要用并查集把连这的都合并起来,如果发现有环,就进行标识。然后把两个图的并查集按照每颗树的节点个数大小排序,如果个数相同,那么有环的都放在前面。 然后,只要一一比较两个已排序的数组,只要发现有一个是不同的,就不是同构图。




代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#define N 10010
using namespace std;int f[N], rank[N], n1, m1, n2, m2, pos1, pos2, isCircle[N];struct Node{int num;int isCircle;friend bool operator <(const Node&a,const Node&b){if(a.num!=b.num) return a.num<b.num;if(a.isCircle<b.isCircle) return true;return false;}
}arr1[N], arr2[N];void init(int n){memset(isCircle, 0, sizeof(isCircle));for(int i=0; i<=n; ++i)f[i]=i,rank[i]=1;
}
int find(int x){int i, j=x;while(j!=f[j]) j=f[j];while(x!=j){ i=f[x]; f[x]=j; x=i; }return j;
}
void Union(int x,int y){int a=find(x), b=find(y);if(a==b){isCircle[a] = 1;return;}rank[a] += rank[b];f[b] = a;
}
void play(int n, int m){int a,b;init(n);for(int i=0; i<m; ++i){scanf("%d%d",&a,&b);Union(a, b);}
}bool judge(){if(pos1!=pos2)return false;sort(arr1, arr1+pos1);sort(arr2, arr2+pos2);for(int i=0; i<pos1; ++i){if(arr1[i].num!=arr2[i].num)return false;if(arr1[i].isCircle!=arr2[i].isCircle)return false;}return true;
}int main(){int T,n1,cas=1;scanf("%d",&T);while(T--){printf("Case #%d: ",cas++);scanf("%d%d",&n1,&m1);play(n1,m1);pos1 = 0;for(int i=1; i<=n1; ++i)if(i==find(i)){arr1[pos1].num = rank[i];arr1[pos1++].isCircle = isCircle[i];}scanf("%d%d",&n2,&m2);play(n2, m2);if(n1!=n2 || m1!=m2){puts("NO");continue;} pos2 = 0;for(int i=1; i<=n2; ++i)if(i==find(i)){arr2[pos2].num = rank[i];arr2[pos2++].isCircle = isCircle[i];}if(judge()) puts("YES");else puts("NO");}return 0;
}

——  生命的意义,在于赋予它意义。

          
     原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)




这篇关于HDU 3926 Hand in Hand(同构图)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/476055

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时