本文主要是介绍ACM新秀赛模拟——统计出其中英文字母、数字、空格和其他字符的个数,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
问题描述:
Description
输入一行字符,分别统计出其中英文字母、数字、空格和其他字符的个数。
Input
一行字符
Output
统计值
Sample Input
aklsjflj123 sadf918u324 asdf91u32oasdf/.';123
Sample Output
23 16 2 4
代码:
#include <iostream>
#include<cstdio>
using namespace std;
int main()
{
char a;
int e=0,l=0,n=0,o=0;
while((a=getchar())!='\n')
{
if((a>=65&&a<=90)||(a>=97&&a<=122))
e++;
else if(a>=48&&a<=57)
n++;
else if(a==' ')
l++;
else
o++;
}
cout<<e<<" "<<n<<" "<<l<<" "<<o;
return 0;
}
心得:
1.将字符串拆分,逐个计数,不必再加一层循环。
2.用"a=getchar()"录入,若用"cin>>a",则空格不被录入。加头文件"include <cstdio>"。
这篇关于ACM新秀赛模拟——统计出其中英文字母、数字、空格和其他字符的个数的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!