本文主要是介绍[SPFA]POJ 3013Big Christmas Tree,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
传送门:Big Christmas Tree
Time Limit: 3000MS | Memory Limit: 131072K | |
Total Submissions: 19794 | Accepted: 4248 |
Description
Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.
The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).
Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.
Input
The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers v, e (0 ≤ v, e ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers a, b, c indicating the edge which is able to connect two nodes a and b, and unit price c.
All numbers in input are less than 216.
Output
For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.
Sample Input
2 2 1 1 1 1 2 15 7 7 200 10 20 30 40 50 60 1 2 1 2 3 3 2 4 2 3 5 4 3 7 2 3 6 3 1 5 9
Sample Output
15 1210
Source
解题报告:
这题的数据范围是0<n,m<50000 点多,边少 显然应该选择spfa的邻接表的做法更好。但是此题卡stl,用邻接表用vector的话会超时,需要用手写的邻接表。
#include<iostream>
#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
const int N = 50005;
const int M = 100005;
struct Enode{int y, next, d;
}e[M];
int tot, head[N], w[N], v[N];
long long d[N];
void Addedge(int x, int y, int d){e[++tot].y = y; e[tot].d = d; e[tot].next = head[x]; head[x] = tot;e[++tot].y = x; e[tot].d = d; e[tot].next = head[y]; head[y] = tot;
}
queue <int> Q;
void SPFA(){memset(d, 0x7f, sizeof(d));memset(v, 0, sizeof(v));Q.push(1);d[1] = 0, v[1] = 1;while (!Q.empty()){int x = Q.front(); Q.pop();for (int p = head[x]; p != -1; p = e[p].next)if (d[e[p].y] > d[x] + e[p].d){d[e[p].y] = d[x] + e[p].d;if (!v[e[p].y]){v[e[p].y] = 1;Q.push(e[p].y);}}v[x] = 0;}
}
int main(){int t, n, m, x, y, z;scanf("%d",&t);while (t--){scanf("%d%d",&n,&m);for (int i = 1; i <= n; i++)scanf("%d", &w[i]);tot = -1;memset(head,-1,sizeof(head));for (int i = 1; i <= m; i++){scanf("%d%d%d", &x, &y, &z);Addedge(x, y, z);}SPFA();long long ans = 0;for (int i = 1; i <= n; i++){if (d[i] > 1e12){ans = -1;break;}ans += w[i]*d[i];}if (ans == -1)puts("No Answer");elseprintf("%lld\n", ans);}
}
这篇关于[SPFA]POJ 3013Big Christmas Tree的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!