本文主要是介绍POJ 2965 The Pilots Brothers' refrigerator,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description
The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.
There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.
The task is to determine the minimum number of handle switching necessary to open the refrigerator.
Input
The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.
Output
The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.
Sample Input
-+-- ---- ---- -+--
Sample Output
6 1 1 1 3 1 4 4 1 4 3 4 4
题意:想把大象装冰箱,但是呢,有的门是开(-)着的,有的是关(+)着的,必须所有的门都打开才能把大象装进去,但是你想开一个门的时候,它所在的行和它所在的列都会发生翻转,(本来是开,变成关,是关的变成开)。
思路:其实这个题和POJ1753是一样的,这个题多了一个输出路径,加两个数组记录一下就行了,4*4的门一共16个,最多不会超过16步,用深搜完全可以,对于一个门,无非就两种情况,你翻转他或者跳过他,翻转过后,发现不合适,怎么办,在反转一次,因为翻转偶数次会恢复到原来状态。
附上代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[5][5];
int mix;
int tx[30],ty[30]; //记录临时路径
int ansx[30],ansy[30];//最少步数时的路径
int check()//检查门是否全部打开
{for(int i=0; i<4; i++)for(int j=0; j<4; j++)if(map[i][j]!='-')return 0;return 1;
}
void turn (int x,int y) //翻转一行和一列
{//翻转一个点奇数次才能改变他的状态,偶数次不会改变if(map[x][y]=='-')map[x][y]='+';else map[x][y]='-';for(int i=0; i<4; i++){if(map[x][i]=='-')map[x][i]='+';else map[x][i]='-';}for(int i=0; i<4; i++){if(map[i][y]=='-')map[i][y]='+';else map[i][y]='-';}
}
void dfs(int x,int y,int step)
{if(check()){if(mix>step){mix=step;//记录最小步数for(int i=0; i<step; i++)//把路径记录下来,方便输出{ansx[i]=tx[i];ansy[i]=ty[i];}}return ;}if(x==4||step>16) return ;//一共四行从0-3,4*4最多16步turn(x,y);//翻转这个点tx[step]=x;ty[step]=y;if(y==3)dfs(x+1,0,step+1);else dfs(x,y+1,step+1);turn(x,y);//不翻转这个点的话要再翻回来,相当于回溯if(y==3)dfs(x+1,0,step);else dfs(x,y+1,step);
}
int main()
{int i,j;mix=9999;for(i=0; i<4; i++)scanf("%s",map[i]);dfs(0,0,0);printf("%d\n",mix);for(i=0; i<mix; i++)printf("%d %d\n",ansx[i]+1,ansy[i]+1);return 0;
}
下面是一个大神的思路,ORZ,大家可以参考一下:
证明:要使一个为'+'的符号变为'-',必须其相应的行和列的操作数为奇数;可以证明,如果'+'位置对应的行和列上每一个位置都进行一次操作,则整个图只有这一'+'位置的符号改变,其余都不会改变.设置一个4*4的整型数组,初值为零,用于记录每个点的操作数,那么在每个'+'上的行和列的的位置都加1,得到结果模2(因为一个点进行偶数次操作的效果和没进行操作一样,这就是楼上说的取反的原理),然后计算整型数组中一的 个数即为操作数,一的位置为要操作的位置(其他原来操作数为偶数的因为操作并不发生效果,因此不进行操作) ********************************* 此上证其可以按以上步骤使数组中值都为‘-’ ******************************** 在上述证明中将所有的行和列的位置都加1后,在将其模2之前,对给定的数组状态,将所有的位置操作其所存的操作数个次数,举例,如果a[i][j]==n,则对(i,j)操作n次,当所有的操作完后,即全为‘-’的数组。 其实就是不模2的操作,作了许多的无用功。 以上的操作次序对结果无影响,如果存在一个最小的步骤,则此步骤一定在以上操作之中。(简单说下:因为以上操作已经包含了所有可改变欲改变位置的操作了) 而模2后的操作是去掉了所有无用功之后的操作,此操作同样包含最小步骤。 但模2后的操作去掉任何一个或几个步骤后,都不可能再得到全为‘-’的。(此同样可证明:因为操作次序无影响,先进行最小步骤,得到全为‘-’,如果还剩下m步,则在全为‘-’的数组状态下进行这m步操作后还得到一个全为 ‘-’的数组状态,此只能是在同一个位置进行偶数次操作,与前文模2后矛盾,所以m=0),因此模2后的操作即为最小步骤的操作。代码:
#include<stdio.h>
#include<string.h>
char map[5][5];
int ansx[30],ansy[30],mark[5][5];
int main()
{int i,j,k;for(i=0; i<4; i++)scanf("%s",map[i]);for(i=0; i<4; i++)for(j=0; j<4; j++)if(map[i][j]=='+'){mark[i][j]=!mark[i][j];for(k=0; k<4; k++){mark[i][k]=!mark[i][k];mark[k][j]=!mark[k][j];}}int num=0;for(i=0; i<4; i++)for(j=0; j<4; j++){if(mark[i][j]){ansx[num]=i;ansy[num++]=j;}}printf("%d\n",num);for(i=0; i<num; i++)printf("%d %d\n",ansx[i]+1,ansy[i]+1);return 0;
}
这篇关于POJ 2965 The Pilots Brothers' refrigerator的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!