本文主要是介绍Hdu 1561 树形DP,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1561
The more, The Better
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10193 Accepted Submission(s): 5939
Problem Description
ACboy很喜欢玩一种战略游戏,在一个地图上,有N座城堡,每座城堡都有一定的宝物,在每次游戏中ACboy允许攻克M个城堡并获得里面的宝物。但由于地理位置原因,有些城堡不能直接攻克,要攻克这些城堡必须先攻克其他某一个特定的城堡。你能帮ACboy算出要获得尽量多的宝物应该攻克哪M个城堡吗?
Input
每个测试实例首先包括2个整数,N,M.(1 <= M <= N <= 200);在接下来的N行里,每行包括2个整数,a,b. 在第 i 行,a 代表要攻克第 i 个城堡必须先攻克第 a 个城堡,如果 a = 0 则代表可以直接攻克第 i 个城堡。b 代表第 i 个城堡的宝物数量, b >= 0。当N = 0, M = 0输入结束。
Output
对于每个测试实例,输出一个整数,代表ACboy攻克M个城堡所获得的最多宝物的数量。
Sample Input
3 2 0 1 0 2 0 3 7 4 2 2 0 1 0 4 2 1 7 1 7 6 2 2 0 0
Sample Output
5 13
//树形DP
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include <iomanip>
#include<list>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define pppp cout<<endl;//换行
#define PI acos(-1.0)
#define EPS 1e-8
#define LL long long
#define ULL unsigned long long //1844674407370955161
#define INT_INF 0x7f7f7f7f //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
const int mod=1e9+7;
const int dr[]= {0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]= {-1, 1, 0, 0, -1, 1, -1, 1};
const int N=310;
struct node
{int v;//终端点int next;//下一条同样起点的边号int w;//权值
} edge[N*2]; //无向边,2倍
int head[N];//head[u]=i表示以u为起点的所有边中的第一条边是 i号边
int tot; //总边数
int minn;
void add(int u,int v)
{edge[tot].v=v;//edge[tot].w=w;edge[tot].next=head[u];head[u]=tot++;
}
int n,m;
int dp[N][N],val[N];
void dfs(int u,int fa)
{dp[u][1]=val[u];//选一个肯定选自己这个结点for(int i=head[u]; i!=-1; i=edge[i].next){int v= edge[i].v;//if(fa==v) continue; ///如果下一个相邻节点就是父节点,则证明到底层了,开始递归父节点的兄弟节点dfs(v,u);//分组背包for(int j=m; j>0; j--) //背包容量,倒叙,保证没有重复的物品{for(int k=0; k<j; k++) //选择用户{dp[u][j]=max(dp[u][j],dp[u][j-k]+dp[v][k]);}}}}
int main()
{while(~scanf("%d%d",&n,&m)&&(n+m)){if(n==0&&m==0)break;memset(head,-1,sizeof(head));memset(dp,0,sizeof(dp));tot=0;for(int i=1; i<=n; i++){int w,v;scanf("%d%d",&v,&w);add(v,i);val[i]=w;//题目直接给出第i节课的值}m++; //我们可以0当作根节点,因为有的课可能没有先修课val[0]=0;//虚拟构造了结点0dfs(0,-1);printf("%d\n",dp[0][m]);}return 0;
}
这篇关于Hdu 1561 树形DP的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!