本文主要是介绍HDU 1686:Oulipo ← KMP算法,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1686
http://poj.org/problem?id=3461
【题目描述】
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
【输入格式】
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
【输出格式】
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
【输入样例】
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
【输出样例】
1
3
0
【算法分析】
1.常规定义的 KMP 函数,第一个参数为主串,第二个参数为模式串,但是本题中给出的样例是先输入模式串,再输入主串。故在本题中调用定义的 KMP 函数时,要注意参数顺序。
2.本题中统计的是模式串在主串中重复出现的次数,故在 KMP 函数中,把在 if(j==lent) 时,不重复进行统计时的 j=0 修改为重复进行统计时的 j=ne[j]。
3.实证知在 HDU 中不支持对 string 求长度,故可将如下代码中的 string 修改为字符数组后再提交至 HDU 进行测试。但是要注意,字符数组 x 的长度用 strlen(x) 进行计算,字符串 x 的长度用 x.length() 进行计算。
【算法代码:string版本】
本 string 版本代码是正确的,但是在 HDU 上不能通过测试,原因是 HDU 无法识别 string。
#include<bits/stdc++.h>
using namespace std;const int maxn=1e4+5;
int ne[maxn];void getNext(string t) {int len=t.length();int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(string S,string T) {int lens=S.length();int lent=T.length();int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {string s,t;cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/
【算法代码:字符数组版本】
本字符数组版本代码,在 HDU 上可正常通过测试。此字符数组版本代码,只是在 string 版本代码基础上做了微改。
#include <iostream>
#include <cstring>
using namespace std;const int maxn=1e6+5;
char s[maxn];
char t[maxn];
int ne[maxn];void getNext(char t[]) {int len=strlen(t);int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(char S[],char T[]) {int lens=strlen(S);int lent=strlen(T);int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/
【参考文献】
https://blog.csdn.net/hnjzsyjyj/article/details/127112363
https://blog.csdn.net/hnjzsyjyj/article/details/127140892
https://blog.csdn.net/hnjzsyjyj/article/details/127112363
https://blog.csdn.net/Ezereal/article/details/50998678
这篇关于HDU 1686:Oulipo ← KMP算法的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!