HDU 1686:Oulipo ← KMP算法

2023-11-06 12:12
文章标签 算法 hdu kmp 1686 oulipo

本文主要是介绍HDU 1686:Oulipo ← KMP算法,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

【题目来源】
http://acm.hdu.edu.cn/showproblem.php?pid=1686
http://poj.org/problem?id=3461

【题目描述】
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

【输入格式】
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

【输出格式】
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

【输入样例】
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

【输出样例】
1
3
0

【算法分析】
1.常规定义的 KMP 函数,第一个参数为主串,第二个参数为模式串,但是本题中给出的样例是先输入模式串,再输入主串。故在本题中调用定义的 KMP 函数时,要注意参数顺序。
2.本题中统计的是模式串在主串中
重复出现的次数,故在 KMP 函数中,把在 if(j==lent) 时,不重复进行统计时的 j=0 修改为重复进行统计时的 j=ne[j]
3.实证知在
HDU 中不支持对 string 求长度,故可将如下代码中的 string 修改为字符数组后再提交至 HDU 进行测试。但是要注意,字符数组 x 的长度用 strlen(x) 进行计算,字符串 x 的长度用 x.length() 进行计算。

【算法代码:string版本】
本 string 版本代码是正确的,但是在 HDU 上不能通过测试,原因是 HDU 无法识别 string。

#include<bits/stdc++.h>
using namespace std;const int maxn=1e4+5;
int ne[maxn];void getNext(string t) {int len=t.length();int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(string S,string T) {int lens=S.length();int lent=T.length();int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {string s,t;cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/


【算法代码:字符数组版本】
本字符数组版本代码,在 HDU 上可正常通过测试。此字符数组版本代码,只是在 string 版本代码基础上做了微改。

#include <iostream>
#include <cstring>
using namespace std;const int maxn=1e6+5;
char s[maxn];
char t[maxn];
int ne[maxn];void getNext(char t[]) {int len=strlen(t);int i=0, j=-1;ne[0]=-1;while(i<len) {if(j==-1 || t[i]==t[j]) {i++;j++;ne[i]=j;} else j=ne[j];}
}int KMP(char S[],char T[]) {int lens=strlen(S);int lent=strlen(T);int i=0;int j=0;int cnt=0;while(i<lens && j<lent) {if(j==-1 || S[i]==T[j]) {i++;j++;} else j=ne[j];if(j==lent) {cnt++;j=ne[j]; //j=0;}}return cnt;
}int main() {int T;cin>>T;while(T--) {cin>>s>>t;getNext(t);cout<<KMP(t,s)<<endl;}return 0;
}/*
input:
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIANoutput:
1
3
0
*/




【参考文献】
https://blog.csdn.net/hnjzsyjyj/article/details/127112363
https://blog.csdn.net/hnjzsyjyj/article/details/127140892
https://blog.csdn.net/hnjzsyjyj/article/details/127112363
https://blog.csdn.net/Ezereal/article/details/50998678



 

这篇关于HDU 1686:Oulipo ← KMP算法的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/356553

相关文章

SpringBoot实现MD5加盐算法的示例代码

《SpringBoot实现MD5加盐算法的示例代码》加盐算法是一种用于增强密码安全性的技术,本文主要介绍了SpringBoot实现MD5加盐算法的示例代码,文中通过示例代码介绍的非常详细,对大家的学习... 目录一、什么是加盐算法二、如何实现加盐算法2.1 加盐算法代码实现2.2 注册页面中进行密码加盐2.

Java时间轮调度算法的代码实现

《Java时间轮调度算法的代码实现》时间轮是一种高效的定时调度算法,主要用于管理延时任务或周期性任务,它通过一个环形数组(时间轮)和指针来实现,将大量定时任务分摊到固定的时间槽中,极大地降低了时间复杂... 目录1、简述2、时间轮的原理3. 时间轮的实现步骤3.1 定义时间槽3.2 定义时间轮3.3 使用时

如何通过Golang的container/list实现LRU缓存算法

《如何通过Golang的container/list实现LRU缓存算法》文章介绍了Go语言中container/list包实现的双向链表,并探讨了如何使用链表实现LRU缓存,LRU缓存通过维护一个双向... 目录力扣:146. LRU 缓存主要结构 List 和 Element常用方法1. 初始化链表2.

golang字符串匹配算法解读

《golang字符串匹配算法解读》文章介绍了字符串匹配算法的原理,特别是Knuth-Morris-Pratt(KMP)算法,该算法通过构建模式串的前缀表来减少匹配时的不必要的字符比较,从而提高效率,在... 目录简介KMP实现代码总结简介字符串匹配算法主要用于在一个较长的文本串中查找一个较短的字符串(称为

通俗易懂的Java常见限流算法具体实现

《通俗易懂的Java常见限流算法具体实现》:本文主要介绍Java常见限流算法具体实现的相关资料,包括漏桶算法、令牌桶算法、Nginx限流和Redis+Lua限流的实现原理和具体步骤,并比较了它们的... 目录一、漏桶算法1.漏桶算法的思想和原理2.具体实现二、令牌桶算法1.令牌桶算法流程:2.具体实现2.1

Python中的随机森林算法与实战

《Python中的随机森林算法与实战》本文详细介绍了随机森林算法,包括其原理、实现步骤、分类和回归案例,并讨论了其优点和缺点,通过面向对象编程实现了一个简单的随机森林模型,并应用于鸢尾花分类和波士顿房... 目录1、随机森林算法概述2、随机森林的原理3、实现步骤4、分类案例:使用随机森林预测鸢尾花品种4.1

不懂推荐算法也能设计推荐系统

本文以商业化应用推荐为例,告诉我们不懂推荐算法的产品,也能从产品侧出发, 设计出一款不错的推荐系统。 相信很多新手产品,看到算法二字,多是懵圈的。 什么排序算法、最短路径等都是相对传统的算法(注:传统是指科班出身的产品都会接触过)。但对于推荐算法,多数产品对着网上搜到的资源,都会无从下手。特别当某些推荐算法 和 “AI”扯上关系后,更是加大了理解的难度。 但,不了解推荐算法,就无法做推荐系

康拓展开(hash算法中会用到)

康拓展开是一个全排列到一个自然数的双射(也就是某个全排列与某个自然数一一对应) 公式: X=a[n]*(n-1)!+a[n-1]*(n-2)!+...+a[i]*(i-1)!+...+a[1]*0! 其中,a[i]为整数,并且0<=a[i]<i,1<=i<=n。(a[i]在不同应用中的含义不同); 典型应用: 计算当前排列在所有由小到大全排列中的顺序,也就是说求当前排列是第

csu 1446 Problem J Modified LCS (扩展欧几里得算法的简单应用)

这是一道扩展欧几里得算法的简单应用题,这题是在湖南多校训练赛中队友ac的一道题,在比赛之后请教了队友,然后自己把它a掉 这也是自己独自做扩展欧几里得算法的题目 题意:把题意转变下就变成了:求d1*x - d2*y = f2 - f1的解,很明显用exgcd来解 下面介绍一下exgcd的一些知识点:求ax + by = c的解 一、首先求ax + by = gcd(a,b)的解 这个

综合安防管理平台LntonAIServer视频监控汇聚抖动检测算法优势

LntonAIServer视频质量诊断功能中的抖动检测是一个专门针对视频稳定性进行分析的功能。抖动通常是指视频帧之间的不必要运动,这种运动可能是由于摄像机的移动、传输中的错误或编解码问题导致的。抖动检测对于确保视频内容的平滑性和观看体验至关重要。 优势 1. 提高图像质量 - 清晰度提升:减少抖动,提高图像的清晰度和细节表现力,使得监控画面更加真实可信。 - 细节增强:在低光条件下,抖