本文主要是介绍PTA advanced level 1153 Decode Registration Card of PAT (25 分) 测试点4答案错误,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1153 测试点4答案错误
- 题目内容
- 源代码
- 问题描述
- 问题更新2021.4.21
题目内容
A registration card number of PAT consists of 4 parts:
the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
the 2nd – 4th digits are the test site number, ranged from 101 to 999;
the 5th – 10th digits give the test date, in the form of yymmdd;
finally the 11th – 13th digits are the testee’s number, ranged from 000 to 999.
Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤10
4) and M (≤100), the numbers of cards and the queries, respectively.
Then N lines follow, each gives a card number and the owner’s score (integer in [0,100]), separated by a space.
After the info of testees, there are M lines, each gives a query in the format Type Term, where
Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.
Output Specification:
For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:
for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt’s, or in increasing order of site numbers if there is a tie of Nt.
If the result of a query is empty, simply print NA.
Sample Input:
8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999
Sample Output:
Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA
源代码
#include <iostream>
#include <unordered_map>
#include <queue>
#include <vector>using namespace std;struct node1 {string t_id;int grade = 0;
};struct cmp1 {bool operator()(const node1 &n1, const node1 &n2) {return n1.grade != n2.grade ? n1.grade < n2.grade : n1.t_id > n2.t_id;}
};struct node2 {int total_grade = 0;int cnt = 0;
};int main() {int N, M;cin >> N >> M;unordered_map<char, priority_queue<node1, vector<node1>, cmp1>> m1;unordered_map<string, node2> m2;unordered_map<string, unordered_map<string, int>> m3;for (int i = 0; i < N; ++i) {string id;int grade;cin >> id >> grade;char level = id[0];string site_number = id.substr(1, 3);string date = id.substr(4, 6);// type 1node1 n;n.t_id = id;n.grade = grade;m1[level].push(n);// type 2m2[site_number].total_grade += grade;m2[site_number].cnt += 1;// type 3m3[date][site_number] += 1;}for (int i = 1; i <= M; ++i) {int c;string s;cin >> c >> s;if (c == 1) {printf("Case %d: %d %s\n", i, c, s.c_str());char tc = s[0];if (m1.count(tc) == 0) {printf("NA\n");continue;}while (!m1[tc].empty()) {printf("%s %d\n", m1[tc].top().t_id.c_str(), m1[tc].top().grade);m1[tc].pop();}} else if (c == 2) {printf("Case %d: %d %s\n", i, c, s.c_str());if (m2.count(s) == 0) {printf("NA\n");continue;}printf("%d %d\n", m2[s].cnt, m2[s].total_grade);} else if (c == 3) {printf("Case %d: %d %s\n", i, c, s.c_str());if (m3.count(s) == 0) {printf("NA\n");continue;}priority_queue<node1, vector<node1>, cmp1> tq;unordered_map<string, int>::iterator it;for (it = m3[s].begin(); it != m3[s].end(); it++) {node1 tn;tn.t_id = it->first;tn.grade = it->second;tq.push(tn);}while (!tq.empty()) {printf("%s %d\n", tq.top().t_id.c_str(), tq.top().grade);tq.pop();}}}return 0;
}
问题描述
个人感觉我的思路没有问题,并且与目前已知的各路前辈分享的代码进行了比对,除了大部分人用了vector+sort函数排序、而我直接使用了优先队列以外,并没有什么大的差异,极端情况也试了好几种,但是就是无法通过最后一个测试点,我累了orz
如果有跟我思路相近的朋友也遇到了相似的问题,并且正好看到了这篇文章,欢迎在评论区一起讨论(说不定集思广益一下就能找到bug是什么了)。
问题更新2021.4.21
我真傻,真的。我在处理case 1的时候用到了优先队列,原本在读取已排序好的队列时用while循环边读边弹出是一种常见思路,但是放在这里并不试用!!!因为如果想第二次访问同一个case的同一个值就会惊奇地发现:之前的队列已经被我弹空了,想读也读不到值。
处理了这个问题就能通过测试了。
错误代码:
if (c == 1) {printf("Case %d: %d %s\n", i, c, s.c_str());char tc = s[0];if (m1.count(tc) == 0) {printf("NA\n");continue;}while (!m1[tc].empty()) {printf("%s %d\n", m1[tc].top().t_id.c_str(), m1[tc].top().grade);m1[tc].pop();}}
改成如下代码:
if (c == 1) {printf("Case %d: %d %s\n", i, c, s.c_str());char tc = s[0];if (m1.count(tc) == 0) {printf("NA\n");continue;}priority_queue<node1, vector<node1>, cmp1> temp;while (!m1[tc].empty()) {printf("%s %d\n", m1[tc].top().t_id.c_str(), m1[tc].top().grade);temp.push({m1[tc].top().t_id, m1[tc].top().grade});m1[tc].pop();}m1[tc] = temp; // 注意读完队列以后要把队列中的值还原}
然后就能通过了。没想到我竟然没有注意到这个细节,浪费了几个小时,唉,学艺不精啊!
这篇关于PTA advanced level 1153 Decode Registration Card of PAT (25 分) 测试点4答案错误的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!