ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 A(bfs)

2023-11-01 02:10

本文主要是介绍ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 A(bfs),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

传送门

题面:

#1828 : Saving Tang Monk II

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts.

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace, and he wanted to reach Tang Monk and rescue him.

The palace can be described as a matrix of characters. Different characters stand for different rooms as below:

'S' : The original position of Sun Wukong

'T' : The location of Tang Monk

'.' : An empty room

'#' : A deadly gas room.

'B' : A room with unlimited number of oxygen bottles. Every time Sun Wukong entered a 'B' room from other rooms, he would get an oxygen bottle. But staying there would not get Sun Wukong more oxygen bottles. Sun Wukong could carry at most 5 oxygen bottles at the same time.

'P' : A room with unlimited number of speed-up pills. Every time Sun Wukong entered a 'P' room from other rooms, he would get a speed-up pill. But staying there would not get Sun Wukong more speed-up pills. Sun Wukong could bring unlimited number of speed-up pills with him.

Sun Wukong could move in the palace. For each move, Sun Wukong might go to the adjacent rooms in 4 directions(north, west,south and east). But Sun Wukong couldn't get into a '#' room(deadly gas room) without an oxygen bottle. Entering a '#' room each time would cost Sun Wukong one oxygen bottle.

Each move took Sun Wukong one minute. But if Sun Wukong ate a speed-up pill, he could make next move without spending any time. In other words, each speed-up pill could save Sun Wukong one minute. And if Sun Wukong went into a '#' room, he had to stay there for one extra minute to recover his health.

Since Sun Wukong was an impatient monkey, he wanted to save Tang Monk as soon as possible. Please figure out the minimum time Sun Wukong needed to reach Tang Monk.

输入

There are no more than 25 test cases.

For each case, the first line includes two integers N and M(0 < N,M ≤ 100), meaning that the palace is a N × M matrix.

Then the N×M matrix follows.

The input ends with N = 0 and M = 0.

输出

For each test case, print the minimum time (in minute) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print -1

样例输入

2 2
S#
#T
2 5
SB###
##P#T
4 7
SP.....
P#.....
......#
B...##T
0 0

样例输出

-1
8
11

题意:

    你要从S走到T,其中每经过一次B,你将获得一罐氧气,你最多可以获得5罐氧气;每经过一次P,你可以获得一个加速器(你可以拥有无限多个加速器)。拥有一个加速器可以使得某一时刻走到下一个时刻不需要时间。每经过一次#,你需要花费一罐氧气,且需要花费额外的1单位时间,你没有氧气无法进入#。现在问你从S到T的最短路径。

题目分析:

    题目中是要求我们求从S到T的最短路径,因此我们不难想到可以用bfs进行解决。而在这个题中,最难处理的一点就是氧气瓶数量。

    为了解决氧气瓶的问题,因此我们可以在常规的dis数组的基础上再开一维状态用来记录现在拿了多少瓶氧气瓶,即代表着现在位于点处,拥有num个氧气瓶。

    而因为在之后的更新中,因为P的存在,导致了某些状态可以能会重复遍历,因此我们不能采用vis数组判重的方法去重,我们需要采用类似最短路松弛操作的做法,当发现一条更短的路径时才更新当前的状态。

代码:

#include <bits/stdc++.h>
#define maxn 105
using namespace std;
const int INF=0x3f3f3f3f;
struct Node{int x,y,num;Node(int _x,int _y,int _num){x=_x,y=_y,num=_num;}
};
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int dis[maxn][maxn][10];
char str[maxn][maxn];
int n,m;
int sx,sy,tx,ty;
void bfs(int x,int y){memset(dis,INF,sizeof(dis));queue<Node> que;dis[x][y][0]=0;que.push(Node(x,y,0));while(!que.empty()){Node now=que.front();que.pop();for(int i=0;i<4;i++){Node to=Node(0,0,0);to.x=now.x+dir[i][0];to.y=now.y+dir[i][1];if((to.x>=n||to.x<0)||(to.y>=m||to.y<0)) continue;if(str[to.x][to.y]=='B'&&now.num<5) to.num=now.num+1;//当前处于氧气状态,且之前的氧气瓶数量少于u,则获取else to.num=now.num;// 否则直接覆盖int tmp=INF;//用tmp作为松弛的条件if(str[to.x][to.y]!='#') tmp=dis[now.x][now.y][now.num]+1;//不是毒气,则直接+1else if(to.num>=1){//为#且氧气数量大于1to.num--;tmp=dis[now.x][now.y][now.num]+2;}if(str[to.x][to.y]=='P') tmp--;if(dis[to.x][to.y][to.num]>tmp){//松弛操作dis[to.x][to.y][to.num]=tmp;que.push(to);}}}
}
int main()
{while(~scanf("%d%d",&n,&m)){if(n==0&&m==0) break;for(int i=0;i<n;i++) scanf("%s",str[i]);for(int i=0;i<n;i++){for(int j=0;j<m;j++)if(str[i][j]=='S') sx=i,sy=j;else if(str[i][j]=='T') tx=i,ty=j;}bfs(sx,sy);int ans=0x3f3f3f3f;for(int i=0;i<=5;i++) ans=min(ans,dis[tx][ty][i]);if(ans>=INF) printf("-1\n");else printf("%d\n",ans);}return 0;
}

 

这篇关于ACM/ICPC 2018亚洲区预选赛北京赛站网络赛 A(bfs)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/319740

相关文章

Linux系统配置NAT网络模式的详细步骤(附图文)

《Linux系统配置NAT网络模式的详细步骤(附图文)》本文详细指导如何在VMware环境下配置NAT网络模式,包括设置主机和虚拟机的IP地址、网关,以及针对Linux和Windows系统的具体步骤,... 目录一、配置NAT网络模式二、设置虚拟机交换机网关2.1 打开虚拟机2.2 管理员授权2.3 设置子

揭秘Python Socket网络编程的7种硬核用法

《揭秘PythonSocket网络编程的7种硬核用法》Socket不仅能做聊天室,还能干一大堆硬核操作,这篇文章就带大家看看Python网络编程的7种超实用玩法,感兴趣的小伙伴可以跟随小编一起... 目录1.端口扫描器:探测开放端口2.简易 HTTP 服务器:10 秒搭个网页3.局域网游戏:多人联机对战4.

SpringBoot使用OkHttp完成高效网络请求详解

《SpringBoot使用OkHttp完成高效网络请求详解》OkHttp是一个高效的HTTP客户端,支持同步和异步请求,且具备自动处理cookie、缓存和连接池等高级功能,下面我们来看看SpringB... 目录一、OkHttp 简介二、在 Spring Boot 中集成 OkHttp三、封装 OkHttp

Linux系统之主机网络配置方式

《Linux系统之主机网络配置方式》:本文主要介绍Linux系统之主机网络配置方式,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录一、查看主机的网络参数1、查看主机名2、查看IP地址3、查看网关4、查看DNS二、配置网卡1、修改网卡配置文件2、nmcli工具【通用

使用Python高效获取网络数据的操作指南

《使用Python高效获取网络数据的操作指南》网络爬虫是一种自动化程序,用于访问和提取网站上的数据,Python是进行网络爬虫开发的理想语言,拥有丰富的库和工具,使得编写和维护爬虫变得简单高效,本文将... 目录网络爬虫的基本概念常用库介绍安装库Requests和BeautifulSoup爬虫开发发送请求解

如何通过海康威视设备网络SDK进行Java二次开发摄像头车牌识别详解

《如何通过海康威视设备网络SDK进行Java二次开发摄像头车牌识别详解》:本文主要介绍如何通过海康威视设备网络SDK进行Java二次开发摄像头车牌识别的相关资料,描述了如何使用海康威视设备网络SD... 目录前言开发流程问题和解决方案dll库加载不到的问题老旧版本sdk不兼容的问题关键实现流程总结前言作为

SSID究竟是什么? WiFi网络名称及工作方式解析

《SSID究竟是什么?WiFi网络名称及工作方式解析》SID可以看作是无线网络的名称,类似于有线网络中的网络名称或者路由器的名称,在无线网络中,设备通过SSID来识别和连接到特定的无线网络... 当提到 Wi-Fi 网络时,就避不开「SSID」这个术语。简单来说,SSID 就是 Wi-Fi 网络的名称。比如

Java实现任务管理器性能网络监控数据的方法详解

《Java实现任务管理器性能网络监控数据的方法详解》在现代操作系统中,任务管理器是一个非常重要的工具,用于监控和管理计算机的运行状态,包括CPU使用率、内存占用等,对于开发者和系统管理员来说,了解这些... 目录引言一、背景知识二、准备工作1. Maven依赖2. Gradle依赖三、代码实现四、代码详解五

hdu1254(嵌套bfs,两次bfs)

/*第一次做这种题感觉很有压力,思路还是有点混乱,总是wa,改了好多次才ac的思路:把箱子的移动当做第一层bfs,队列节点要用到当前箱子坐标(x,y),走的次数step,当前人的weizhi(man_x,man_y),要判断人能否将箱子推到某点时要嵌套第二层bfs(人的移动);代码如下:

认识、理解、分类——acm之搜索

普通搜索方法有两种:1、广度优先搜索;2、深度优先搜索; 更多搜索方法: 3、双向广度优先搜索; 4、启发式搜索(包括A*算法等); 搜索通常会用到的知识点:状态压缩(位压缩,利用hash思想压缩)。