本文主要是介绍HDU3586 Information Disturbing 树形dp+二分,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接
Information Disturbing
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 5602 Accepted Submission(s): 1811
Problem Description
In the battlefield , an effective way to defeat enemies is to break their communication system.
The information department told you that there are n enemy soldiers and their network which have n-1 communication routes can cover all of their soldiers. Information can exchange between any two soldiers by the communication routes. The number 1 soldier is the total commander and other soldiers who have only one neighbour is the frontline soldier.
Your boss zzn ordered you to cut off some routes to make any frontline soldiers in the network cannot reflect the information they collect from the battlefield to the total commander( number 1 soldier).
There is a kind of device who can choose some routes to cut off . But the cost (w) of any route you choose to cut off can’t be more than the device’s upper limit power. And the sum of the cost can’t be more than the device’s life m.
Now please minimize the upper limit power of your device to finish your task.
Input
The input consists of several test cases.
The first line of each test case contains 2 integers: n(n<=1000)m(m<=1000000).
Each of the following N-1 lines is of the form:
ai bi wi
It means there’s one route from ai to bi(undirected) and it takes wi cost to cut off the route with the device.
(1<=ai,bi<=n,1<=wi<=1000)
The input ends with n=m=0.
Output
Each case should output one integer, the minimal possible upper limit power of your device to finish your task.
If there is no way to finish the task, output -1.
Sample Input
5 5 1 3 2 1 4 3 3 5 5 4 2 6 0 0
Sample Output
3
最大边的最小值,二分;
dp[u]表示切断u子树里所有叶子节点的最小花费(切的每一条边不超过mid的时候),从儿子节点向父亲节点即从下向上转移;
设v是u的儿子节点,切除u每一个儿子v的所有叶子节点有两种方案,一种是切断uv之间的边,一种是按照v的方案;如果u,v之间边权大于mid,只能按照v的方案;如果边权小于mid,则取min。
听不懂就看代码吧,简单易懂。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <vector>
#define LL long long
#define INF 0x3f3f3f3f
#define ms(a,b) memset(a,b,sizeof(a))
using namespace std;
const int N=1e3+10;
struct node
{int v,w;node (){}node(int v,int w):v(v),w(w){}
};
vector<node>tr[N];
int n,m,l,r,ans,mid,dp[N];
void dfs(int u,int fa)
{if(tr[u].size()==1&&u!=1)dp[u]=m+1;//叶子节点初始化elsedp[u]=0;//非叶子节点初始化for(int i=0;i<tr[u].size();i++){int v=tr[u][i].v,w=tr[u][i].w;if(v==fa) continue;dfs(v,u);if(w>mid)//边权大于mid不能选用dp[u]+=dp[v];elsedp[u]+=min(w,dp[v]);//选取一个最小值}
}
int main()
{ios::sync_with_stdio(false);cin.tie(0);while(cin>>n>>m,n+m){r=0;int u,v,w;for(int i=1;i<=n;i++)tr[i].clear();for(int i=1;i<n;i++){cin>>u>>v>>w;tr[u].push_back(node(v,w));tr[v].push_back(node(u,w));r=max(r,w);//右边界}l=1,ans=-1;//没有答案输出-1,所以ans初始化-1while(l<=r)//二分{mid=(l+r)>>1;dfs(1,0); if(dp[1]<=m){ans=mid;r=mid-1;}elsel=mid+1;}cout<<ans<<'\n';}
}

这篇关于HDU3586 Information Disturbing 树形dp+二分的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!