本文主要是介绍1147. Heaps (30) 堆,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1147. Heaps (30)
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (<= 100), the number of trees to be tested; and N (1 < N <= 1000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line "Max Heap" if it is a max heap, or "Min Heap" for a min heap, or "Not Heap" if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:3 8 98 72 86 60 65 12 23 50 8 38 25 58 52 82 70 60 10 28 15 12 34 9 8 56Sample Output:
Max Heap 50 60 65 72 12 23 86 98 Min Heap 60 58 52 38 82 70 25 8 Not Heap 56 12 34 28 9 8 15 10
给出一个层序遍历的树,判断是不是最大堆或者最小堆,最后按后序遍历输出。
输入数据的时候建立二叉树。给出的是层序遍历,那么最后的树除了右下肯定是充满了的,用一个list存储没有右子树的节点地址,每次把新节点接在list最前面的节点上,如果最前面的节点左右子树都有了就pop,即可建立二叉树。
之后思路很清楚的,递归判断,通过返回值判断子树类型,再结合自身节点情况继续向上返回即可,判断过程中可以以后序顺序收集数据,最后输出即可。(后久没做二叉树居然忘记了后序是怎么遍历的了。。。
#include <cstdio>
#include <cstdlib>
#include <list>
#include <vector>using namespace std;typedef struct Node *TREE;
typedef struct Node {int data;TREE l;TREE r;
}Node;int M, N;
int sz[100010];
Node *T;
vector<int>v1;int isHeap(TREE t) {if ((!t->l) && (!t->r)) {v1.push_back(t->data);return 3;}if (!t->r) {int f = isHeap(t->l);v1.push_back(t->data);return t->data > t->l->data ? 1 : 2;}if (t->data > t->l->data&&t->data > t->r->data) {int ll = isHeap(t->l);int rr = isHeap(t->r);v1.push_back(t->data);if (ll == 0 || rr == 0 || ll == 2 || rr == 2)return 0;return 1;}else if (t->data < t->l->data&&t->data < t->r->data) {int ll = isHeap(t->l);int rr = isHeap(t->r);v1.push_back(t->data);if (ll == 0 || rr == 0 || ll == 1 || rr == 1)return 0;return 2;}else {int ll = isHeap(t->l);int rr = isHeap(t->r);v1.push_back(t->data);return 0;}
}void pf() {int n = v1.size();for (int i = 0; i < n; i++) {printf("%d%c", v1[i], i == n - 1 ? '\n' : ' ');}
}void checkk() {v1.clear();int f = T->data > T->l->data ? 1 : 2;//0:Not Heap 1:Max Heap 2:Min Heap 3:Allf = isHeap(T);if (f == 1) {printf("Max Heap\n");}else if (f == 2) {printf("Min Heap\n");}else {printf("Not Heap\n");}pf();
}int main() {scanf("%d %d\n", &M, &N);for (int i = 0; i < M; i++) {int t;list<TREE>ls;TREE rot = NULL;for (int j = 0; j < N; j++) {scanf("%d", &t);TREE tt = (TREE)malloc(sizeof(Node));tt->data = t;tt->l = NULL;tt->r = NULL;ls.push_back(tt);if (!rot) {rot = tt;}else {if ((ls.front())->l) {(ls.front())->r = tt;ls.pop_front();}else {(ls.front())->l = tt;}}}T = rot;checkk();}return 0;
}
这篇关于1147. Heaps (30) 堆的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!