本文主要是介绍POJ 2236 Wireless Network 并查集,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接
Wireless Network |
---|
Time Limit: 10000MS Memory Limit: 65536K |
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
- “O p” (1 <= p <= N), which means repairing computer p.
- “S p q” (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print “SUCCESS” if the two computers can communicate, or “FAIL” if not.
Sample Input
4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4
Sample Output
FAIL
SUCCESS
题目大意:
给你n台坏的电脑(从1~n编号),以及电脑之间能连接的最远距离d。
然后输入O k1表示修复k1号电脑;
输入S k1 k2表示测试k1 k2号电脑能否连接。
两台电脑能否连接的条件是:这两台电脑是已经修复好的并且这两台电脑是连通的(两台电脑直接相通或者借助其它的已修复电脑实现连通)。
解题思路:
并查集问题,判断两台已经修复好的电脑之间能否连通,如果可以就把根并在一起。
AC代码
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node {int x, y;int parent;
}list[1002];
double compute(node a, node b) {//计算结点之间的距离double ans = (a.x - b.x)*(a.x - b.x);ans += (a.y - b.y)*(a.y - b.y);ans = sqrt(ans);return ans;
}
int findroot(int i) {//找寻根的函数 同时进行路径压缩if (list[i].parent == i) return i;else {int tmp = findroot(list[i].parent);list[i].parent = tmp;return tmp;}
}
void MIX(int a, int b) {//合并根int fa = findroot(a);int fb = findroot(b);if (fa != fb) list[fa].parent = fb;
}
int main() {int n; double d;scanf("%d%lf", &n, &d);for (int i = 1; i <= n; i++) {scanf("%d%d", &list[i].x, &list[i].y);list[i].parent = -1;}char a;while (scanf("%c", &a) != EOF) {if (a == 'O') {int b;scanf("%d", &b);list[b].parent = b;for (int i = 1; i <= n; i++) {//把所有能跟电脑b进行通信的集合进行合并,合并的结果只有一个集合,并且该集合以b为根if (list[i].parent != -1 && compute(list[i], list[b]) <= d) {MIX(i, b);}}}else if (a == 'S') {int nn, mm;scanf("%d%d", &nn, &mm);if (findroot(nn) != findroot(mm)) {cout << "FAIL" << endl;}else cout << "SUCCESS" << endl;}}
}
这篇关于POJ 2236 Wireless Network 并查集的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!