本文主要是介绍猜数字 2178,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。
问B猜n次可以猜到的最大数。
Input
第1行是整数T,表示有T组数据,下面有T行
每行一个整数n (1 ≤ n ≤ 30)
Output
猜n次可以猜到的最大数
Sample Input
2
1
3
Sample Output
1
7
#include <cstdio>
int main(int argc, const char* argv[])
{
int nCases = 0;
scanf("%d", &nCases);
while (nCases--)
{
int n = 0;
scanf("%d", &n);
int nSum = 1;
for (int i=1; i<=n; ++i)
{
nSum *= 2;
}
printf("%d\n", nSum - 1);
}
return 0;
}
这篇关于猜数字 2178的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!