本文主要是介绍POJ3468 A Simple Problem with Integers(线段树区间更新,lazy标记),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
A Simple Problem with Integers
Description You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval. Input The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000. Output You need to answer all Q commands in order. One answer in a line. Sample Input 10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4 Sample Output 4 55 9 15 Hint The sums may exceed the range of 32-bit integers. Source POJ Monthly--2007.11.25, Yang Yi |
[Submit] [Go Back] [Status] [Discuss]
思路:这一题的意思是给了一个区间,然后有两种操作,'C'可以对某段区间的所有数加上一个值,'Q'代表查询一段区间的总和,一道lazy标记的模板题
代码:
#include <cstdio>
#include <cstring>
#include <cctype>
#include <string>
#include <set>
#include <iostream>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
#define inf 0x3f3f3f3f
#define N 100050
#define ll long long
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
ll sum[N<<2],lazy[N<<2];
void pushup(ll rt)
{sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(ll rt,ll m)
{if(lazy[rt]){lazy[rt<<1]+=lazy[rt];lazy[rt<<1|1]+=lazy[rt];sum[rt<<1]+=lazy[rt]*(m-(m>>1));sum[rt<<1|1]+=lazy[rt]*(m>>1);lazy[rt]=0;}
}
void build(ll l,ll r,ll rt)
{lazy[rt]=0;if(l==r){scanf("%lld",&sum[rt]);return;}ll m=(l+r)>>1;build(lson);build(rson);pushup(rt);
}
void update(ll L,ll R,ll c,ll l,ll r,ll rt)
{if(L<=l&&r<=R){lazy[rt]+=c;sum[rt]+=(ll)c*(r-l+1);return;}pushdown(rt,r-l+1);ll m=(l+r)>>1;if(L<=m) update(L,R,c,lson);if(m<R) update(L,R,c,rson);pushup(rt);
}
ll query(ll L,ll R,ll l,ll r,ll rt)
{if(L<=l&&r<=R)return sum[rt];pushdown(rt,r-l+1);ll m=(l+r)>>1;ll ans=0;if(L<=m)ans+=query(L,R,lson);if(R>m)ans+=query(L,R,rson);return ans;
}
int main()
{ll n,m,a,b,c;char s[5];scanf("%lld%lld",&n,&m);build(1,n,1);while(m--){scanf("%s",s);if(s[0]=='Q'){scanf("%lld%lld",&a,&b);printf("%lld\n",query(a,b,1,n,1));}if(s[0]=='C'){scanf("%lld%lld%lld",&a,&b,&c);update(a,b,c,1,n,1);}}return 0;
}
这篇关于POJ3468 A Simple Problem with Integers(线段树区间更新,lazy标记)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!