本文主要是介绍HLJUOJ1117(暴力模拟),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
八数码
Submit: 109 Solved: 19
[ Submit][ Status][ Web Board]
Description
给定一个8数码的初始状态,然后给出一系列对8数码的操作,求其最终状态.
Input
第一行t,代表样例个数。
每组数据前三行各三个数,代表八数码的初始位置,0代表空。
接下来一行一个数n,代表操作次数。
接下来n行,包含一个大写字母:U,D,L,R,代表不同的操作。
Output
每组数据输出三行各三个数,代表八数码的最终状态。
每组数据后输出一个空行。
Sample Input
1
1 2 3
4 5 6
7 8 0
2
U
L
Sample Output
1 2 3
4 0 5
7 8 6
HINT
有些操作可能无法实行,直接忽略
解题思路:
所谓八数码,就是一个九宫格,填0~8这九个数字,每次移动都关注0这个数字。依照题意,可以暴力模拟上、下、左、右这四个方向的操作,注意判断下是否存在越界,即能否与下一个位置进行交换。
另外,每组数据最后跟一个空行,包括最后一组也要跟空行。
完整代码:
#include <functional>
#include <algorithm>
#include <iostream>
#include <fstream>
#include <sstream>
#include <iomanip>
#include <numeric>
#include <cstring>
#include <climits>
#include <cassert>
#include <complex>
#include <cstdio>
#include <string>
#include <vector>
#include <bitset>
#include <queue>
#include <stack>
#include <cmath>
#include <ctime>
#include <list>
#include <set>
#include <map>
using namespace std;#pragma comment(linker, "/STACK:102400000,102400000")typedef long long LL;
typedef double DB;
typedef unsigned uint;
typedef unsigned long long uLL;/** Constant List .. **/ //{const int MOD = int(1e9)+7;
const int INF = 0x3f3f3f3f;
const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
const DB EPS = 1e-9;
const DB OO = 1e20;
const DB PI = acos(-1.0); //M_PI;
int g[1111][1111];
string str;
void change(int &a , int &b)
{int t;t = a;a = b;b = t;
}int main()
{#ifdef DoubleQfreopen("in.txt","r",stdin);#endifint t;scanf("%d",&t);while(t--){int si , sj;for(int i = 0 ; i < 3 ; i ++){for(int j = 0 ; j < 3 ; j ++){scanf("%d",&g[i][j]);if(g[i][j] == 0){si = i;sj = j;}}}int n;scanf("%d",&n);while(n--){cin >> str;if(str[0] == 'U'){if(si - 1 < 0)continue;else{change(g[si][sj] , g[si-1][sj]);si = si - 1;}}else if(str[0] == 'D'){if(si + 1 >= 3)continue;else{change(g[si][sj] , g[si+1][sj]);si = si + 1;}}else if(str[0] == 'L'){if(sj - 1 < 0)continue;else{change(g[si][sj] , g[si][sj-1]);sj = sj - 1;}}else if(str[0] == 'R'){if(sj + 1 >= 3)continue;else{change(g[si][sj] , g[si][sj+1]);sj = sj + 1;}}}for(int i = 0 ; i < 3 ; i ++){for(int j = 0 ;j < 3 ; j ++){if(j == 0)printf("%d",g[i][j]);elseprintf(" %d",g[i][j]);}printf("\n");}printf("\n");}
}
这篇关于HLJUOJ1117(暴力模拟)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!