2015ACM多校对抗赛第四场 hdu 5336

2024-08-31 12:48

本文主要是介绍2015ACM多校对抗赛第四场 hdu 5336,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=5336

XYZ and Drops

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1024    Accepted Submission(s): 291


Problem Description
XYZ is playing an interesting game called "drops". It is played on a  rc  grid. Each grid cell is either empty, or occupied by a waterdrop. Each waterdrop has a property "size". The waterdrop cracks when its size is larger than 4, and produces 4 small drops moving towards 4 different directions (up, down, left and right). 

In every second, every small drop moves to the next cell of its direction. It is possible that multiple small drops can be at same cell, and they won't collide. Then for each cell occupied by a waterdrop, the waterdrop's size increases by the number of the small drops in this cell, and these small drops disappears. 

You are given a game and a position ( x y ), before the first second there is a waterdrop cracking at position ( x y ). XYZ wants to know each waterdrop's status after  T  seconds, can you help him?

1r100 1c100 1n100 1T10000

Input
The first line contains four integers  r c n  and  T n  stands for the numbers of waterdrops at the beginning. 
Each line of the following  n  lines contains three integers  xi yi sizei , meaning that the  i -th waterdrop is at position ( xi yi ) and its size is  sizei . ( 1sizei4 )
The next line contains two integers  x y

It is guaranteed that all the positions in the input are distinct. 

Multiple test cases (about 100 cases), please read until EOF (End Of File).

Output
n  lines. Each line contains two integers  Ai Bi
If the  i -th waterdrop cracks in  T  seconds,  Ai=0 Bi=  the time when it cracked. 
If the  i -th waterdrop doesn't crack in  T  seconds,  Ai=1 Bi=  its size after  T  seconds.

Sample Input
  
4 4 5 10 2 1 4 2 3 3 2 4 4 3 1 2 4 3 4 4 4

Sample Output
  
0 5 0 3 0 2 1 3 0 1

题意:十滴水游戏的改版。
现在某个位置有一滴即将爆炸的水滴,爆炸后,将产生四个方向的四个小水滴,每一秒只能移动一步,这些小水滴要么出了表格边界,要么和其他水滴融合,被吸收。
当融合后的值达到5的时候,又会发生爆炸,问给定n个起始水滴的T时刻后的状态。0表示爆炸了+爆炸时刻。1表示没有爆炸+最后时刻水滴大小。

宽搜就行了,用优先队列维护,并标记。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
#define sf scanf
const int d[4][2]={1,0,0,1,-1,0,0,-1};
struct node{int t,x,y,d;bool operator<(const node &a)const{return t>a.t;}
};
struct point{int x,y;
}a[105];
int r,c,n,T;
priority_queue<node> que;
int mapt[102][102];
int ans[101][101];
bool legel(int x,int y){return x>0&&x<=r&&y>0&&y<=c;}
void addque(node p)
{for(int i = 0;i<4;i++){int xx = p.x + d[i][0];int yy = p.y + d[i][1];while(legel(xx,yy)&&mapt[xx][yy] == 0) {xx+=d[i][0];yy+=d[i][1];}//cout<<xx<<" "<<yy<<endl;if(mapt[xx][yy] != 0){//cout<<xx<<","<<yy<<":"<<abs(xx+yy-p.x-p.y)+p.t<<endl;que.push(node{abs(xx+yy-p.x-p.y)+p.t,xx,yy,i});}}
}
int main()
{while(~sf("%d%d%d%d",&r,&c,&n,&T)){memset(mapt,0,sizeof mapt);memset(ans,0,sizeof ans);for(int i = 0;i<n;i++){int x,y,z;sf("%d%d%d",&x,&y,&z);mapt[x][y] = z;a[i] = point{x,y};}int x,y;sf("%d%d",&x,&y);while(!que.empty()) que.pop();addque(node{0,x,y,0});while(!que.empty()){node p = que.top();//cout<<p.t<<":"<<p.x<<","<<p.y<<"----------"<<endl;que.pop();if(p.t>T) continue;if(mapt[p.x][p.y]<=4){mapt[p.x][p.y]++;if(mapt[p.x][p.y]==5){addque(p);ans[p.x][p.y] = p.t;}}else{if(ans[p.x][p.y] != p.t){int xx = p.x + d[p.d][0];int yy = p.y + d[p.d][1];while(legel(xx,yy)&&mapt[xx][yy] == 0) {xx+=d[p.d][0];yy+=d[p.d][1];}if(mapt[xx][yy] != 0){//  cout<<xx<<","<<yy<<":"<<abs(xx+yy-p.x-p.y)+p.t<<endl;que.push(node{abs(xx+yy-p.x-p.y)+p.t,xx,yy,p.d});}}}}for(int i =0;i<n;i++)if(ans[a[i].x][a[i].y]!=0)printf("0 %d\n",ans[a[i].x][a[i].y]);elseprintf("1 %d\n",mapt[a[i].x][a[i].y]);}return 0;
}




这篇关于2015ACM多校对抗赛第四场 hdu 5336的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1123953

相关文章

usaco 1.3 Mixing Milk (结构体排序 qsort) and hdu 2020(sort)

到了这题学会了结构体排序 于是回去修改了 1.2 milking cows 的算法~ 结构体排序核心: 1.结构体定义 struct Milk{int price;int milks;}milk[5000]; 2.自定义的比较函数,若返回值为正,qsort 函数判定a>b ;为负,a<b;为0,a==b; int milkcmp(const void *va,c

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2093 考试排名(sscanf)

模拟题。 直接从教程里拉解析。 因为表格里的数据格式不统一。有时候有"()",有时候又没有。而它也不会给我们提示。 这种情况下,就只能它它们统一看作字符串来处理了。现在就请出我们的主角sscanf()! sscanf 语法: #include int sscanf( const char *buffer, const char *format, ... ); 函数sscanf()和

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

hdu 3790 (单源最短路dijkstra)

题意: 每条边都有长度d 和花费p,给你起点s 终点t,要求输出起点到终点的最短距离及其花费,如果最短距离有多条路线,则输出花费最少的。 解析: 考察对dijkstra的理解。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstrin

hdu 2489 (dfs枚举 + prim)

题意: 对于一棵顶点和边都有权值的树,使用下面的等式来计算Ratio 给定一个n 个顶点的完全图及它所有顶点和边的权值,找到一个该图含有m 个顶点的子图,并且让这个子图的Ratio 值在所有m 个顶点的树中最小。 解析: 因为数据量不大,先用dfs枚举搭配出m个子节点,算出点和,然后套个prim算出边和,每次比较大小即可。 dfs没有写好,A的老泪纵横。 错在把index在d

hdu 1102 uva 10397(最小生成树prim)

hdu 1102: 题意: 给一个邻接矩阵,给一些村庄间已经修的路,问最小生成树。 解析: 把已经修的路的权值改为0,套个prim()。 注意prim 最外层循坏为n-1。 代码: #include <iostream>#include <cstdio>#include <cstdlib>#include <algorithm>#include <cstri

hdu 1285(拓扑排序)

题意: 给各个队间的胜负关系,让排名次,名词相同按从小到大排。 解析: 拓扑排序是应用于有向无回路图(Direct Acyclic Graph,简称DAG)上的一种排序方式,对一个有向无回路图进行拓扑排序后,所有的顶点形成一个序列,对所有边(u,v),满足u 在v 的前面。该序列说明了顶点表示的事件或状态发生的整体顺序。比较经典的是在工程活动上,某些工程完成后,另一些工程才能继续,此时