本文主要是介绍POJ 1459 ZOJ 1734 Power Network (网络最大流),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
http://poj.org/problem?id=1459
http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1734
Power Network
Description A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. Input There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct. Output For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line. Sample Input 2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20 7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5(0)5 (1)2 (3)2 (4)1 (5)4 Sample Output 15 6 Hint The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1. Source Southeastern Europe 2003 |
题意:
一共有n个点,其中np个发电站,nc个用户,剩余的是中转站,有m条电缆(有向),电缆上有容量限制,发电站有发电上限,用户有耗电上限,求电网中最大消耗。
分析:
显然是网络最大流,发电站是源点,用户是汇点,建立超级源点与超级汇点,超级源点与发电站连一条有向边,容量为该发电站的发电上限,用户与超级汇点连一条有向边,容量为该用户的耗电上限。
这题我分别用EK算法和Dinic算法实现,发现在本题中Dinic算法的效率比EK算法高了近20倍!而在POJ 2112中,Dinic算法也比EK算法快了7倍多!Dinic简直就是神器啊,以后都用他了。
比较两种算法,EK算法是一次BFS找一条增广路;Dinic是一次BFS建立分层图,在该分层图上多次DFS找出多条增广路,以此减少BFS的次数,从而获得更高的效率。
EK算法实现:
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define maxm 23456
#define maxn 107using namespace std;int fir[maxn];
int u[maxm],v[maxm],cap[maxm],flow[maxm],nex[maxm];
int e_max;
int p[maxn],q[maxn],d[maxn];void add_edge(int _u,int _v,int _w)
{int e;e=e_max++;u[e]=_u;v[e]=_v;cap[e]=_w;nex[e]=fir[u[e]];fir[u[e]]=e;e=e_max++;u[e]=_v;v[e]=_u;cap[e]=0;nex[e]=fir[u[e]];fir[u[e]]=e;
}int max_flow(int s,int t)
{memset(flow,0,sizeof flow);int total_flow=0;for (;;){memset(d,0,sizeof d);d[s]=INF;int f=0,r=0;q[0]=s;while (f<=r){int _u=q[f++];for (int e=fir[_u];~e;e=nex[e]){if (!d[v[e]] && cap[e]>flow[e]){q[++r]=v[e];p[v[e]]=e;d[v[e]]=min(d[u[e]],cap[e]-flow[e]);}}}if (d[t]==0) break;for (int e=p[t];;e=p[u[e]]){flow[e]+=d[t];flow[e^1]-=d[t];if (u[e]==s) break;}total_flow+=d[t];}return total_flow;
}int main()
{#ifndef ONLINE_JUDGEfreopen("/home/fcbruce/文档/code/t","r",stdin);#endif // ONLINE_JUDGEint n,np,nc,m,_u,_v,_w;while (~scanf("%d %d %d %d",&n,&np,&nc,&m)){e_max=0;int s=n,t=n+1;memset(fir,-1,sizeof fir);for (int i=0;i<m;i++){scanf(" (%d,%d)%d",&_u,&_v,&_w);add_edge(_u,_v,_w);}for (int i=0;i<np;i++){scanf(" (%d)%d",&_u,&_w);add_edge(s,_u,_w);}for (int i=0;i<nc;i++){scanf(" (%d)%d",&_u,&_w);add_edge(_u,t,_w);}printf("%d\n",max_flow(s,t));}return 0;
}
dinic算法实现:
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define maxm 23456
#define maxn 107using namespace std;int fir[maxn];
int u[maxm],v[maxm],cap[maxm],flow[maxm],nex[maxm];
int e_max;
int iter[maxn],q[maxn],lv[maxn];void add_edge(int _u,int _v,int _w)
{int e;e=e_max++;u[e]=_u;v[e]=_v;cap[e]=_w;nex[e]=fir[u[e]];fir[u[e]]=e;e=e_max++;u[e]=_v;v[e]=_u;cap[e]=0;nex[e]=fir[u[e]];fir[u[e]]=e;
}void dinic_bfs(int s)
{int f,r;memset(lv,-1,sizeof lv);q[f=r=0]=s;lv[s]=0;while(f<=r){int x=q[f++];for (int e=fir[x];~e;e=nex[e]){if (cap[e]>flow[e] && lv[v[e]]<0){lv[v[e]]=lv[u[e]]+1;q[++r]=v[e];}}}
}int dinic_dfs(int _u,int t,int _f)
{if (_u==t) return _f;for (int &e=iter[_u];~e;e=nex[e]){if (cap[e]>flow[e] && lv[_u]<lv[v[e]]){int _d=dinic_dfs(v[e],t,min(_f,cap[e]-flow[e]));if (_d>0){flow[e]+=_d;flow[e^1]-=_d;return _d;}}}return 0;
}int max_flow(int s,int t)
{memset(flow,0,sizeof flow);int total_flow=0;for (;;){dinic_bfs(s);if (lv[t]<0) return total_flow;memcpy(iter,fir,sizeof iter);int _f;while ((_f=dinic_dfs(s,t,INF))>0)total_flow+=_f;}return total_flow;
}int main()
{#ifndef ONLINE_JUDGEfreopen("/home/fcbruce/文档/code/t","r",stdin);#endif // ONLINE_JUDGEint n,np,nc,m,_u,_v,_w;while (~scanf("%d %d %d %d",&n,&np,&nc,&m)){e_max=0;int s=n,t=n+1;memset(fir,-1,sizeof fir);for (int i=0;i<m;i++){scanf(" (%d,%d)%d",&_u,&_v,&_w);add_edge(_u,_v,_w);}for (int i=0;i<np;i++){scanf(" (%d)%d",&_u,&_w);add_edge(s,_u,_w);}for (int i=0;i<nc;i++){scanf(" (%d)%d",&_u,&_w);add_edge(_u,t,_w);}printf("%d\n",max_flow(s,t));}return 0;
}
这篇关于POJ 1459 ZOJ 1734 Power Network (网络最大流)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!