本文主要是介绍【PAT】【Advanced Level】1057. Stack (30),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
1057. Stack (30)
Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian -- return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<= 105). Then N lines follow, each contains a command in one of the following 3 formats:
Push keyPop
PeekMedian
where key is a positive integer no more than 105.
Output Specification:
For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print "Invalid" instead.
Sample Input:17 Pop PeekMedian Push 3 PeekMedian Push 2 PeekMedian Push 1 PeekMedian Pop Pop Push 5 Push 4 PeekMedian Pop Pop Pop PopSample Output:
Invalid Invalid 3 2 2 1 2 4 4 5 3 Invalid
https://www.patest.cn/contests/pat-a-practise/1057
思路:
两个set,分别存放上下一半
开数组记录重复的元素(也可以用multiset)
插入时,先插入元素较少的set,然后调整,使得第一个的最大值不大于第二个的最小值。
删除时,先找,再删,然后调整两个set的大小为一样或者差一个。
查询时,若为奇数个,取大的begin()
否则取小的end()
坑:
用scanf、printf读写,否则超时
CODE:
#include<iostream>
#include<cstring>
#include<string>
#include<set>
#include<cstdio>
#include<stack>
#define N 100100
using namespace std;
stack<int> st;
set<int> s1;
int n1[N];
int size1;
set<int> s2;
int n2[N];
int size2;
int main()
{memset(n1,0,sizeof(n1));memset(n2,0,sizeof(n2));int n;cin>>n;int to=-1;size1=0;size2=0;for (int i=0;i<n;i++){char t[10];scanf("%s",t);if (t[1]=='o'){if (st.empty()){printf("Invalid\n");}else{int _top=st.top();st.pop();printf("%d\n",_top);if (n1[_top]!=0){n1[_top]--;size1--;if (n1[_top]==0) s1.erase(s1.find(_top));while (size1<size2-1){int b=*s2.begin();if (n2[b]==1) s2.erase(s2.find(b));n2[b]--;size2--;if (n1[b]==0) s1.insert(b);n1[b]++;size1++;}}else{n2[_top]--;size2--;if (n2[_top]==0) s2.erase(s2.find(_top));while (size2<size1){int a=*s1.rbegin();if (n1[a]==1) s1.erase(s1.find(a));n1[a]--;size1--;if (n2[a]==0) s2.insert(a);n2[a]++;size2++;}}}}else if (t[1]=='u'){scanf("%d",&to);st.push(to);if (size1 < size2){size1++;if (n1[to]==0) s1.insert(to);n1[to]++; }else{size2++;if (n2[to]==0) s2.insert(to);n2[to]++;}if (s1.empty()) continue;while (*s1.rbegin()>*s2.begin()){int a=*s1.rbegin();int b=*s2.begin();if (n1[a]==1) s1.erase(s1.find(a));n1[a]--;if (n2[b]==1) s2.erase(s2.find(b));n2[b]--;if (n1[b]==0) s1.insert(b);n1[b]++;if (n2[a]==0) s2.insert(a);n2[a]++;} }else {if (st.empty()){printf("Invalid\n");}else{if (size1<size2){int a=*s2.begin();printf("%d\n",a);}else{int a=*s1.rbegin();printf("%d\n",a);}}}} return 0;
}
这篇关于【PAT】【Advanced Level】1057. Stack (30)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!