poj 1639 Picnic Planning(最小K度限制生成树)

2024-06-15 19:18

本文主要是介绍poj 1639 Picnic Planning(最小K度限制生成树),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

hihoCoder挑战赛11来啦!有Tshirt作为奖品哦~

Language:
Picnic Planning
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 9563 Accepted: 3427

Description

The Contortion Brothers are a famous set of circus clowns, known worldwide for their incredible ability to cram an unlimited number of themselves into even the smallest vehicle. During the off-season, the brothers like to get together for an Annual Contortionists Meeting at a local park. However, the brothers are not only tight with regard to cramped quarters, but with money as well, so they try to find the way to get everyone to the party which minimizes the number of miles put on everyone's cars (thus saving gas, wear and tear, etc.). To this end they are willing to cram themselves into as few cars as necessary to minimize the total number of miles put on all their cars together. This often results in many brothers driving to one brother's house, leaving all but one car there and piling into the remaining one. There is a constraint at the park, however: the parking lot at the picnic site can only hold a limited number of cars, so that must be factored into the overall miserly calculation. Also, due to an entrance fee to the park, once any brother's car arrives at the park it is there to stay; he will not drop off his passengers and then leave to pick up other brothers. Now for your average circus clan, solving this problem is a challenge, so it is left to you to write a program to solve their milage minimization problem.

Input

Input will consist of one problem instance. The first line will contain a single integer n indicating the number of highway connections between brothers or between brothers and the park. The next n lines will contain one connection per line, of the form name1 name2 dist, where name1 and name2 are either the names of two brothers or the word Park and a brother's name (in either order), and dist is the integer distance between them. These roads will all be 2-way roads, and dist will always be positive.The maximum number of brothers will be 20 and the maximumlength of any name will be 10 characters.Following these n lines will be one final line containing an integer s which specifies the number of cars which can fit in the parking lot of the picnic site. You may assume that there is a path from every brother's house to the park and that a solution exists for each problem instance.

Output

Output should consist of one line of the form 
Total miles driven: xxx 
where xxx is the total number of miles driven by all the brothers' cars.

Sample Input

10
Alphonzo Bernardo 32
Alphonzo Park 57
Alphonzo Eduardo 43
Bernardo Park 19
Bernardo Clemenzi 82
Clemenzi Park 65
Clemenzi Herb 90
Clemenzi Eduardo 109
Park Herb 24
Herb Eduardo 79
3

Sample Output

Total miles driven: 183



求一个无向图的最小生成树 其中有个点的度有限制(不大于K)

具体内容可以参考这篇博客: http://www.cnblogs.com/jackge/archive/2013/05/12/3073669.html

代码能力有限  只能学着别人的代码 写下 作为模版使用

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#include <vector>
#include <queue>
#include <map>#define MEM(a,x) memset(a,x,sizeof a)
#define eps 1e-8
#define MOD 10009
#define MAXN 10010
#define MAXM 100010
#define INF 99999999
#define ll __int64
#define bug cout<<"here"<<endl
#define fread freopen("ceshi.txt","r",stdin)
#define fwrite freopen("out.txt","w",stdout)using namespace std;int Read()
{char c = getchar();while (c < '0' || c > '9') c = getchar();int x = 0;while (c >= '0' && c <= '9') {x = x * 10 + c - '0';c = getchar();}return x;
}void Print(int a)
{if(a>9)Print(a/10);putchar(a%10+'0');
}
const int N=30;
struct node
{int v,cap;node() {}node(int _v,int _cap):v(_v),cap(_cap){}bool operator < (const node &a)const{return cap>a.cap;}
};
map<string,int> mp;
int g[N][N],dis[N],clo[N],pre[N],fst[N],max_side[N];
int n,m,k;//点的数量 边的数量 指定点度数int Prim(int src,int id)
{priority_queue<node> q;while(!q.empty())q.pop();dis[src]=0;q.push(node(src,0));int ans=0;while(!q.empty()){node cur=q.top(); q.pop();int u=cur.v;if(!clo[u]){clo[u]=id;ans+=dis[u];for(int i=1;i<n;i++){if(!clo[i]&&g[u][i]!=0&&dis[i]>g[u][i])//满足松弛条件{pre[i]=u;dis[i]=g[u][i];q.push(node(i,dis[i]));}}}}return ans;
}void update(int cur,int last,int maxside)//dfs过程 直到搜回到起点 并完成max_sidegengxin
{max_side[cur]=maxside>g[cur][last]?maxside:g[cur][last];for(int i=1;i<n;i++){if(i!=last&&g[cur][i]!=0&&(pre[cur]==i||pre[i]==cur))update(i,cur,max_side[cur]);}
}void Solve()
{int res,cnt;for(int i=0;i<n;i++){dis[i]=INF;clo[i]=pre[i]=fst[i]=0;}res=0; cnt=1;   //除去根节点后,图中连通子图个数 即最小生成树个数for(int i=1;i<n;i++)if(!clo[i])res+=Prim(i,cnt++);for(int i=1;i<n;i++)//找到每个生成树和Park最近的点使之和Park相连{int id=clo[i];if(g[0][i]!=0&&(!fst[id]||g[0][i]<g[0][fst[id]]))fst[id]=i;}for(int i=1;i<cnt;i++)//把m个生成树上和根节点相连的边加入res 得到关于Park的最小m度生成树{res+=g[0][fst[i]];g[0][fst[i]]=g[fst[i]][0]=0;update(fst[i],0,0);}/*添删操作:将根节点和生成树中一个点相连,会产生一个环,将这个环上(除刚添的那条边外)权值最大的边删去.由于每次操作都会给总权值带来影响 d=max_side[tmp]-mat[0][tmp],我们需要得到最小生成树,所以我们就要求 d 尽量大*/k=k-cnt+1; //接下来重复操作 直到度数满足条件while(k--){int tmp=0;for(int i=1;i<n;i++)//找d值最大的点(就是完成增删操作之后可以使总边权减小的值最大)if(g[0][i]!=0&&(tmp==0||max_side[tmp]-g[0][tmp]<max_side[i]-g[0][i]))tmp=i;if(max_side[tmp]<=g[0][tmp])//总权值无法再减小break;res=res-max_side[tmp]+g[0][tmp];g[0][tmp]=g[tmp][0]=0;int p=0;for(int i=tmp;pre[i]!=0;i=pre[i])if(p==0||g[p][pre[p]]<g[i][pre[i]])p=i;pre[p]=0;update(tmp,0,0);}printf("Total miles driven: %d\n",res);
}int main()
{
//    fread;char s1[20],s2[20];int cap;while(scanf("%d",&m)!=EOF){mp["Park"]=0;n=1;MEM(g,0);while(m--){scanf("%s %s %d",s1,s2,&cap);if(!mp.count(s1))//如果键存在返回1,否则返回0mp[s1]=n++;if(!mp.count(s2))mp[s2]=n++;int u=mp[s1],v=mp[s2];if(!g[u][v]||g[u][v]>cap)//u v之间还没建边或者之间的距离大于capg[u][v]=g[v][u]=cap;}scanf("%d",&k);Solve();}return 0;
}



这篇关于poj 1639 Picnic Planning(最小K度限制生成树)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1064340

相关文章

Java编译生成多个.class文件的原理和作用

《Java编译生成多个.class文件的原理和作用》作为一名经验丰富的开发者,在Java项目中执行编译后,可能会发现一个.java源文件有时会产生多个.class文件,从技术实现层面详细剖析这一现象... 目录一、内部类机制与.class文件生成成员内部类(常规内部类)局部内部类(方法内部类)匿名内部类二、

使用Jackson进行JSON生成与解析的新手指南

《使用Jackson进行JSON生成与解析的新手指南》这篇文章主要为大家详细介绍了如何使用Jackson进行JSON生成与解析处理,文中的示例代码讲解详细,感兴趣的小伙伴可以跟随小编一起学习一下... 目录1. 核心依赖2. 基础用法2.1 对象转 jsON(序列化)2.2 JSON 转对象(反序列化)3.

java中使用POI生成Excel并导出过程

《java中使用POI生成Excel并导出过程》:本文主要介绍java中使用POI生成Excel并导出过程,具有很好的参考价值,希望对大家有所帮助,如有错误或未考虑完全的地方,望不吝赐教... 目录需求说明及实现方式需求完成通用代码版本1版本2结果展示type参数为atype参数为b总结注:本文章中代码均为

在java中如何将inputStream对象转换为File对象(不生成本地文件)

《在java中如何将inputStream对象转换为File对象(不生成本地文件)》:本文主要介绍在java中如何将inputStream对象转换为File对象(不生成本地文件),具有很好的参考价... 目录需求说明问题解决总结需求说明在后端中通过POI生成Excel文件流,将输出流(outputStre

浅谈mysql的sql_mode可能会限制你的查询

《浅谈mysql的sql_mode可能会限制你的查询》本文主要介绍了浅谈mysql的sql_mode可能会限制你的查询,这个问题主要说明的是,我们写的sql查询语句违背了聚合函数groupby的规则... 目录场景:问题描述原因分析:解决方案:第一种:修改后,只有当前生效,若是mysql服务重启,就会失效;

C/C++随机数生成的五种方法

《C/C++随机数生成的五种方法》C++作为一种古老的编程语言,其随机数生成的方法已经经历了多次的变革,早期的C++版本使用的是rand()函数和RAND_MAX常量,这种方法虽然简单,但并不总是提供... 目录C/C++ 随机数生成方法1. 使用 rand() 和 srand()2. 使用 <random

Flask 验证码自动生成的实现示例

《Flask验证码自动生成的实现示例》本文主要介绍了Flask验证码自动生成的实现示例,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友们下面随着小编来一起学习... 目录生成图片以及结果处理验证码蓝图html页面展示想必验证码大家都有所了解,但是可以自己定义图片验证码

Python如何在Word中生成多种不同类型的图表

《Python如何在Word中生成多种不同类型的图表》Word文档中插入图表不仅能直观呈现数据,还能提升文档的可读性和专业性,本文将介绍如何使用Python在Word文档中创建和自定义各种图表,需要的... 目录在Word中创建柱形图在Word中创建条形图在Word中创建折线图在Word中创建饼图在Word

nginx生成自签名SSL证书配置HTTPS的实现

《nginx生成自签名SSL证书配置HTTPS的实现》本文主要介绍在Nginx中生成自签名SSL证书并配置HTTPS,包括安装Nginx、创建证书、配置证书以及测试访问,具有一定的参考价值,感兴趣的可... 目录一、安装nginx二、创建证书三、配置证书并验证四、测试一、安装nginxnginx必须有"-

Java实战之利用POI生成Excel图表

《Java实战之利用POI生成Excel图表》ApachePOI是Java生态中处理Office文档的核心工具,这篇文章主要为大家详细介绍了如何在Excel中创建折线图,柱状图,饼图等常见图表,需要的... 目录一、环境配置与依赖管理二、数据源准备与工作表构建三、图表生成核心步骤1. 折线图(Line Ch