TOJ 4399 Deal with numbers / 线段树成段更新

2024-06-15 12:18

本文主要是介绍TOJ 4399 Deal with numbers / 线段树成段更新,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Deal with numbers

时间限制(普通/Java):10000MS/30000MS     运行内存限制:65536KByte

描述

There are n numbers with the corresponding NO.1-n, and the value of the i-th number is xi.

Define three operations:

    1.Division a b c, in the interval [a,b], if the value of a number is equal or greater than zero, then its value changed to it divide C(integer division). (1 <= a <= b <= n, 1 <= c <= 50000)

    2.Minus a b c, all numbers in the interval [a, b] subtract c. (1 <= a <= b <= n ,1<= c <= 50000)

    3.Sum a b, query for the sum of all numbers in the interval [a, b]. (1 <= a <= b <= n)

输入

Input contains several test cases.

The first line is an integer T indicates the number of test cases.

For each test case, the first line contains two integer numbers n and m (1<=n,m<=10^5), indicates the number of numbers and the number of operations. The second line contains n integers, the i-th integer shows the original value of the i-th number (1<=xi<=50000). Then m lines followed, each line shows an operation.

输出

For each set of data, output the case number in a line first, and then for each query, output an integer in a line to show the answer.

Print a blank line after the end of each test cases.

样例输入

2
5 5
1 2 3 4 5
Division 1 3 2
Minus 3 5 3
Sum 1 2
Sum 3 4
Sum 5 5
5 3
-2 -1 3 -2 1
Sum 1 2
Division 1 2 2
Sum 1 2

样例输出

Case 1:
1
-1
2Case 2:
-3
-3
#include <stdio.h>
const __int64 MAX = 100010;
__int64 pos[MAX];
struct node
{__int64 l;__int64 r;__int64 add;__int64 sum;bool b;
}a[MAX*4];void build(__int64 l,__int64 r,__int64 rt)
{a[rt].l = l;a[rt].r = r;a[rt].add = 0;if(l == r){pos[l] = rt;scanf("%I64d",&a[rt].sum);a[rt].b = a[rt].sum > 0;return;}__int64 m = (l + r) >> 1;build(l,m,rt<<1);build(m+1,r,rt<<1|1);a[rt].b = a[rt<<1].b | a[rt<<1|1].b;a[rt].sum = a[rt<<1].sum + a[rt<<1|1].sum;
}void update1(__int64 l,__int64 r,__int64 rt,__int64 divide)
{if(!a[rt].b)return;if(a[rt].l == a[rt].r){if(a[rt].sum > 0)a[rt].sum /= divide;a[rt].b = a[rt].sum > 0;return;}if(a[rt].add){__int64 k = a[rt].r - a[rt].l + 1;a[rt<<1].add += a[rt].add;a[rt<<1|1].add += a[rt].add;a[rt<<1].sum -= a[rt].add * (k - (k >> 1));a[rt<<1|1].sum -= a[rt].add * (k >> 1);a[rt].add = 0;}__int64 m = (a[rt].l + a[rt].r) >> 1;if(l <= m)update1(l,r,rt<<1,divide);if(r > m)update1(l,r,rt<<1|1,divide);a[rt].b = a[rt<<1].b | a[rt<<1|1].b;a[rt].sum = a[rt<<1].sum + a[rt<<1|1].sum;
}void update2(__int64 l,__int64 r,__int64 rt,__int64 add)
{if(a[rt].l == a[rt].r){a[rt].sum -= add;a[rt].b = a[rt].sum > 0;return;}if(a[rt].l >= l && a[rt].r <= r){a[rt].add += add ;a[rt].sum -= add * (a[rt].r - a[rt].l + 1);return;}if(a[rt].add){__int64 k = a[rt].r - a[rt].l + 1;a[rt<<1].add += a[rt].add;a[rt<<1|1].add += a[rt].add;a[rt<<1].sum -= a[rt].add * (k - (k >> 1));a[rt<<1|1].sum -= a[rt].add * (k >> 1);a[rt].add = 0;}__int64 m = (a[rt].l + a[rt].r) >> 1;if(l <= m)update2(l,r,rt<<1,add);if(r > m)update2(l,r,rt<<1|1,add);a[rt].b = a[rt<<1].b | a[rt<<1|1].b;a[rt].sum = a[rt<<1].sum + a[rt<<1|1].sum;
}
__int64 query(__int64 l,__int64 r,__int64 rt)
{if(a[rt].l >= l && a[rt].r <= r){return a[rt].sum;}if(a[rt].add){__int64 k = a[rt].r - a[rt].l + 1;a[rt<<1].add += a[rt].add;a[rt<<1|1].add += a[rt].add;a[rt<<1].sum -= a[rt].add * (k - (k >> 1));a[rt<<1|1].sum -= a[rt].add * (k >> 1);a[rt].add = 0;}__int64 ret = 0;__int64 m = (a[rt].l + a[rt].r) >> 1;if(l <= m)ret += query(l,r,rt<<1);if(r > m)ret += query(l,r,rt<<1|1);return ret;
}
int main()
{char str[100];__int64 t,n,m,x,y,z,i,cas = 1;scanf("%I64d",&t);while(t--){printf("Case %I64d:\n",cas++);scanf("%I64d %I64d",&n,&m);build(1,n,1);while(m--){scanf("%s",str);if(str[0] == 'D'){scanf("%I64d %I64d %I64d",&x,&y,&z);if(z == 1)continue;update1(x,y,1,z);}else if(str[0] == 'M'){scanf("%I64d %I64d %I64d",&x,&y,&z);if(z == 0)continue;update2(x,y,1,z);}else{scanf("%I64d %I64d",&x,&y);printf("%I64d\n",query(x,y,1));}}puts("");}return 0;
}


这篇关于TOJ 4399 Deal with numbers / 线段树成段更新的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/1063427

相关文章

poj3468(线段树成段更新模板题)

题意:包括两个操作:1、将[a.b]上的数字加上v;2、查询区间[a,b]上的和 下面的介绍是下解题思路: 首先介绍  lazy-tag思想:用一个变量记录每一个线段树节点的变化值,当这部分线段的一致性被破坏我们就将这个变化值传递给子区间,大大增加了线段树的效率。 比如现在需要对[a,b]区间值进行加c操作,那么就从根节点[1,n]开始调用update函数进行操作,如果刚好执行到一个子节点,

hdu1394(线段树点更新的应用)

题意:求一个序列经过一定的操作得到的序列的最小逆序数 这题会用到逆序数的一个性质,在0到n-1这些数字组成的乱序排列,将第一个数字A移到最后一位,得到的逆序数为res-a+(n-a-1) 知道上面的知识点后,可以用暴力来解 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#in

hdu1689(线段树成段更新)

两种操作:1、set区间[a,b]上数字为v;2、查询[ 1 , n ]上的sum 代码如下: #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<queue>#include<set>#include<map>#include<stdio.h>#include<stdl

hdu 1754 I Hate It(线段树,单点更新,区间最值)

题意是求一个线段中的最大数。 线段树的模板题,试用了一下交大的模板。效率有点略低。 代码: #include <stdio.h>#include <string.h>#define TREE_SIZE (1 << (20))//const int TREE_SIZE = 200000 + 10;int max(int a, int b){return a > b ? a :

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

AI行业应用(不定期更新)

ChatPDF 可以让你上传一个 PDF 文件,然后针对这个 PDF 进行小结和提问。你可以把各种各样你要研究的分析报告交给它,快速获取到想要知道的信息。https://www.chatpdf.com/

GIS图形库更新2024.8.4-9.9

更多精彩内容请访问 dt.sim3d.cn ,关注公众号【sky的数孪技术】,技术交流、源码下载请添加微信:digital_twin123 Cesium 本期发布了1.121 版本。重大新闻,Cesium被Bentley收购。 ✨ 功能和改进 默认启用 MSAA,采样 4 次。若要关闭 MSAA,则可以设置scene.msaaSamples = 1。但是通过比较,发现并没有多大改善。

poj 1127 线段相交的判定

题意: 有n根木棍,每根的端点坐标分别是 px, py, qx, qy。 判断每对木棍是否相连,当他们之间有公共点时,就认为他们相连。 并且通过相连的木棍相连的木棍也是相连的。 解析: 线段相交的判定。 首先,模板中的线段相交是不判端点的,所以要加一个端点在直线上的判定; 然后,端点在直线上的判定这个函数是不判定两个端点是同一个端点的情况的,所以要加是否端点相等的判断。 最后

HDU4737线段树

题目大意:给定一系列数,F(i,j)表示对从ai到aj连续求或运算,(i<=j)求F(i,j)<=m的总数。 const int Max_N = 100008 ;int sum[Max_N<<2] , x[Max_N] ;int n , m ;void push_up(int t){sum[t] = sum[t<<1] | sum[t<<1|1] ;}void upd

zoj 1721 判断2条线段(完全)相交

给出起点,终点,与一些障碍线段。 求起点到终点的最短路。 枚举2点的距离,然后最短路。 2点可达条件:没有线段与这2点所构成的线段(完全)相交。 const double eps = 1e-8 ;double add(double x , double y){if(fabs(x+y) < eps*(fabs(x) + fabs(y))) return 0 ;return x + y ;