本文主要是介绍poj3254 Corn Fields 状压dp,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Language: Corn Fields
Description Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant. Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant. Input Line 1: Two space-separated integers: M and N Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile) Output Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000. Sample Input 2 3 1 1 1 0 1 0 Sample Output 9 Hint Number the squares as follows: 1 2 34 There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9. Source USACO 2006 November Gold |
题意:给定一个m*n的0、1矩阵,1表示可放置,0表示不可放置,问有多少种放置方法而相邻可放置位置不能同时放。
思路:很明显的状压dp,由于相邻可放置位置不能同时放,所以首先将一行1<<n种状态中的可行状态存储在s数组中,然后根据每层与其上一层的关系地推。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=15;
const int M=600+100;
const int mod=1000000000;
int n,m,cnt;
int cur[M],s[M],dp[MAXN][M];
void init()
{cnt=0;memset(cur,0,sizeof(cur));memset(dp,0,sizeof(dp));for(int i=0;i<(1<<n);i++)if(i&(i<<1))continue;elses[++cnt]=i; //
}
inline bool ok(int x,int k)
{if(x & cur[k])return 0;return 1;
}
int main()
{//freopen("text.txt","r",stdin);while(~scanf("%d%d",&m,&n)){init();for(int i=1;i<=m;i++){cur[i]=0;for(int j=1;j<=n;j++){int x;scanf("%d",&x);if(!x)cur[i]+=(1<<(n-j));}}for(int i=1;i<=cnt;i++)if(ok(s[i],1))dp[1][i]=1;for(int i=2;i<=m;i++)for(int k=1;k<=cnt;k++){if(!ok(s[k],i))continue;for(int j=1;j<=cnt;j++){if(!ok(s[j],i-1))continue;if(s[k] & s[j])continue;dp[i][k]=(dp[i][k]+dp[i-1][j])%mod;}}int ans=0;for(int i=1;i<=cnt;i++)ans=(ans+dp[m][i])%mod;printf("%d\n",ans);}return 0;
}
这篇关于poj3254 Corn Fields 状压dp的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!