本文主要是介绍贪心法 部分背包问题 结构体数组 FatMouse' Trade,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
FatMouse’ Trade
题目:FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.333
31.500
题目大意是用f交换j,可以不用全部交换,按f%a和j%a来交换,其中每个房间的交换汇率不一样。思路大概是用一个结构体储存j,f,汇率,当然,也可以用三个数组来储存,这样的话在对汇率进行排序时就要将j,f交换到相应的位置。
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn =1024;
struct data
{
int j,f;
double rate;
}room[maxn];
bool operator <(const data&a,const data&b)
{
return a.rate<b.rate;}int main()
{
int m,n;while(~scanf("%d%d",&m,&n),m!=-1&&n!=-1)
{
for(int i=0;i<n;i++){scanf("%d%d",&room[i].j,&room[i].f);room[i].rate=(double)room[i].j/(double)room[i].f;
}
double obtain=0;
sort(room,room+n);
for(int i=n-1;i>=0&&m>=0;i--)
{if(m==0)break;else if(room[i].f<=m){obtain+=room[i].j;m-=room[i].f;}else{obtain+=m*room[i].rate;m=0;}}printf("%.3lf\n",obtain);}}
这篇关于贪心法 部分背包问题 结构体数组 FatMouse' Trade的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!