本文主要是介绍【GDOI2018模拟8.7】图的异或,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description
Input
Output
输出文件名为xor.out。
输出一个整数,表示答案。
Sample Input
输入1:
4 7
3 1 128
3 4 1184
2 2 1152
3 1 1248
4 1 0
4 3 1184
1 1 224
4 1
输入2:
8 15
8 4 146371386014040064
6 1 144119604376436736
8 1 1073872896
4 4 720580494187561216
3 7 146367143582498816
4 6 2256215051010304
1 5 4416377782272
4 5 578712570379239680
6 2 4416367362048
6 2 144119603369443328
7 8 146371404189794304
6 4 18331336704
2 7 720580339577258240
6 5 4399122808832
6 8 144115326597071104
4 3
Sample Output
输出1:
4992
输出2:
638472881
Code
首先我们知道,如果没有环,那么能异或到答案的结果只有S到T路径上的
建出dfs树,可以通过返祖边快速找到简单环,将简单环上的边的异或加入线性基中
如何统计答案?
按位考虑
对于每一位只要线性基中至少有一个数这位为1,那么异或出的所有结果,这一位必定一半是0,一半是1
设线性基大小为tot,那么这一位对答案的贡献为2^tot-1
如果线性基中没有这一位,而S到T的路径异或值的这一位为1,那么异或出的所有结果再异或S到T路径,这一位一定是1,对答案贡献为2^tot
至于线性基是什么,不知道的直接去百度搜索,一堆很好的解释和介绍
Code
#include<cstdio>
#include<algorithm>
#include<cstring>
#define fo(i,a,b) for(ll i=a;i<=b;i++)
#define fd(i,a,b) for(ll i=a;i>=b;i--)
#define mo 1000000007
#define N 101000
#define ll long long
using namespace std;
int n,m,last[N],next[N*10],to[N*10],S,T,tot=1,bz[N],bb[N*10];
ll date[N*10],ans=0,e[N],a[N],b[N];
void putin(int x,int y,ll z)
{next[++tot]=last[x];last[x]=tot;to[tot]=y;date[tot]=z;
}
void ins(ll x)
{fd(j,63,0)if(x&e[j]){if(a[j]==0) {a[j]=x;tot++;break;}x^=a[j];}
}
void dg(int x)
{bz[x]=1;for(int i=last[x];i;i=next[i]){if(bz[to[i]]&&!bb[i]) ins(b[x]^date[i]^b[to[i]]);//bb[i]=bb[i^1]=1;if(bz[to[i]]) continue;b[to[i]]=b[x]^date[i];dg(to[i]);}
}
int main()
{freopen("xor.in","r",stdin);freopen("xor.out","w",stdout);scanf("%d%d",&n,&m);e[0]=1;fo(i,1,63) e[i]=e[i-1]*2;fo(i,1,m){int x,y;ll z;scanf("%d%d%lld",&x,&y,&z);putin(x,y,z);putin(y,x,z);}scanf("%d%d",&S,&T);tot=0;dg(S);ll jy=0;fo(i,0,63) jy|=a[i];fo(i,0,63) if(jy&e[i]) (ans+=(e[tot-1]%mo*(e[i]%mo))%mo)%=mo;else if(b[T]&e[i]) (ans+=(e[tot]%mo*(e[i]%mo))%mo)%=mo;printf("%lld",ans);
}
这篇关于【GDOI2018模拟8.7】图的异或的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!