本文主要是介绍图(最小生成树) MST 2,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
/*题目1144:Freckles 克鲁斯卡尔
题目描述:
In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad's back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley's engagement falls through.
Consider Dick's back to be a plane with freckles at various (x,y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
输入:
The first line contains 0 < n <= 100, the number of freckles on Dick's back. For each freckle, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the freckle.
输出:
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
样例输入:
3
1.0 1.0
2.0 2.0
2.0 4.0
样例输出:
3.41
*/
#include <stdio.h>
#include <math.h>
#include <algorithm>
using namespace std;
#define N 101
int tree[N];
int findroot(int x){
if(tree[x] == -1) return x;
else{
int tmp = findroot(tree[x]);
tree[x] = tmp;
return tmp;
}
}
struct edge{
int a,b;
double cost;//权值变为长度,固改用浮点数
bool operator < (const edge &A) const{
return cost < A.cost;
}
}edge[6000];
struct point{//点结构体
double x,y;//点的两个坐标值
double getdistance(point A){//计算点之间的距离
double tmp = (x-A.x)*(x-A.x) + (y-A.y)*(y-A.y);
return sqrt(tmp);
}
}list[101];
int main(){
int n,i,j;
while(scanf("%d",&n) != EOF){
for(i=1;i<=n;i++){
scanf("%lf%lf",&list[i].x,&list[i].y);
}//输入
int size = 0;//抽象出的边的总数
for(i=1;i<=n;i++){
for(j=i+1;j<=n;j++){//连接两点的线段抽象成边
edge[size].a = i;
edge[size].b = j;//该边的两个顶点编号
edge[size].cost = list[i].getdistance(list[j]);
//边权值为两点之间的长度
size++;//边的总数增加
}//遍历所有的点对
}
sort(edge,edge+size);//对边按权值递增排序
for(i=1;i<=n;i++){
tree[i] = -1;
}
double ans = 0;
for(i=0;i<size;i++){
int a = findroot(edge[i].a);
int b = findroot(edge[i].b);
if(a != b){
tree[a] = b;
ans += edge[i].cost;
}
}//最小生成树
printf("%.2lf\n",ans);//输出
}
return 0;
}
这篇关于图(最小生成树) MST 2的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!