本文主要是介绍2013 - ECJTU 暑期训练赛第三场-problem-H,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0
9
999999999
1000000000
-1
Sample Output
0
34
626
6875
矩阵连乘加上快速二分幂
AC代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
void js(int (*a)[2],int (*c)[2])
{
int b[2][2];
b[0][0]=(a[0][0]*c[0][0]+a[0][1]*c[1][0])%10000;
b[0][1]=(a[0][0]*c[0][1]+a[0][1]*c[1][1])%10000;
b[1][0]=(a[1][0]*c[0][0]+a[1][1]*c[1][0])%10000;
b[1][1]=(a[1][0]*c[0][1]+a[1][1]*c[1][1])%10000;
a[0][0]=b[0][0];
a[0][1]=b[0][1];
a[1][0]=b[1][0];
a[1][1]=b[1][1];
}
int main()
{
int a[2][2],b[2][2];
int n;
while(scanf("%d",&n),n>=0)
{
if(n==0)
{printf("0\n");
continue;}
a[0][0]=1;
a[0][1]=1;
a[1][0]=1;
a[1][1]=0;
b[0][0]=1;
b[0][1]=0;
b[1][0]=0;
b[1][1]=1;
for(;n>0;n=n>>1,js(a,a))
if(n&1) js(b,a);
printf("%d\n",b[0][1]);
}
return 0;
}
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
.
这篇关于2013 - ECJTU 暑期训练赛第三场-problem-H的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!