数组重载加减

2024-05-06 03:32
文章标签 数组 重载 加减

本文主要是介绍数组重载加减,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

题目:

数组重载加减

Time/Memory Limit:1000 MS/32768 K
Submitted: 38 Accepted: 22

Problem Description

定义一个shuzu类,编写一个程序,含有默认构造函数(将数组每个元素初始为0),构造函数,用成员函数运算符重载“+”和“-”,实现将两个一维数组相加和相减。

Input

第一行输入一个数t,代表t组测试数据,每组数据先输入一个整数N(0<N<=100)代表两个数组的长度,接着依次输入两个数组。

Output

每组输出占两行,分别为两个数组加减后的结果。(减法默认第一个数组的每个元素为被减数)每个数后面带一个空格。

Sample Input

2
2
5 6
3 2
3
1 2 3
3 2 1

Sample Output

8 8 
2 4 
4 4 4 
-2 0 2 

参考代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
class Matrix
{
private:
int num, array[200];
public:
Matrix();
Matrix(int n, int a[200]);
Matrix(Matrix&);
Matrix operator+(const Matrix&);
Matrix operator-(const Matrix&);
void show();
};
Matrix::Matrix()
{
num = 0;
for (int i = 0; i < num; i++)
array[i] = 0;
}
Matrix::Matrix(int n, int* a)
{
num = n;
for (int i = 0; i < num; i++)
array[i] = a[i];
}
Matrix::Matrix(Matrix& c)
{
num = c.num;
for (int i = 0; i < c.num; i++)
array[i] = c.array[i];
}
Matrix Matrix::operator+(const Matrix& c)
{
Matrix x;
x.num = c.num;
for (int i = 0; i < num; i++)
x.array[i] = array[i] + c.array[i];
return x;
}
Matrix Matrix::operator-(const Matrix& c)
{
Matrix x;
x.num = c.num;
for (int i = 0; i < num; i++)
x.array[i] = array[i] - c.array[i];
return x;
}
void Matrix::show()
{
int i, k = 0;
for (i = 0; i < num; i++) {
cout << array[k++]<<" ";
}
cout << endl;
}
int main()
{
//freopen("1.txt", "r", stdin);
int  t, i, j, n, a[200], b[200];
while (cin >> t) {
while (cin >> n) {
for (i = 0; i < n; i++)
cin >> a[i];
for (j = 0; j < n; j++)
cin >> b[j];
Matrix x(n, a), y(n, b), z, w;
z = x + y;
z.show();
w = x - y;
w.show();
}
}
return 0;
}

 

这篇关于数组重载加减的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/963336

相关文章

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

hdu 1166 敌兵布阵(树状数组 or 线段树)

题意是求一个线段的和,在线段上可以进行加减的修改。 树状数组的模板题。 代码: #include <stdio.h>#include <string.h>const int maxn = 50000 + 1;int c[maxn];int n;int lowbit(int x){return x & -x;}void add(int x, int num){while

C++操作符重载实例(独立函数)

C++操作符重载实例,我们把坐标值CVector的加法进行重载,计算c3=c1+c2时,也就是计算x3=x1+x2,y3=y1+y2,今天我们以独立函数的方式重载操作符+(加号),以下是C++代码: c1802.cpp源代码: D:\YcjWork\CppTour>vim c1802.cpp #include <iostream>using namespace std;/*** 以独立函数

C语言:柔性数组

数组定义 柔性数组 err int arr[0] = {0}; // ERROR 柔性数组 // 常见struct Test{int len;char arr[1024];} // 柔性数组struct Test{int len;char arr[0];}struct Test *t;t = malloc(sizeof(Test) + 11);strcpy(t->arr,

C 语言基础之数组

文章目录 什么是数组数组变量的声明多维数组 什么是数组 数组,顾名思义,就是一组数。 假如班上有 30 个同学,让你编程统计每个人的分数,求最高分、最低分、平均分等。如果不知道数组,你只能这样写代码: int ZhangSan_score = 95;int LiSi_score = 90;......int LiuDong_score = 100;int Zhou

计算数组的斜率,偏移,R2

模拟Excel中的R2的计算。         public bool fnCheckRear_R2(List<double[]> lRear, int iMinRear, int iMaxRear, ref double dR2)         {             bool bResult = true;             int n = 0;             dou

C# double[] 和Matlab数组MWArray[]转换

C# double[] 转换成MWArray[], 直接赋值就行             MWNumericArray[] ma = new MWNumericArray[4];             double[] dT = new double[] { 0 };             double[] dT1 = new double[] { 0,2 };

PHP7扩展开发之数组处理

前言 这次,我们将演示如何在PHP扩展中如何对数组进行处理。要实现的PHP代码如下: <?phpfunction array_concat ($arr, $prefix) {foreach($arr as $key => $val) {if (isset($prefix[$key]) && is_string($val) && is_string($prefix[$key])) {$arr[

Go 数组赋值问题

package mainimport "fmt"type Student struct {Name stringAge int}func main() {data := make(map[string]*Student)list := []Student{{Name:"a",Age:1},{Name:"b",Age:2},{Name:"c",Age:3},}// 错误 都指向了最后一个v// a

第二十四章 rust中的运算符重载

注意 本系列文章已升级、转移至我的自建站点中,本章原文为:rust中的运算符重载 目录 注意一、前言二、基本使用三、常用运算符四、通用约束 一、前言 C/C++中有运算符重载这一概念,它的目的是让即使含不相干的内容也能通过我们自定义的方法进行运算符操作运算。 比如字符串本身是不能相加的,但由于C++中的String重载了运算符+,所以我们就可以将两个字符串进行相加、但实际