本文主要是介绍统计学生人数和成绩(静态),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目:
统计学生人数和成绩
Problem Description
定义一个Student类记录学生的学号和C++课程的成绩。要求使用静态成员变量和静态成员函数计算全班学生C++课程的总成绩和平均成绩。
Input
输入每个学生的学号和成绩,每个学生的信息占一行,直到文件结束。
Output
输出包括两行,第一行全班人数和总成绩,用空格隔开;
第二行平均成绩。
第二行平均成绩。
Sample Input
101 30
102 50
103 90
104 60
105 70
Sample Output
5 300
60
参考代码:
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
class Student
{
private:
int id, score;
static int count;
static int sum;
public:
Student(int i, int s);
Student(const Student&);
~Student();
static void show();
};
Student::Student(int i, int s)
{
id = i;
score = s;
count++;
sum += score;
}
Student::Student(const Student& c)
{
id = c.id;
score = c.score;
}
Student::~Student()
{
}
void Student::show()
{
cout << count << " " << sum << endl;
cout << (double)(1.0 * sum / count) << endl;
}
int Student::count = 0;
int Student::sum = 0;
int main()
{
//freopen("1.txt", "r", stdin);
int id, score;
while (cin >> id >> score)
Student x(id, score);
Student::show();
return 0;
}
这篇关于统计学生人数和成绩(静态)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!