本文主要是介绍hdu 1710 Binary Tree Traversals,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接:点击打开链接
Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.
In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.
In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1
<span style="font-size:24px;">#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>using namespace std;
struct node
{int data;struct node *l,*r;
};
struct node *creat(int a[],int b[],int n)
{if(n<=0)return NULL;struct node *root;root=new node;root->l=NULL;root->r=NULL;root->data=a[0];int i;for(i=0;i<n;i++){if(a[0]==b[i])break;}int k=i;root->l=creat(a+1,b,k);root->r=creat(a+1+k,b+1+k,n-1-k);return root;
}
int f=1;
void past(struct node *root)
{if(root!=NULL){past(root->l);past(root->r);if(f==1){printf("%d",root->data);f=0;}else printf(" %d",root->data);}return ;
}
int main()
{int a[1005],b[1005];int n;while(cin>>n){for(int i=0;i<n;i++){cin>>a[i];}for(int i=0;i<n;i++){cin>>b[i];}struct node *root;root=new node;root=creat(a,b,n);f=1;past(root);printf("\n");}return 0;
}
</span>
这篇关于hdu 1710 Binary Tree Traversals的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!