本文主要是介绍poj 2255 Tree Recovery(二叉树),希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
题目链接:点击打开链接
Description
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
This is an example of one of her creations:
D/ \/ \B E/ \ \/ \ \A C G//F
To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB
<span style="font-size:24px;">#include <iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>using namespace std;
struct node
{char data;struct node *l,*r;
};
struct node *creat(char *pre,char *in,int len)
{if(len<=0) return NULL;struct node *root;root=new node;root->l=NULL;root->r=NULL;root->data=*pre;char *p;for(p=in;*p!='\0';p++){if(*p==*pre)break;}int k=p-in;root->l=creat(pre+1,in,k);root->r=creat(pre+1+k,in+k+1,len-1-k);return root;
}
void past(struct node *root)
{if(root!=NULL){past(root->l);past(root->r);printf("%c",root->data);}return ;
}
int main()
{char pre[30],in[30];while(cin>>pre>>in){struct node *root;root=new node;int len=strlen(pre);root=creat(pre,in,len);past(root);printf("\n");}return 0;
}
</span>
这篇关于poj 2255 Tree Recovery(二叉树)的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!