本文主要是介绍poj1065 贪心,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
如题:http://poj.org/problem?id=1065
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 19547 | Accepted: 8246 |
Description
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
Output
Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
Sample Output
2 1 3
Source
思路:看完这一题其实最先想起的那道蓝桥里见过的拦截导弹问题,两者很相似,都是关于最长不下降子序列的个数。但是区别在于这一题可以任意排序而不影响结果,而拦截导弹,导弹是按照顺序发射,不能去排序,只能dp。
贪心:将序列按l升序排序,当l相等时,按w排序。每次取尽量多的上升序列,直到所有序列中的值被取完。
对于任意的(l1,w1)....(l2,w2).......(l3,w3).因为排序,有l1<=l2<=l3.因此若w1<=w2<=w3,则3个全取,以(l1,w1)开头的这个序列必然是最长的。
当w1>w2,w3>w1.有w3>w1>w2,序列可以为(l1,w1)和(l3,w1)一组也可以是(l2,w2)和(l3,w3)一组,而其中不管哪一组包含(l3,w3),往后都会有根据l1=l3,w1=w3,继续向后推的情况。w1>w2,如果(l2,w2)和(l3,w3)一组,剩下的一组最后一个是(l1,w1),后续如果存在w2<w<w1,则w无法被分到w2的那一组,不是最优,因此(l1,w1)和(l3,w3)一组,而小的w2作为另一组的最后一个元素,继续贪心,最终序列最长,结果最优。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef pair<int,int>P;
#define MAXN 5005
P a[MAXN];
int vis[MAXN];
bool operator<(P a,P b)
{
if(a.first!=b.first)
return a.first<b.first;
return a.second<b.second;
}
int main()
{
// freopen("C:\\1.txt","r",stdin);
int t;
cin>>t;
while(t--)
{
memset(vis,0,sizeof(vis));
int n;
cin>>n;
int i,j;
for(i=0;i<n;i++)
{
int l,w;
cin>>l>>w;
a[i].first=l;
a[i].second=w;
}
sort(a,a+n);
int res=0;
for(j=0;j<n;j++)
{
if(!vis[j])
{
int now=j;
vis[now]=1;
for(i=1;i<n;i++)
{
if(!vis[i]&&a[i].second>=a[now].second)
{
vis[i]=1;
now=i;
}
}
res++;
}
}
cout<<res<<endl;
}
return 0;
}
这篇关于poj1065 贪心的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!