poj 2887 块状数组

2024-04-20 05:58
文章标签 数组 poj 块状 2887

本文主要是介绍poj 2887 块状数组,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!

Big String
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 7116 Accepted: 1701

Description

You are given a string and supposed to do some string manipulations(操纵).

Input

The first line of the input(投入) contains the initial string. You canassume(承担) that it is non-empty and its length does notexceed(超过) 1,000,000.

The second line contains the number of manipulation commands N (0 < N 2,000). The following N lines describe a command each. The commands are in one of the two formats below:

  1. I ch p: Insert a character ch before the p-th character of the current string. Ifp is larger than the length of the string, the character is appended(附加) to the end of the string.
  2. Q p: Query the p-th character of the current string. The input(投入) ensures(保证) that thep-th character exists.

All characters in the input(投入) aredigits(数字) orlowercase(小写字母) letters of the Englishalphabet(字母表).

Output

For each Q command output(输出) one line containing only the single character queried.

Sample Input

题意 :

有一串字符串 需要进行一些操作  ;当输入Q i时  将第i个字符输出

当输入  I  ch i  时 将第 i个字符前添加一个字符ch;

这道题 本来想用  线段树来做的  后来感觉 块状数组更简单一些。

ab
7
Q 1
I c 2
I d 4
I e 2
Q 5
I f 1
Q 3

Sample Output

a
d
e
#include<string.h>
#include<stdio.h>
#include<algorithm>
#define maxn 1001
#define maxl 2000005
#define N 1001
using namespace std;
char c[maxn*maxn];
char a[maxn][maxn*3];
int len[N];
int alen;
char query(int k){int cou=0;for(int i=0;i<alen;i++){if(k<=cou+len[i]){return a[i][k-cou-1];}cou+=len[i];}
}
void add(int k,char ch){int cou=0;int r;for(int i=0;i<alen;i++){if(k<=cou+len[i]){r=i;break;}if(i==alen-1){r=alen-1;break;}cou+=len[i]; }int pos=k-cou-1;if(pos>=len[r])pos=len[r];for(int i=len[r];i>pos;i--){a[r][i]=a[r][i-1];}a[r][pos]=ch;len[r]++;}int main(){while(~scanf("%s",c)){int  slen=strlen(c);int along;memset(len,0,sizeof(len));along=(slen+999)/1000;alen=(slen+along-1)/along;for(int i=0;i<alen;i++)len[i]=along;for(int i=0;i<slen;i++){a[i/along][i%along]=c[i];}len[alen-1]=(slen-1)%along+1;int n;scanf("%d",&n);while(n--){char op[3];int k;scanf("%s",op);if(op[0]=='Q'){scanf("%d",&k);printf("%c\n",query(k));} else{scanf("%s %d", op, &k); add(k,op[0]);}}
}
return 0;
}


这篇关于poj 2887 块状数组的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!



http://www.chinasem.cn/article/919444

相关文章

JAVA中整型数组、字符串数组、整型数和字符串 的创建与转换的方法

《JAVA中整型数组、字符串数组、整型数和字符串的创建与转换的方法》本文介绍了Java中字符串、字符数组和整型数组的创建方法,以及它们之间的转换方法,还详细讲解了字符串中的一些常用方法,如index... 目录一、字符串、字符数组和整型数组的创建1、字符串的创建方法1.1 通过引用字符数组来创建字符串1.2

vue如何监听对象或者数组某个属性的变化详解

《vue如何监听对象或者数组某个属性的变化详解》这篇文章主要给大家介绍了关于vue如何监听对象或者数组某个属性的变化,在Vue.js中可以通过watch监听属性变化并动态修改其他属性的值,watch通... 目录前言用watch监听深度监听使用计算属性watch和计算属性的区别在vue 3中使用watchE

hdu2241(二分+合并数组)

题意:判断是否存在a+b+c = x,a,b,c分别属于集合A,B,C 如果用暴力会超时,所以这里用到了数组合并,将b,c数组合并成d,d数组存的是b,c数组元素的和,然后对d数组进行二分就可以了 代码如下(附注释): #include<iostream>#include<algorithm>#include<cstring>#include<stack>#include<que

poj 3974 and hdu 3068 最长回文串的O(n)解法(Manacher算法)

求一段字符串中的最长回文串。 因为数据量比较大,用原来的O(n^2)会爆。 小白上的O(n^2)解法代码:TLE啦~ #include<stdio.h>#include<string.h>const int Maxn = 1000000;char s[Maxn];int main(){char e[] = {"END"};while(scanf("%s", s) != EO

hdu 2602 and poj 3624(01背包)

01背包的模板题。 hdu2602代码: #include<stdio.h>#include<string.h>const int MaxN = 1001;int max(int a, int b){return a > b ? a : b;}int w[MaxN];int v[MaxN];int dp[MaxN];int main(){int T;int N, V;s

poj 1511 Invitation Cards(spfa最短路)

题意是给你点与点之间的距离,求来回到点1的最短路中的边权和。 因为边很大,不能用原来的dijkstra什么的,所以用spfa来做。并且注意要用long long int 来存储。 稍微改了一下学长的模板。 stack stl 实现代码: #include<stdio.h>#include<stack>using namespace std;const int M

poj 3259 uva 558 Wormholes(bellman最短路负权回路判断)

poj 3259: 题意:John的农场里n块地,m条路连接两块地,w个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。 任务是求你会不会在从某块地出发后又回来,看到了离开之前的自己。 判断树中是否存在负权回路就ok了。 bellman代码: #include<stdio.h>const int MaxN = 501;//农场数const int

poj 1258 Agri-Net(最小生成树模板代码)

感觉用这题来当模板更适合。 题意就是给你邻接矩阵求最小生成树啦。~ prim代码:效率很高。172k...0ms。 #include<stdio.h>#include<algorithm>using namespace std;const int MaxN = 101;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int n

poj 1287 Networking(prim or kruscal最小生成树)

题意给你点与点间距离,求最小生成树。 注意点是,两点之间可能有不同的路,输入的时候选择最小的,和之前有道最短路WA的题目类似。 prim代码: #include<stdio.h>const int MaxN = 51;const int INF = 0x3f3f3f3f;int g[MaxN][MaxN];int P;int prim(){bool vis[MaxN];

poj 2349 Arctic Network uva 10369(prim or kruscal最小生成树)

题目很麻烦,因为不熟悉最小生成树的算法调试了好久。 感觉网上的题目解释都没说得很清楚,不适合新手。自己写一个。 题意:给你点的坐标,然后两点间可以有两种方式来通信:第一种是卫星通信,第二种是无线电通信。 卫星通信:任何两个有卫星频道的点间都可以直接建立连接,与点间的距离无关; 无线电通信:两个点之间的距离不能超过D,无线电收发器的功率越大,D越大,越昂贵。 计算无线电收发器D