本文主要是介绍Eight HDU-1043,希望对大家解决编程问题提供一定的参考价值,需要的开发者们随着小编来一起学习吧!
The 15-puzzle has been around for over 100 years; even if you don’t know it by that name, you’ve seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let’s call the missing tile ‘x’; the object of the puzzle is to arrange the tiles so that they are ordered as:
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange ‘x’ with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the ‘x’ tile is swapped with the ‘x’ tile at each step; legal values are ‘r’,‘l’,‘u’ and ‘d’, for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing ‘x’ tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus ‘x’. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable’’, if the puzzle has no solution, or a string consisting entirely of the letters ‘r’, ‘l’, ‘u’ and ‘d’ that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
2 3 4 1 5 x 7 6 8
Sample Output
ullddrurdllurdruldr
题意: 3*3的方格输入9个字符,其中8个数字从1到8和一个字符x,x可以上下左右移动,并和移动后的数字交换位置,当数字变成从小到大排序时停止,输出x走的路径。
思路: 逆向打表,把每一种情况考虑一遍进行打表。
代码:
#include<stdio.h>
#include<string>
#include<iostream>
#include<string.h>
#include<map>
#include<queue>
#include<algorithm>
using namespace std;
int d[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
map<int,int>u;
map<int,string>v;
struct node
{string t;int s[3][3];int x,y;
};
void bfs()
{queue<node>Q;node now,next;int sum=1;for(int i=0;i<3;i++)for(int j=0;j<3;j++)now.s[i][j]=sum++;now.s[2][2]=0;now.x=2;now.y=2;u[123456780]=1;Q.push(now);while(!Q.empty()){now=Q.front();Q.pop();for(int i=0;i<4;i++){int tx=now.x+d[i][0];int ty=now.y+d[i][1];if(tx<0||ty<0||tx>=3||ty>=3)continue;for(int j=0;j<3;j++)for(int k=0;k<3;k++)next.s[j][k]=now.s[j][k];swap(next.s[now.x][now.y],next.s[tx][ty]);int sum=1;for(int j=0;j<3;j++)for(int k=0;k<3;k++)sum=sum*10+next.s[j][k];//用sum代表当前序列的顺序if(u[sum])//走过就不再走continue;u[sum]=1;next.x=tx;next.y=ty;if(i==0)//走的方向next.t=now.t+'l';if(i==1)next.t=now.t+'u';if(i==2)next.t=now.t+'r';if(i==3)next.t=now.t+'d';Q.push(next);v[sum]=next.t;//v数组存x走的路径}}
}
int main()
{char str[50];bfs();while(gets(str)){int sum=1;int len=strlen(str);for(int i=0;i<len;i++){if(str[i]>='1'&&str[i]<='9')sum=sum*10+str[i]-'0';if(str[i]=='x')sum=sum*10; }if(!u[sum]){printf("unsolvable\n");continue;}string s=v[sum];len=s.size();for(int i=len-1;i>=0;i--)printf("%c",s[i]);printf("\n");}return 0;
}
这篇关于Eight HDU-1043的文章就介绍到这儿,希望我们推荐的文章对编程师们有所帮助!